Jump to content

Recommended Posts

Mue, when making a new LodViewer, please consider to add the weapons, pilot and brightness views. Thanks!:clapping:

Share this post


Link to post
Share on other sites

On 25/8/2021 at 8:30 AM, mue said:

But right now I hope (again) the first release will be "ready in two weeks"(TM).

TODEditor WIP screenshot:

TODEditor.thumb.jpg.2e16222ef8acae6a2ade20ffc14f30ee.jpg

Two weeks... :bye:

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
2 hours ago, Stratos said:

Two weeks... :bye:

Outstanding can't wait :pope: :pilotfly:

Edited by GKABS

Share this post


Link to post
Share on other sites

Lol, I was remembering Mue about the program, not saying that will be relased in two weeks!

  • Haha 1

Share this post


Link to post
Share on other sites
On 8/24/2021 at 11:30 PM, mue said:

Wow, thank you all for the praise. It means a lot to me. Really!

I still have plans to update the tools: TargetAreaEditor, LODViewer and LODExporter.
And first and foremost I want to eventually release a first version of the TODEditor! I know I promised the TODEditor since by now more than 5 years(!):blush:. And three months ago I thought the first version will be "ready in two weeks"(TM). But than again RL stuff, vacation, etc. ... happened, and I haven't worked much on it since then.
But right now I hope (again) the first release will be "ready in two weeks"(TM).

TODEditor WIP screenshot:

TODEditor.thumb.jpg.2e16222ef8acae6a2ade20ffc14f30ee.jpg

This opens up a whole new world. Think of the realistic cities that could be created with countless different styles of buildings.

 

  • Like 1

Share this post


Link to post
Share on other sites
On 25/8/2021 at 8:30 AM, mue said:

Wow, thank you all for the praise. It means a lot to me. Really!

I still have plans to update the tools: TargetAreaEditor, LODViewer and LODExporter.
And first and foremost I want to eventually release a first version of the TODEditor! I know I promised the TODEditor since by now more than 5 years(!):blush:. And three months ago I thought the first version will be "ready in two weeks"(TM). But than again RL stuff, vacation, etc. ... happened, and I haven't worked much on it since then.
But right now I hope (again) the first release will be "ready in two weeks"(TM).

TODEditor WIP screenshot:

 

Any update Mue? I have a jungle to populate!

  • Haha 2

Share this post


Link to post
Share on other sites

He hasn't been around since late August, hope he's doing fine, some months have passed. 

  • Like 1

Share this post


Link to post
Share on other sites

Hopefully he is just busy with real life work.  Hope to hear from him soon.

  • Like 1

Share this post


Link to post
Share on other sites

Hi all,
I'm OK. But as GKABS correctly assumed, I was and still am very busy with real life work. And now even more so. In september we had a sudden change at work that eventually increased my workload again.
So, SF2 modding is still on a back burner :sad:.

  • Like 2
  • Thanks 9

Share this post


Link to post
Share on other sites

Hey Andy,

thats bad...sorry to hear that. But good to see, that you're fine. :good:

I hope you're get some free days around X-mas. :drinks:

  • Like 3

Share this post


Link to post
Share on other sites

I was a bit scared after so many weeks without login! good to see you're doing fine!

  • Like 1

Share this post


Link to post
Share on other sites

Was looking at this pic by Dunois with SF2 planes and WT terrain, and I believe we can get a lot better terrain representation once Mue release his tool, trees flanking rural roads, more trees on forests, better city representations! Can't wait.

 

large.61c031cf99dec_F104004.jpg.79e4ca879a565c334749bd7b0784c187.jpg

  • Like 4

Share this post


Link to post
Share on other sites

in that pic, life is good.....

but yes it could be better :lol:

and in a shameless plug, someone needs to get the  KC-135 skinpack number 2. proper SAC/Wing badges and no tail checkerboard  like it was back then.......

  • Haha 2

Share this post


Link to post
Share on other sites

I have a question to the TOD Editor.

img00109.thumb.JPG.9ea4422d7ecfd6a37887d68085386517.JPG

I added LOD buildings to the editor, then i placed them on the tile. It works fine. My problem is, that the LOD buildings do not draw their skin from jpg file which is originaly linked with the LOD but from terobject file which is connected with the tileset.

The result you see in the screenshot above.

Any idea, somebody?

 

 

Share this post


Link to post
Share on other sites

Mue will be able to answer this definitively, but my guess is that each tile can only have one texture for its TOD objects, which is defined by the line SolidObjectTexture=, an example being:

[Texture001]
Filename=germanyG1.BMP
HasWater=0
Color=0.315639,0.372233,0.266439
SolidObjectTexture=terobject_buildings1.bmp
AlphaObjectTexture=terobject_trees1.tga

 

It would be good to be able to add LOD objects which used their own texture files. Hopefully Mue can explain.

 

  • Like 1

Share this post


Link to post
Share on other sites

Thx, i will try it.

Share this post


Link to post
Share on other sites

I have been playing around with this new TOD Editor, moving some of the TOD objects around to conform better with the roads and things painted on the tiles themselves. It is a tedious tile-by-tile business, but the result looks much more pleasing from the air. This is great new tool from Mue!  :good:

 

Gepard: you are one step ahead of me. I haven't worked out how to add LOD buildings to a TOD file. I see the option in the drop-down menu, but haven't worked out how to make it work yet. :smile:

  • Like 1

Share this post


Link to post
Share on other sites

Yes. The editing of the line in the data.ini was successfull. The LOD building now has the intended skin. Thanks.

But there is a new problem:

img00110.thumb.JPG.6a2266e1fb972d884004a539c254f83b.JPG

Theposition of the skin on the LOD object is wrong. Looks funny, isnt it!

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Hmm...  those buildings do look a bit funny. Mue will have to tell us how to paint the LODs which are now TOD objects.

Also, those square things next to the houses, which I assume are trees, look very odd. I think you will need to tweak the line AlphaObjectTexture= 

 

 

Share this post


Link to post
Share on other sites
3 hours ago, Gatling20 said:

Mue will be able to answer this definitively, but my guess is that each tile can only have one texture for its TOD objects, which is defined by the line SolidObjectTexture=, an example being:

[Texture001]
Filename=germanyG1.BMP
HasWater=0
Color=0.315639,0.372233,0.266439
SolidObjectTexture=terobject_buildings1.bmp
AlphaObjectTexture=terobject_trees1.tga

 

It would be good to be able to add LOD objects which used their own texture files. Hopefully Mue can explain.

 

Yes, you are correct. The solid TOD objects of a tile share the same texture (atlas) defined by SolidObjectTexture (and respectively the alpha objects share the same texture defined by AlphaObjectTexture). Thats how the game engine works and there is nothing I can do about it.
That also means objects that use different texture files can not be imported and used together in a tile. The objects must be first remapped to use the same texture atlas that also has to be created.
I should update the readme.txt to clarify that restriction.

  • Thanks 1

Share this post


Link to post
Share on other sites
3 hours ago, Gepard said:

Theposition of the skin on the LOD object is wrong. Looks funny, isnt it!

 

Oops, It seems the texture coordinates are flipped vertically. I'll investigate where exactly the bug is. As a workaround I think you can flip the texture vertically.

  • Like 1
  • Thanks 2

Share this post


Link to post
Share on other sites

Thanks mue for all the hard work.

Share this post


Link to post
Share on other sites
13 hours ago, mue said:

Oops, It seems the texture coordinates are flipped vertically. I'll investigate where exactly the bug is. As a workaround I think you can flip the texture vertically.

This bug is fixed in version 0.1.1.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..