Jump to content

Recommended Posts

Hello everyone:

Here is my question over which I've been tearing my hair out all week, maybe someone here can help! 

About three years ago I was able to get Strike Fighters 2 running in VorpX and it was fluid, beautiful, and smooth, almost VR-native quality. But when I try to run it again now with my HP Reverb G2 and VorpX 21.3.0, about 49 times out of 50 SF2 will crash to desktop without warning. That 50th time it will run perfectly. I will change no settings between the running and the crashing. It's bizarre. Here's what I've tried:

1) Changing every graphics settings in the game
2) Changing each VorpX setting one by one- hook helpers, alternative hooking, etc.
3) Running SF2 as an administrator, in Win 7 compatibility mode, etc.

Nothing consistently works. It seems totally random whether it will CTD without warning or run perfectly that 2% of the time it does feel like running. I'm writing this here because I know some members like @streakeagle have had great success with VorpX and SF2 in the past. I suspect a recent update to VorpX broke compatibility with SF2 and that's the root problem, but I haven't been able to get support from VorpX (as in, they won't even respond to me) and there's no way to download older versions, so I'm stuck trying to get this one to run. 

So my question is: is anyone running SF2 in VR, today, with the current version of VorpX? Trying to figure out if it's just my system or it's this version of VorpX that's breaking it and there's nothing I can do about it. 

Also attaching my VorpX crash logs if anyone can make heads or tails of them. Now back to the troubleshooting battle, we'll see if I'm up until 2 AM again today trying to figure this out...



Share this post

Link to post
Share on other sites

It has always been a luck of the draw for me. VorpX constantly changes. Sometimes it works really well for SF2, other times it doesn't. The Reverb G2 can be used one of two ways: Steam VR or Open XR/Windows Mixed Reality. I have not run it in a while, so I am not sure if it is currently working for me. The last time I used it (months? years?), it worked really well for the G2, but I couldn't get it working at all with the Quest 2. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..