Jump to content
Warmbrak

Problems with Nato Fighters 5 Installation

Recommended Posts

I recently fired up my Strike Fighters 2 again, and discovered the awesome Nato Fighters 5 mod. I also applied the May 2013 update, and I have all the major SF2 titles as a merged install on my E: drive. I created a copy of the North Atlantic exe, ran it to created a mod folder, correctly changed the path from my Saved Games folder to the one on my E: drive and followed all the installation instructions to the tee. When I run Nato Fighters 5 after the installation, I get the NF5 menu screen, but when I try to set up a mission, my aircraft selection is limited to the default SF2 merged set only.

 

I have gone through the instructions a few times but I am pretty sure I did not miss a thing. I have recently tried out the SweetFX shader mod, and that is the only thing out of the ordinary that I can think of that is different to how I would set a mod up normally.

 

Any ideas on how to debug this will be greatly appreciated!

 

I have attached a screenshot showing my mod folder file structure.

 

Edit: I installed Operation Tainted Cigar as well, and before moving the SweetFX files into the mod folder, SF2 won't load at all. I remember now I had the same issue that NF5 would not start at all before I moved the SweetFX files to the Flight & Menu subfolders in the mod folder. I think I should remove SweetFX entirely form all folders, as this is most likely what is causing the problems.

post-17461-0-37903600-1371131859.jpg

Edited by Warmbrak

Share this post


Link to post
Share on other sites

Warmbrak:

 

First, solve one problem at a time. That means get the missing aircraft problem solved first before you try to mess around with SweetFX.

 

Second, if you're not seeing any new aircraft, then you did not  follow "all the installation instructions to the tee." The installation, in other words, is botched because the game isn't finding the new aircraft (and possibly some of the other new items from NF5) where it expects to find them.

 

I can't tell you where they are because I'm not sitting at your PC. I would recommend nosing around and finding where all the new aircraft are on your hard drive, them moving them to the proper location: \Objects\Aircraft. My guess is that they're buried in some sub-folder somewhere -- possibly \Objects\Objects\Aircraft or even \Objects\Aircraft\Aircraft.

 

The other possibility is that you dropped the new files in a mod folder that is not being used by the custom EXE that you created.

 

Wherever they are, they're not where they're supposed to be (or the game expects them to be). And the same likely holds true for the new Decals, Weapons, Guns, and Pilots as well.

 

Eric Howes

Share this post


Link to post
Share on other sites

Hi Eric,

 

Thanks for taking the time to respond. I have removed SweetFX for the moment to make sure there are no issues because of it, and I should also point out that I am using a custom location Mod folder (this worked fine for Nato Fighters 4 Plus previously). I created a copy of my SF2 North Atlantic exe, renamed it to NF5MOD, and executed this exe, producing a Mod folder under Saved Games\Thirdwire. This is however on my SSD C: drive that I prefer not to use for games. I thus edit my Options.ini in this NF5MOD folder, and under the section [Mods], I change the Directory to E:\Games\Thirdwire\NF5MOD. I execute the NF5MOD exe again, and the MOD folder is now set up in this new location.

 

In this new location, I delete the Objects folder, and copy the contents of the To_Mods_Folder into this NF5MPD folder, leaving a structure as per the screenshot from my original post. The mod aircraft is located in E:\Games\Thirdwire\NF5MOD\Objects\Aircraft, so there are definitely no double sub-folder to break the structure. I also updated the mission settings in the Options.ini.

 

When I run the NF5MOD exe, the NF5 menu screen loads and all appears fine. However, when creating a single mission, I am still stuck with the default aircraft only. I am attaching a screenshot of the top portion of my Aircraft folder that shows the Mod folder path.

 

I will try an install into the Mod folder where the Options.ini file resides and see if this fixes the problem. Could something in the latest patch have broken compatibility for custom Mod folder locations, or am I the only person to experience this issue so far?

post-17461-0-99182800-1371217902.jpg

Share this post


Link to post
Share on other sites

Excuse me for butting in, but has anyone actually managed to get the SweetFX working in SF2 games (Vista/7 DX10 mode)?

Share this post


Link to post
Share on other sites

  Warmbrak, did you delete everything in the C:\blah, blah\SavedGames\ThirdWire folder but the Options and Versions .inis? I have a setup like yours and NF5 works fine for me. The other thing off the top of my head, because I don't run the .exe a second time after changing the Directory path but copy/paste it to my F: Drive, you may have to copy/paste the Options .ini from your E: Drive back to your C:\SavedGames folder. Don't ask me why, but sometimes it matters.

Share this post


Link to post
Share on other sites

I fiddled around more, up to a point where I damaged my installation completely (in game, the sim would not take any keyboard commands, strange one).

 

So I back up pilot profiles, and reinstalled from scratch. I started with the NF5 installation again, and then I worked out what went wrong. When extracting the eight archives, I just assumed that it was one archive volume with eight pieces, and never realised that I should unzip each file. The fact that the first file extracted to 5 GB+, I naturally assumed that all the files were extracted. I was wrong; each file needed individual extraction, and then moving the content to the MOD folder. 

 

Then suddenly, the problems cleared up, and NF5 was up an running. Thanks for all the feedback and comments. Now I can get SweetFX running with the main SF2 North Atlantic exe, but not with a MOD folder yet. Can someone please point out which of the SweetFX files I should copy over to the NF5 MOD folders?

 

Thanks again gents.

 

Share this post


Link to post
Share on other sites

Hi SupGen,

 

Thanks, I did rename the ini along with the exe. Although the menu loads, as soon as I try to start a flight the game crashes, sometimes even in the menu. I can only run SweetFX safely for the stock Thirdwire/Strike Fighters 2 folder. My SweetFX files have been installed to this same folder. Any other tips on how to get SweetFX working with mod folders?

 

Having at least all my mods working, I am in awe with the amazing work you modders are doing for this sim. I wish TK would see an opportunity to open this sim up even further by providing a scripting interface where in game variables can be read, modified and overridden using custom code. Then maybe we will finally have a CCRP bombing mode, custom avionics, and it won't be long before someone comes up with a way to run a multiplayer environment. One can only dream...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.