Jump to content
Sign in to follow this  
swambast

For you 3dStudio Max Gurus - Please Read

Recommended Posts

Hi, thanks for reading. Well, I'm starting to take an increased interest in 3DSM-based simple ground objects. I have had the absolute good fortune and graces of a friend of mine who attends the university loan me an entire computer tower with both 3D Studio Max and Adobe Photoshop Elements on it, so I am doing the best I can to pick this up with the limited time I have. How does one get the .bmp textures to be output into the final .LOD model? I can stumble through getting the object textured in the viewports the way I want (editable meshes, etc.). But what specific steps/commands actually cause the final .bmp texture to be written out into the .LOD file after you export using the .LOD exporter plug-in? When I open the final .LOD in a text editor, there is no reference to any of the .bmp textures I applied /UV unwrapped. Thanks for any guidance here, slowly picking this up.

 

On another note, it seems you very small ground of talented 3DSM modders are all busy working on your projects right now. But if anyone actually has some additional free time and willingness to help train and coach me 1:1 more in-depth in 3DS modeling specifically for Thirdwire objects, please Private Message me!!! Please - I have read multiple tutorials online, but I'm trying to leverage the experience and knowledge of someone who knows the THIRDWIRE modelling world - and I don't see many options. I recognize and appreciate the value of your talents, so please let me know what it would take to make it worth your time and effort. I am really interested in learning this on my own, and not just having the models created for me since that just fosters more dependency and frustration. Well, thanks for reading all and for this great community support.

Edited by swambast

Share this post


Link to post
Share on other sites

You actually don't need to do anything special. Once the model is mapped and textured you export the LOD file and that's it.

The exporter creates two files, the .LOD and the .OUT. Only the first one is actually used in the game, but you can open the .OUT with notepad and see the meshes characteristics, the hierarchy of the various parts and the material assigned to them, like this:

 

Fuselage (114 polys, 342 verts) '07 - Default'

Box04 (12 polys, 36 verts) '14 - Default'

RightGearStrut (92 polys, 276 verts) '14 - Default'

 

In this case "default" is the name of the material assigned (no big fantasy, I know)

Share this post


Link to post
Share on other sites

Thanks much for the reply...I must not be getting the texturing properly applied then, here is an example .OUT: I see the 5 materials read <No Texture> and that must be what the .LOD references when integrating the .bmp textures...looks like I don't understand how to properly apply the texture, even though everything looks right in the Viewports...

 

steeringwh [140 polys, 420 verts (decal)] '19 - Default'

Windshield [4 polys, 12 verts (decal)] 'Default'

RearTire05 [68 polys, 204 verts (decal)] '19 - Default'

RearTire04 [68 polys, 204 verts (decal)] '19 - Default'

RearTire03 [68 polys, 204 verts (decal)] '19 - Default'

RearTire02 [68 polys, 204 verts (decal)] 'Material #68'

RearTire1 [68 polys, 204 verts (decal)] 'Material #57'

bottom [84 polys, 252 verts (decal)] 'Default'

body [374 polys, 1122 verts (decal)] 'Material #35'

 

 

Num Nodes: 9

Total: (942 polys, 2826 verts)

Mesh Max: (374 polys, 1122 verts)

 

5 Materials:

( 1) 19 - Default:

<No Texture>

( 2) Default:

<No Texture>

( 3) Material #68:

<No Texture>

( 4) Material #57:

<No Texture>

( 5) Material #35:

<No Texture>

 

0 Textures:

 

Points

 

Extents

Share this post


Link to post
Share on other sites

It doesn't look like you're using the Materials Editor properly.

 

Either hit 'M' or go to Rendering - Materials Editor.

 

Make sure for the slot you are using, that Blinn is selected as the Shader Basic Parameter.

 

Make sure under the basic Blinn parameters, that the bitmap you wanted is selected with Diffuse.

 

That should be it...

 

FC

Share this post


Link to post
Share on other sites

Well the materials used in max for a TW compatible model are very simple: a straight "default" material with a bitmap in the diffuse channel.

From what I see in that OUT you didn't assign any bitmap to your materials.

Share this post


Link to post
Share on other sites

Just don't quite get it I guess:

 

"Make sure for the slot you are using, that Blinn is selected as the Shader Basic Parameter." - I can't find that option anywhere.

"Make sure under the basic Blinn parameters, that the bitmap you wanted is selected with Diffuse." - Yep, think I'm doing that part right...

 

Here is what I see: it's so damn frustrating because it LOOKS like what I want, I just can't get it out properly...LOL!

 

3dsmedjeep.jpg

Share this post


Link to post
Share on other sites

Okay, on that screen in the materials editor, in the pull down window that says Map #1, open it up and you should see a selection similar to 'Default_xx'.

 

Select that, and then you'll see the screens I was talking about eariler.

 

FC

Share this post


Link to post
Share on other sites

Are you sure you're not applying the map directly to the object? Because that's what it seems from the screenshot you posted.

Take a step back and redo it from start:


  •  
  • pick an empty material from the material editor, that's a standard material
  • assign it to your object just to make sure it's the one you're actually using
  • now click on the little square box next to "diffuse", a pop up will open with all the options available. pick bitmap then choose the image you want to use
  • go to parent, be sure the "show map in viewport" option is active
  • you're material editor should look like this

 

post-15328-12557676557447.jpg

 

Hope this helps

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..