Jump to content
Sign in to follow this  
llamedos

Error 7217 now error 803 derrrr

Recommended Posts

Yes. This old chestnut.

 

I have recently tried to run my aged copy of EAW having uncovered a little about the 7217 error which stopped me from running it when I replaced my system 2 years ago.

I had no idea how 'common' the error was on EAW

 

Sure enough after installation, up popped the dreaded 7217.

I have installed the following patches:

120 to 128a

128ato128b

 

The 7217 went away only to be replaced with 803

Progress perhaps, but not quite what I was hoping for. :boredom:

 

Can anyone on here explain what the error is (google search says it's a font issue?) and if there is any way to get around it?

 

 

Techy stuff that may help:

 

My EAW was a clean install.

System:

XP service pack3

Athlon 64x2 dual

2.51GHz 2.00 Gb RAM

8600GTS 512Mb

 

Thanks

Alan

Share this post


Link to post
Share on other sites

The EAW source code has this line:

 

ERR_FONT_LOAD_NOFILE 803

 

I have searched the EAW source code for references to ERR_FONT_LOAD_NOFILE and 803 and there is no sign of this error message being generated by EAW.

 

My only (wild) guess is that you have a corrupted "fonts.cdf" file, and that XP is generating this error.

 

Jel

Share this post


Link to post
Share on other sites

Not such a wild guess!

 

I renamed "fonts.cdf" as "fonts.cdfx", copied "flt.cdf" and renamed the copy as "fonts.cdf". Launched EAW and got the 803.

 

Do you have another copy of your "fonts.cdf" somewhere?

 

Jel

Share this post


Link to post
Share on other sites

Thanks for the personal research!

 

Only copy I have is [the original] on the game CD

Tried to paste it in, but no luck - still get the 803.

 

I guess it's not that simple....

 

I have another copy of the game so I'll see if I can use the FONT.cdf from that...

Share this post


Link to post
Share on other sites

Hi,

 

the default EAW1.0 fonts.cdf cause this error!

 

You need the EAW1.2 fonts.cdf, that one will work. :)

 

EAW1.28 1st need to get patched to EAW1.2!

 

Greetings,

 

Knegel

Share this post


Link to post
Share on other sites

Thanks for the replies guys!

 

 

@Jel Thanks for the FONTS file.

Unfortunately the game now gives a shutdown error "EAW has encountered a problem and needs to close...." when trying to run it.

 

What I have done is this (in this order):

Clean Install

added 120 to 128a patch

added 128 to 128a patch

added 128ato128b patch

 

That got me to the "803"

Pasted in Jels Font file

 

Game now encounters the closedown error.

 

I've also tried changing the compatability with the same results i.e. the closedown error

 

I'm no doubt doing something very basic and silly :)

 

Any help?

Share this post


Link to post
Share on other sites

Hello again,

 

this is the way to do it:

 

1. copy/paste the contents of the EAW CD to a wanted directory(a real installation cause some, somtimes disturbing but absolut not needed, regestry entrys)

2. Patch this with the official EAW1.2 patch. EAW1.2 patch

3. add 120 to 128a patch

4. add 128 to 128a patch

5. add 128ato128b patch

 

That should do the job.

 

Greetings,

 

Knegel

Share this post


Link to post
Share on other sites

Hi Knegel,

 

Thanks for the guide and extra patch.

 

Unfortunately even with all the patches installed the game still don't work.....

I think there's something more going on than just updates.

 

I appreciate your efforts and input.

 

Alan

Share this post


Link to post
Share on other sites

Hi Knegel,

 

Thanks for the guide and extra patch.

 

Unfortunately even with all the patches installed the game still don't work.....

I think there's something more going on than just updates.

 

I appreciate your efforts and input.

 

Alan

 

Hi,

 

try this:

Open the EAW.ini and set "PlayIntro=0".

 

It might be that your card cant play the videos.

 

Greetings,

 

Knegel

Share this post


Link to post
Share on other sites

Alan,

 

 

 

If you are still having issues with EAW, try the new version 1.28c. See the top post in this forum. You can do an install from cd, then go straight to the 1.28c patch. Hopefully that will solve your problem.

 

 

Share this post


Link to post
Share on other sites

btw, is it possible that you didnt let EAW1.28c create a absolut new EAW.ini??

 

Hi Knegel,

 

Apologies for my ignorance in this matter, but how would I do that?

I presume I delete the cd installed .ini file, install the patch and run the game?

 

As an aside, I've also tried to run EAW in my new vista laptop - I can get as far as the 'home' screen of EAW, but it is 'ripped' and unuseable.

The music file plays ok though :)

 

Alan

Share this post


Link to post
Share on other sites

Hello,

 

yes, you need to delete the old EAW.ini(better is to rename it, then its not lost), if available, then a new get created with the game start.

 

What you describe on your Vista System make me believe you have a ATI card i this system, the garblet screen often can get fixed by a driver update.

 

CrashingJack currently work on a other fix that also might fix your garblet Vista screens.

 

btw, did you try to run EAW in XP in Win98 compatibility mode? Normaly thats not needed, but for at least one i know it fixed some problems.

 

Right click to the EAW.exe, then propetiers, there you can enable the copatibility modes.

 

Greetings,

 

Knegel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..