Jump to content

Recommended Posts

I am running combined WOV/WOE and am having trouble with the a A-4E(late) and A-4L. The avionics hump ends up as a gun pod. I know the weapondata for these in the weapons editor lists them as a gunpod.

How to fix this?

Anyone?

img00015.bmp

Share this post


Link to post
Share on other sites

This is Wretch's fix for the "hump":

 

The definitive fix for the Scooter's hump problem (hump? what hump?)

Changes it from gunpod to 'jammer' pod

 

Replace the info in your weaponsdata.ini with this below:

 

A-4E(Late):

 

(do, please! double check the weapon's id number

 

[WeaponData1068]

TypeName=A4E

FullName=ALQ-100 RHAW/AVI HUMP

ModelName=A4E

Mass=100.000000

Diameter=2.000000

Length=4.000000

AttachmentType=NATO

NationName=USN

StartYear=1965

EndYear=1975

Availability=3

BaseQuantity=8

Exported=FALSE

ExportStartYear=0

ExportEndYear=0

ExportAvailability=0

WeaponDataType=4

StoreType=0

JammerStrength=1.000000

 

A-4L:

 

[WeaponData1066]

TypeName=A4L

FullName=ALQ-100 RHAW

ModelName=A4L

Mass=100.000000

Diameter=2.000000

Length=4.000000

AttachmentType=NATO

NationName=USN

StartYear=1969

EndYear=1975

Availability=3

BaseQuantity=8

Exported=FALSE

ExportStartYear=0

ExportEndYear=0

ExportAvailability=0

WeaponDataType=4

StoreType=0

JammerStrength=1.000000

 

Do the weapons editor 'open/click on this, save, and close ini dance', and your humps are fixed.

 

and in the data inis, make this tweek:

 

A-4L

 

[AvionicsHump]

SystemType=WEAPON_STATION

StationID=1

StationGroupID=1

StationType=EXTERNAL

AttachmentPosition=0.0,3.82,1.82

AttachmentAngles=0.0,0.0,0.0

LoadLimit=2350.0

AllowedWeaponClass=EP

AttachmentType=NATO

ModelNodeName=A4L

PylonMass=0.0

PylonDragArea=0.01

LaunchRailNodeName=

MinExtentPosition=

MaxExtentPosition=

 

A-4E(Late) pretty much the same...

 

[AvionicsHump]

SystemType=WEAPON_STATION

StationID=1

StationGroupID=1

StationType=EXTERNAL

AttachmentPosition=0.0,3.82,1.82

AttachmentAngles=0.0,0.0,0.0

LoadLimit=2350.0

AllowedWeaponClass=A4E,EP

AttachmentType=NATO

ModelNodeName=A4E

PylonMass=0.0

PylonDragArea=0.01

LaunchRailNodeName=

MinExtentPosition=

MaxExtentPosition=

 

Also double check your loadout ini, and make sure Loadout<01>= is pointing to the correct hump. You shouldn't have to adjust it, just make sure it is.

 

This should get you going!

 

I propose this should be added to the Knowledge Base, as a lot have been asking about this problem lately.

Share this post


Link to post
Share on other sites

Yes and no on the wepak conflict. The original humps are set as gunpods, hence the mounting the SUU23.

 

I'd thought this was fixed in the 7/06 pak...oh well, here's the fixes, as edited by me almost 2 years ago:

 

A-4E hump mod:

Open up your weaponsdata ini, and copy/paste the infor below directly OVER the existing data, leaving the number section (top line) alone:

 

TypeName=A4E

FullName=ALQ-100 RHAW/AVI HUMP

ModelName=A4E

Mass=100.000000

Diameter=2.000000

Length=4.000000

AttachmentType=NATO

NationName=USN

StartYear=1965

EndYear=1975

Availability=3

BaseQuantity=8

Exported=FALSE

ExportStartYear=0

ExportEndYear=0

ExportAvailability=0

WeaponDataType=4

StoreType=0

JammerStrength=1.000000

 

for the A-4L:

copy/paste this directly OVER the existing data, leaving the numbered section alone:

 

TypeName=A4L

FullName=ALQ-100 RHAW

ModelName=A4L

Mass=100.000000

Diameter=2.000000

Length=4.000000

AttachmentType=NATO

NationName=USN

StartYear=1969

EndYear=1975

Availability=3

BaseQuantity=8

Exported=FALSE

ExportStartYear=0

ExportEndYear=0

ExportAvailability=0

WeaponDataType=4

StoreType=0

JammerStrength=1.000000

 

save and close.

Using the LATEST version of the weapons editor, open the weaponsdata ini, scroll down until you find the A4L and A4E entries, double click on each one at at time . This will open the data sections -- DO NOTHING ELSE - but click "SAVE" for one.

Save and close the editor.

 

What this does, is change the humps from a gunpod to a Jammer pod with the strength of 1.

 

Now, on to the data inis....

 

In the A-4EL, open it's data ini and scroll down to the weapons hum callout in the //Weapons section:

Copy/Paste this directly OVER the existing data:

 

[AvionicsHump]

SystemType=WEAPON_STATION

StationID=1

StationGroupID=1

StationType=EXTERNAL

AttachmentPosition=0.0,3.82,1.82

AttachmentAngles=0.0,0.0,0.0

LoadLimit=2350.0

AllowedWeaponClass=A4E,EP

AttachmentType=NATO

ModelNodeName=A4E

PylonMass=0.0

PylonDragArea=0.01

LaunchRailNodeName=

MinExtentPosition=

MaxExtentPosition=

 

save and close

 

For the A-4L:

same instructions,

 

 

[AvionicsHump]

SystemType=WEAPON_STATION

StationID=1

StationGroupID=1

StationType=EXTERNAL

AttachmentPosition=0.0,3.82,1.82

AttachmentAngles=0.0,0.0,0.0

LoadLimit=2350.0

AllowedWeaponClass=EP

AttachmentType=NATO

ModelNodeName=A4L

PylonMass=0.0

PylonDragArea=0.01

LaunchRailNodeName=

MinExtentPosition=

MaxExtentPosition=

 

save and close.

 

Your loadout ini should look like these examples:

 

[Attack]

Loadout[01].WeaponType=A4L

Loadout[01].Quantity=1

Loadout[02].WeaponType=LAU-10A

Loadout[02].Quantity=1

Loadout[03].WeaponType=LAU-10A

Loadout[03].Quantity=1

Loadout[04].WeaponType=Tank300_A4a

Loadout[04].Quantity=1

 

 

A-4EL:

 

Loadout[01].WeaponType=A4E

Loadout[01].Quantity=1

Loadout[02].WeaponType=

Loadout[02].Quantity=1

Loadout[03].WeaponType=

Loadout[03].Quantity=1

Loadout[04].WeaponType=Tank300_A4a

Loadout[04].Quantity=1

Loadout[05].WeaponType=Tank300_A4a

Loadout[05].Quantity=1

Loadout[06].WeaponType=Mk82SE

Loadout[06].RackType=MER

Loadout[06].Quantity=6

 

Station 1 should always be the callout for the hump.

 

 

Congratulations! You've successfully updated your Scooters :)

 

I'd thought these were already at the weapons wiki...but it looks like I only posted the Argie Skyhawks.

Better get this one up there as well as the IDF A-4H too.

 

Wrench

Kevin Stein

Edited by Wrench

Share this post


Link to post
Share on other sites

Oh, forgot this little tweek too, putting the anti-collision light on the top of the hump:

 

Add this to [Fuselage] section of data.ini:

Where *** is the next number in sequence

 

SystemName[***]=TopRedHumpLight

 

Add this to bottom of data.ini, in the "Lights" section:

 

[TopRedHumpLight]

SystemType=LIGHT

Position=0.00,1.43,1.18

LightSrcOffset=0.00,0.00,0.0

Color=0.88,0.25,0.25

Brightness=0.05

LightSrcRange=0.3

CanFlash=TRUE

FlashTime=0.6

 

**Note, this light adjustment may also work on the A-4E(L), and A-4H 'Ahit'

 

Might as well light the sucker up at night, eh???

 

Wrench

Kevin Stein

 

ps: wiki updated

Share this post


Link to post
Share on other sites

Hey folks,

 

Had the same issue, the notes here fixed it...however, I have a question.

 

Obviously, for preset loadouts (using the aircraft as AI in single missions, or in a campaign) the loadout.ini will always place the hump. My question is, how do you get to 'place' it permenantly...ie so you can't put anything else there if you're flying the A4L in a single mission... Is it even possible?

 

What I mean...can I force the program to not allow the option to place anything but the hump there in any circumstance?

 

Or better yet, make it part of the aircraft component list as stated in the data.ini file?

 

FastCargo

Share this post


Link to post
Share on other sites

See my posts above, brother!

 

The permanant, all inclusive, you-only-get-the-hump loadout.

 

Wrench

Kevin Stein

Share this post


Link to post
Share on other sites
The permanant, all inclusive, you-only-get-the-hump loadout.

 

As I mentioned in my previous post, I have already done everything mentioned in the thread. However, I can still select something other than the ALQ-100 for that station... Don't get me wrong, I can make the A-4L look correct by selecting the ALQ-100, but I can also not select it. Does that make sense?

 

FastCargo

Share this post


Link to post
Share on other sites

Let me make this issue a bit clearer. What I'm trying to do is like what exists on the F-111F ECM station and on the MiG-17PFU radar nose. In those aircraft, the ECM pod and radar nose are permanent. There is NO way to select putting something in those stations in the loadout screen. They show up as <Empty> in the loadout screen, but you go to fly, and there they are. I want the A-4L avionics hump to work the same way, but I haven't been able to find any obvious differences between the 3 aircraft in the data.ini files in that station (other than something called MinExtendPosition and MaxEntendPosition in the F-111F ECM station entry). Does that make more sense?

 

Also, anyone got textures for the MiG-17PFU radar nose so it matches the rest of the aircraft? Looks kind of odd as it is right now...

 

FastCargo

Share this post


Link to post
Share on other sites

You can change the loadout on the loadout screen; this can be done with any aircraft, that's how it works.

 

You shold have pre-loaded the correct avi hump...why are you messing about with changing it on the laodout screen??? Just leave it alone...it's works fine as is

 

As to the <empty> staton, is the little circle blacked out??? That means something is already loaded. Leave it alone.

As you said:

They show up as <Empty> in the loadout screen, but you go to fly, and there they are.

Then, obviously, the data in and loadout ini are working.

 

the Min/Max extend positions are the the collision meshes, I think, they have no affect on the laoding or not loading of the hump.

 

The only other thing you can try is this:

 

AllowedWeaponClass=A4L

 

that should force only the hump to load (although you might need to leave the EP callout)

 

As to the Izumrud nose, that's all we got.

There once was a time, that a real 17PFU was under construction, but that was several years ago, and I personally expect to see the 2nd Coming befor the real, fully built in 17PFU's arrive.

 

Wrench

kevin stein

Share this post


Link to post
Share on other sites
You shold have pre-loaded the correct avi hump...why are you messing about with changing it on the laodout screen??? Just leave it alone...it's works fine as is

 

But, but, I don't want to be able to change it...

 

As to the <empty> staton, is the little circle blacked out??? That means something is already loaded. Leave it alone. Then, obviously, the data in and loadout ini are working.

 

I guess what bugs me is I've tried to make the Avionics hump work exactly like the 17PFU nose/F-111F Pavetack and ECM pods...data, loadout, and weapondata.ini editing, making the entries as close as possible. Yet, it doesn't work like those other examples...

 

Offends my sensibilities I guess...

 

Also, tried the "AllowedWeaponClass=A4L" line...didn't change anything.

 

Thanks for trying to help though...guess I'll just not screw with it in the loadout panel...

 

FastCargo

Share this post


Link to post
Share on other sites

Well, POOP!!

 

At least it IS loading!!!

 

One other thing I thought of, is add the name to the weaponsdata ini; ie, the the "FullName" section

 

ALQ-100 RHAW A-4L

 

That would make sure you've got the right one (and skin) loaded.

 

Wrench

Kevin STein

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..