Jump to content
Sign in to follow this  
Aladar

Cockpit troubles...

Recommended Posts

I'm messing around with a new cockpit for the Salmson, but I need some help. In the cockpit.ini there is a line that reads...

 

HideExternalNodeName=cockpit

 

Well, I need to hide more than just the cockpit. I need to hide the fuselage and two spars. Is there any way to get the engine to hide more than one node?

Share this post


Link to post
Share on other sites

I'm messing around with a new cockpit for the Salmson, but I need some help. In the cockpit.ini there is a line that reads...

 

HideExternalNodeName=cockpit

 

Well, I need to hide more than just the cockpit. I need to hide the fuselage and two spars. Is there any way to get the engine to hide more than one node?

 

in the *_Data.ini

 

[fuselage]

ModelNodeName=fuselage

ShowFromCockpit=TRUE <---------------FALSE

DestroyedNodeName

DetachWhenDestroyed=FALSE

DamageRating=Destroyed

HasAeroCoefficients=TRUE

Yadda yadda

 

hope that helps :)

Share this post


Link to post
Share on other sites
Guest capun

There are three ways (maybe more?)

 

1- p10ppy's way

 

2- In the 3D Model, link the meshes/nodes you want them to disappear with the Virtual Cockpit to the external model "cockpit".

 

HideExternalNodeName=cockpit

 

With this statement all meshes/nodes linked below (children) the cockpit mesh/node will be hidden in VC mode

 

3- Make a Dummy statement in the data ini if you want some other mesh/name that are not the normally declared names or you don't want to hide everything. Something like this

 

 

[HideThisNode]

ModelNodeName=Spars ; The mesh/node you want to hide

ShowFromCockpit=FALSE ; Not visible

.

.

.

Share this post


Link to post
Share on other sites
There are three ways (maybe more?)

 

1- p10ppy's way

 

2- In the 3D Model, link the meshes/nodes you want them to disappear with the Virtual Cockpit to the external model "cockpit".

 

HideExternalNodeName=cockpit

 

With this statement all meshes/nodes linked below (children) the cockpit mesh/node will be hidden in VC mode

 

3- Make a Dummy statement in the data ini if you want some other mesh/name that are not the normally declared names or you don't want to hide everything. Something like this

[HideThisNode]

ModelNodeName=Spars ; The mesh/node you want to hide

ShowFromCockpit=FALSE ; Not visible

.

.

.

 

Thanks a bunch y'all, I was about to give up. :) Back to work!

Share this post


Link to post
Share on other sites

Aladar;

When you find the best solution, let me know. I am looking for any easy way to accomplish a 'full time' invisible cockpit. Right now I have to set all items ShowFromCockpit=false. There are about six of them, so there may be a better way. Let me know what you find out. I like the idea of the 3D model, but have no clue how best to do it. Good luck.

Edited by J18Dread

Share this post


Link to post
Share on other sites

J18Dread

if i'm understanding what you want correctly you could just add

 

HideExternalNodeName=fuselage

 

to the cockpit ini (if not fuselage, then what ever the Parent node for the whole aircraft is)

it will take itsself and its all its children and vanish

then rem out the

 

//ModelName=morane_cp.LOD in the cockpit.ini

 

and you get a full "glass" pit

 

hope that helps :)

Share this post


Link to post
Share on other sites
J18Dread

if i'm understanding what you want correctly you could just add

 

HideExternalNodeName=fuselage

 

to the cockpit ini (if not fuselage, then what ever the Parent node for the whole aircraft is)

it will take itsself and its all its children and vanish

then rem out the

 

//ModelName=morane_cp.LOD in the cockpit.ini

 

and you get a full "glass" pit

 

hope that helps :)

 

Thanks, I think. Is there a 'sure fire' way to know what this parent node is? Current node seems to be "cockpit". Will be changing it shortly in the D8 to see what happens. Again, thanks.

Share this post


Link to post
Share on other sites

yeah it will always be (well maybe :wink: ) the first Component listed in the data.ini/[AircraftData] section

and most of the other nodes will be parented to it in their repective sections (its ushally very obvious)

[AircraftData]
EmptyMass=968.0
EmptyInertia=2498.7,5660.7,8036.6
--Snip----
DefaultArmorThickness=25
Component[001]=Fuselage  <<<-----Me!  Me!
Component[002]=TopWingLeft
Component[003]=TopWingRight
--snip-----
Component[017]=VertTail
Component[018]=Nose

Share this post


Link to post
Share on other sites
Guest capun

A minor correction and some explanantions.

 

It helps to get hold of the .OUT file created by the 3DS Max exporter that creates the LOD file. The OUT file has the name of the meshes/nodes and the hierarchy plus other data like materials, texture maps, poly count, etc.

 

The top most mesh/node (The "super" parent) is usually the main fuselage mesh/node. To it other meshes/nodes are linked as the children of the fuselage, usually Left/Right Wings, Vertical Tail Fin, etc.

 

Each of those children mesh/nodes may have children mesh/nodes of their own. For example the Left Wing may have a Flap and Aileron linked to it.

 

Why is that important? If the Left Wing is destroyed, the Flaps and Ailerons will also be destroyed.

 

 

Now if you look at a plane_Data.ini (in this case the F-4E)

 

[AircraftData]

EmptyMass=13397.1

EmptyInertia=141739.6,28550.6,161309.4

ReferenceArea=49.24

ReferenceSpan=11.79

ReferenceChord=4.79

CGPosition=0.00,1.70,0.00

Component[001]=Fuselage ; This is the name of a Data ini Component not the node name

.

.

.

 

[Fuselage]

ModelNodeName=fuselage_P ; This is the node name

ShowFromCockpit=FALSE

HasAeroCoefficients=TRUE

 

In most cases, but not all, the Top Most Mesh/Node is named Fuselage (it is in all of our models) but as you can see in this case the name is fuselage_P

 

So you need that node to be hidden by the cockpit statement like this

 

HideExternalNodeName=fuselage_P

 

 

In most cases with the cockpit.ini file you only want to hide the external model cockpit mesh/nodes and its children meshes so they do not overlap with the virtual cockpit

Share this post


Link to post
Share on other sites

S! all

 

For me i have invisible cockpit and fuse when I hit the (.) del key on numpad ...

Edited by *BRUNO*

Share this post


Link to post
Share on other sites
S! all

 

For me i have invisible cockpit and fuse when I hit the (.) del key on numpad ...

 

Yes, but the cockpit view always comes back when switching between views. I do not want to see it at all. Would like the toggle in CFS or bitmap change in RB3D. Presonal preference, too bad it will not carry over into online play.

Share this post


Link to post
Share on other sites

Here's what I had to do:

 

[Fuselage]
ModelNodeName=Fuselage_P
ShowFromCockpit=False
HasAeroCoefficients=False

 

They were TRUE, so I changed them to False. Worked.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..