Jump to content
Sign in to follow this  
Old Diego

SF2V stand alone

Recommended Posts

I'm trying to track down a problem with a merged install SF2/SF2V/SF2E/SF2I. The issue is that once you patch up SF2I with the latest patch, it changes the water level in SF2V by 0.80 meters. This isn't so obvious on large ships or CVs but on sampans and smaller boats - they appear sinking or sunk.

 

This is how the VietnamSEA_data.ini looks post patch

 

[HeightOffset]

NonTexturedMesh=-10.0

TexturedMesh=-5.0

DetailedMesh=0.0

LowDetailMesh=-1.5

WaterMesh=0.8 <---------<<<

 

I need this info from an unpatched merged or fully patched stand-alone SF2V install. I'm guessing its 0.0 or much lower than 0.80. I want to make sure before I change out all my boat XYZ COG. HERE is an accompanying topic at Thirdwire.

Share this post


Link to post
Share on other sites

This is out of my merged SF2/V/E install:

 

[TerrainMesh]

TextureThreshold=0.80

LowDetailMeshThreshold=0.50

MedDetailMeshThreshold=0.30

TileToHeightGridRatio=4

RenderMeshVertexCount=4096

RenderMeshIndexCount=6144

SolidObjectVertexCount=12288

SolidObjectIndexCount=18432

AlphaObjectVertexCount=8192

AlphaObjectIndexCount=12288

 

[HeightField]

DetailScale=1.0

DetailFrequency=1.0

MaxHeight=1000

MinHeight=0

 

[HeightOffset]

LowDetailMesh=-1.5

WaterMesh=0.8

 

 

shows the same numbers.

 

I remember we has the same issue (sunken ships, docks, vehicle near the beach) after the 08 patch in all the 1st gens. I do think the fix was reducing it to 0.0 or 0.1 (but can't exactly remember, age youknow)!!!

The other thing I did, was extract and repaing ALL the VietnamSEA HM bmps to solid black. That helped too. I uploaded them there; should be in the terrains d/l section. Since the names are the same...

 

But I'd test the numbers first. There was a thread about after the 08 pacth, as some of my terrains (Lybia in particular) had the issue

 

wrench

kevin stein

Share this post


Link to post
Share on other sites

forget to mention, on the transition tiles, there's the height map scale

 

We had to reduce that valuse as well. Unfortunately, in the VNSEA it seem's its already set to the "2" it got adjusted to on the aftermarket terrains...

 

[Texture024]

Filename=vietnamSG25A.TGA

HasWater=1

HeightMap=vietnamSG25A_hm.BMP

HeightMapScale=2.000000 <---this is the other line

Color=0.210002,0.300120,0.325420

SolidObjectTexture=terobject_buildings1.BMP

AlphaObjectTexture=terobject_trees1.TGA

MipMapLevels=6

 

maybe reduce that to 1?? or try the black hms??? :dntknw:

personally, methinks it's something to do with the SF2I merge (not having it at all, I can't really comment)

 

wrench

kevin stein

Share this post


Link to post
Share on other sites

I can report that "WaterMesh=0.8" is set in Clean SF2I and Patched up. The Bug is there either way. And this is a "Stock" Item.......

 

uw.jpg

 

 

Not too noticable on CV's and Large Ships, But it deffently effects River Crafts and Boats.

 

 

331KillerBee

Share this post


Link to post
Share on other sites

Thanks guys for the help and info. I think since all stock boats show this bug, it should be fixed by TK. The last thing I want to do is readjust all of my boats COG to work in this water level only to have TK fix it later...where I'll have to lower the COG again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.