Jump to content
Sign in to follow this  
Swordsman422

Aircraft blowing up on carriers...

Recommended Posts

Okay, so after a prolonged absence I've finally come to my senses and am getting back into the TW sims. Never one to be satisfied with campaigns as they are, I'm always finding excuses to add carriers to them. Anyway, I'm having some extremely abnormal issues with the ships in SFP1; the player aircraft based in them will all spawn in a lump on the deck and explode. One would think this is uniform for all carriers on all terrains, but it is not. On some terrains, some carriers will work fine and others will not. Example: In the Taiwan terrain, DO's CVN-75 and Beer's Forestall will be okay, but the problem occurs with every other carrier, even the stock ones. And in the Madagascar terrain, the Forestall will be troublesome while the Kitty Hawk is not. Generally the CVN-75 model is the only one that tends to be universally compatible. The only terrains not giving me migraines are the stock Desert terrain, Iraq, and Vietnam. I thought I was just going to have to be choosy about which units are in a terrain map... until I met Cuba. No carrier of any class will function for me in this terrain. Jets blow up on it no matter what I do it seems. I've not ever seen this complaint before (search function rendered nothing) so it MUST be something I'm doing wrong. I've read the knowledge base entries on the subject and followed them to the letter (plus I've been doing this for long enough that I'm not a stranger to the process) and have had no success.

 

Here are my data entries:

 

From the campaign.ini

 

air unit data omitting weapons entries

 

[AirUnit004]

AircraftType=F-14A

UnitName=VF-41 Black Aces

StartDate=08/28/1999

ForceID=1

Nation=USN

CarrierBased=TRUE

CarrierNumber=71

DefaultTexture=USNVF41

StartNumber=4

BaseArea=Delta Station

RandomChance=100

MaxAircraft=11

StartAircraft=11

MaxPilots=19

StartPilots=19

Experience=100

Morale=100

Supply=50

UpgradeType=NEVER

MissionChance[sWEEP]=50

MissionChance[CAP]=50

MissionChance[iNTERCEPT]=30

MissionChance[ESCORT]=50

MissionChance=60

MissionChance[CAS]=60

MissionChance[sEAD]=10

MissionChance[ARMED_RECON]=60

MissionChance[ANTI_SHIP]=05

MissionChance[RECON]=20

 

Carrier unit data

 

[CarrierUnit001]

CarrierType=CVN75

CarrierNumber=71

UnitName=USS Theodore Roosevelt (CVN-71)

DefaultTexture=CVN-71

ForceID=1

Nation=USN

BaseArea=Delta Station

NumSquadron=10

BaseSize=MEDIUM

Experience=100

Morale=100

Supply=100

Intelligence=100

UpgradeType=NEVER

 

 

Terrain targets.ini entry for this station

 

[TargetArea094]

Name=Delta Station

Position=368282,453825

Radius=5657

ActiveYear=0

Location=1

Alignment=FRIENDLY

CarrierStation=TRUE

 

 

I'm having the same problem in the OTC campaign as well, and I cannot figure out where I may be going wrong. I am secure in the knowledge that these MODs are quality and that the creators would not have released them without knowing they work, so this is MY fault, I just cannot figure where I've gone wrong.

 

In a word: help?

Share this post


Link to post
Share on other sites

He returns!!!!!!!!!!! Hey Sword long time no see how have you been? Anyway what patch level are you with your SFP1?

Share this post


Link to post
Share on other sites

DAVE! Awesome to be back. I've been okay. I spent some time cheating on my beloved Thirdwire games. I've been pretty good so far. Women have changed, computers have changed, and I'm generally in a better spot than I was. How have you been?

 

Anyway, I'm current on my patches for SFP1. Sorry that I forgot to mention that. My bad.

Share this post


Link to post
Share on other sites

I'm doing really good. Site has grown and we have one of the best sims community anywhere. People here are great. One big family.

 

What aircraft are blowing up, on what terrains specifically?

Share this post


Link to post
Share on other sites

Any player navy aircraft assigned to the carriers, though I'm a tomcat addict by nature. All aircraft that may be in question have the CarrierBased=TRUE in the aircraft_data.ini. And to be sure, the carrier ground object names all match properly. ALL of the carriers and aircraft function correctly in the stock terrains under all patches, it's the add-on terrains that are being troublesome and Cuba in particular.

Share this post


Link to post
Share on other sites

I have had some success adding the carriers to the (terrain)_types.ini. I don't know why,but sometimes they work.

 

You might want to try this for a little more realism. The target ships stay in one place,while the carrier moves,but it's more realistic.

It gives the "boat" some support ships. There are some really cool support ships to add.

 

[TargetArea094]

Name=Delta Station

Position=368282,453825

Radius=5657

ActiveYear=0

Location=1

Alignment=FRIENDLY

CarrierStation=TRUE

Target[001].Type=Benham

Target[001].Offset=920.07,860.34

Target[001].Heading=267

Target[002].Type=Brooklyn

Target[002].Offset=-920.07,-860.34

Target[002].Heading=267

Target[003].Type=CargoShip

Target[003].Offset=-920.07,500.00

Target[003].Heading=267

Target[004].Type=Jaccard

Target[004].Offset=920.07,500.00

Target[004].Heading=267

Share this post


Link to post
Share on other sites

Any player navy aircraft assigned to the carriers, though I'm a tomcat addict by nature. All aircraft that may be in question have the CarrierBased=TRUE in the aircraft_data.ini. And to be sure, the carrier ground object names all match properly. ALL of the carriers and aircraft function correctly in the stock terrains under all patches, it's the add-on terrains that are being troublesome and Cuba in particular.

 

Yeah those have been a problem for awhile. For some reason with 3rd party terrains that has been happening and I am not sure what the cure was.

Share this post


Link to post
Share on other sites

Ah, so I'm not the only one who is having this problem. I was absolutely certain that I was at fault. Shame that it isn't just me. Could it be the terrains aren't compatible with the latest patches and that is the root of the issue? I doubt this would be the case though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..