Jump to content
Sign in to follow this  
streakeagle

Jane's Fighters Anthology on Win 7 64-bit

Recommended Posts

I can't believe someone came up with a simple fix to getting Jane's Fighters Anthology to run correctly on Win 7 64-bit. The fix was actually created for another game (Starcraft), but someone else figured out that FA was suffering the same problem and therefore could be fixed using the same solution. Simply use a batch file to start the game. The original batch file posted for Starcraft didn't work for me, so I deleted parts that did not apply to me and edited the rest to fit Fighters Anthology. This is the text of the batch file I am using:

 

rem First kill Explorer.exe, which messes up the colors

taskkill /f /IM explorer.exe

 

rem Change to the application directory

cd C:\JANES\Fighters Anthology

 

rem run the application

FA.EXE

 

rem Wait for the game to quit, press Enter to continue

pause

 

rem Restart Explorer.exe

start explorer.exe

exit

Edited by streakeagle

Share this post


Link to post
Share on other sites

rem Restart Explorer.exestart explorer.exe

exit

 

rem Restart Explorer.exe

start explorer.exe

exit

 

:ok:

Share this post


Link to post
Share on other sites

Janes FA works on my Vista 32 bit.

But i get graphics corruption once in a while.

Will this help fix it?

Share this post


Link to post
Share on other sites

Janes FA works on my Vista 32 bit.

But i get graphics corruption once in a while.

Will this help fix it?

 

I don't know if this works for Vista, but it is graphics corruption that it fixes. The intro videos and menu screens looked terrible and the game looked worse, but with this fix, it looks 100% like it did in Win95/Win98 as far as I can tell and recall. This game looked so cool to me in 1998 when I played on a work laptop.

Share this post


Link to post
Share on other sites

I know that this is a large bump, but I found this thread during a Google search.

 

Anyways, I have Windows 7 64-bit and I followed your instructions and I am now able to play the game without all the graphical problems! :)

 

However, I am having a huge issue with my mouse lagging and much of the game being choppy (although the flying itself is not choppy for some reason). I am able to fly fine with no lag at all, but I can't use the mouse very well at all for locking on and such. This is also a huge problem in the menus as my mouse is going all over the place trying to select which missiles to use and just going through the menus to get flying.

 

Do you know what may be causing my problem? I am using an ACER Aspire 7740G-6930, if that makes any difference.

 

Thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..