Jump to content
Sign in to follow this  

The Nieuport 17\23 Pack For FE1

Recommended Posts



Usually I have no trouble adding aircraft. But the the panes in the N 17\23 pack for FE1 is giving me fits, lol. I have FE1, Expansion Pack 1, November patch.


I simply can not get the planes to show up in the single mission menu. Every other plane I have installed is ok. 


I think christian59 made the pack. I am not trying to use his FE2 pack either.


Probably something very simple I'm missing.


Many thanks in advance.

Share this post

Link to post
Share on other sites

Hi there!


this sort of thing has sometimes happened to me but I'm darned if I can remember why planes sometimes don't show up and how I fixed it. The 'typical' reason I CAN think of is that they don't have the files needed for the cockpit, which means in effect that they are AI-only planes which the player can't fly. That should not be an issue with these, though.


If you're sure you didn't use the FE2 version with its different install routine and instead installed into your main install folder (and not the FE2-style 'mods' folder under your username), all I can think of is:


1. installation issue - have you looked at your C:/Program Files/ThirdWire/First Eagles/Objects/Aircraft folder, to confirm that the planes in the pack all appear there, each in their own folders and complete with a Cockpit subfolder with appropriate-looking files?


2. service dates - in trying to select one for a single mission, have you picked a date during which the planes were in service, as defined in (IIRC) it's .ini or data.ini file?

Share this post

Link to post
Share on other sites

HI !


Thanks for the quick reply.


Yeah, I have no trouble what so ever in adding planes. It is not the FE2 download.


It's acting like the plane folder is not the same name as the plane .ini file. It's not showing up in the available aircraft list at all.


The date range is 4\17 to 11\18.


I have not changed any files from the original download as well as the instructions say the typical routine.


I read way back into the forums to see if any one else had any trouble and I'm not seeing anything. Since the file has been around since 2007 and has been updated in 2010 and has 164 downloads and lol a 4 star rating, I'm feeling a little foolish for not being able to make it work.


Well, not a designer, I have no trouble being a mod "user". I am comfortable in all aspects required to use mods.


Do you happen to have that pack loaded your self? I wonder if the update pooched the original cockpit file?

Share this post

Link to post
Share on other sites

One thing I'm seeing in the FE1 download. The read me file in the Nie 23 plane folder, (the one I'm trying to get to work) is the same read me for the FE2 download.


I read on the forum when the file was updated, there was some confusion about removing the old file. A mod had to do it for the uploader. I wonder if the original FE1 download was accidentally replaced by the FE2 version?


It's a multi plane pack and they are all supposed to flyable but I'm not getting any to show up in the selection list.


If any FE1 flyers could take the time and try to install the Nie 23 model, please let me know if it works for you.


I don't have FE2, but I would imagine the files would work in either game, just different installation procedures.



Share this post

Link to post
Share on other sites

Had similar difficulties some time back. Its probably a Unicode problem.


To fix, open the aircraft.ini file in the aircraft folder, eg, for the Nieuport23 plane open the Nieuport23.ini file in the Nieuport23 folder (in the Aircraft directory), and use the option "Save As" to save it as an ANSII text file. It  probably is an Unicode file and if so that would be the problem. If this works, do this for each aircraft ini file.


Hope that helps keif.

Edited by extremeone

Share this post

Link to post
Share on other sites

Greetings, keif149


Interesting. I just checked the Downloads section here, and the "Nieuport N 17/23 Family" file (uploaded by

Christian59, ver 2.0, release date 07.11.2010) is listed as "for FE2."  Yours must be an earlier version.

There is also an earlier "Nieuport 17 Megapack" available that appears to have been designed for FE1.


Are you, perhaps, encountering problems because you are trying to load FE2-designed files into FE1?
Well, we'll deal with that, perhaps, later.

I've used both the above Nieuport downloads, and had no problems that I can remember.

I can assure you that the "Nieuport N 17/23 Family" does work in FE2. Just drop the files/folders in the correct

places, and everything works just fine. Don't even bother with the "Weapons" or "Guns" or "Decals" subfolders --

the planes still show up. [Yeah, they ain't "right," but they do show up, without any editing].
So, I don't think there's anything inherently wrong with Christian59's download (at least, the currently-available one). However, I currently use FE2

exclusively, so my responses to you regarding Create Mission in FE1 may seem somewhat "generic," even though I'm

trying to help.


OK, so if you've tried all the obvious solutions for Create Mission unavailability --

 -- Correct files/folders install;

 -- Aircraft Folder name and Aircraft.ini filename must match exactly, including spelling;

 -- Valid cockpit file and .ini;

 -- All .inis are in ANSI format;

 -- Verified dates of service/availability


Now you get to check a few "brainfade" issues (things that one tends to easily overlook), such as:

 -- In the Aircraft Data.ini, (after you've checked the Service Dates), verify that the Nation matches what you

are trying to use in the Create Mission setup, and that the Mission Type (Sweep, Intercept, etc.) you want to use

is listed in the Data.ini as a Primary or Secondary Role. [in FE2, this often gets re-set automatically in Create Mission when you pick a different plane. I can't remember

if FE1 does that also, or if you have to do it manually]. 

 -- What you see in the Create Mission aircraft picklist is the Aircraft Name/Shortname [from the Aircraft.ini],

NOT the Aircraft Folder name [e.g., the "Nieuport23_Lewis" plane is shown as "Nie.23 C.1 Lewis" in Create Mission.

That can sometimes be confusing. But, it can easily be edited].


That's sorta the "checklist" that I go through when I can't get a plane to show up in Create Mission.
[Missing weapons, guns, pilot .lods, etc. errors usually don't prevent the aircraft from at least appearing].


So, here's a couple things you can try --
(1) Re-name the "Nieuport23" aircraft folder to "N23" and re-name the "Nieuport23.ini" file to "N23.ini."
(2) In your new "N23.ini," change the AircraftFullName and ShortName lines to "N23 C.1"
This is to make it easy to recognize and find your new plane in Create Mission.
(3) Check that the AircraftDataFile and CockpitDataFile lines in your new "N23.ini" match exactly the

corresponding filenames in the N23 folder (including spelling).

(4) If necessary, copy a couple corresponding files from other plane folders that you KNOW work into your N23 folder, and temporarily change the lines in "N23.ini" to

reference THOSE files [Your N23 won't work right, but you'll be narrowing down the possibilities for where the

problem may lie]. Probably best to just use "default" stuff, like Spad 13 cockpit/data file references.


If you discover that the plane shows up with a different cockpit file or data file, you can then narrow your

troubleshooting to that specific file/folder/setup.

Most of my issues tend to be when trying to run FE1-designed planes in FE2, but I have had some experience trying

to run SF2-designed planes in SF1, and it is always due to differences in the way the AircraftData.ini file is


There are others on this Forum better qualified to explain the differences between FE1 and FE2 AircraftData.ini

files. And if the problem is with the aircraft .lod files (not likely), you may be out of luck.


If you find your N23 shows up if it uses a different Data.ini, you sorta have 2 (3) choices --
(1) You MIGHT be able to find an alternative N23 flightmodel, in one of Peter01's earlier FM downloads for FE1

(2) You can go line-by-line, comparing your current N23 data.ini with a different FE1 data.ini (that you know

works), and change 1 line/parameter at a time, until the file STOPS working. Then go back, change it back, and

proceed to the next line, etc. Not much fun.
(3) You can wait for someone else on this Forum to offer different, better suggestions.


Hope you get it settled.



  • Like 1

Share this post

Link to post
Share on other sites

Good Day Gentlemen!


Just want to say thanks for all who tried to help me. Much appreciated!


I have been a forum lurker since about 2008 and was always able to figure out my own solution or by researching the forums or knowledge base.

This one really had me stumped!


I am very happy to report, it was indeed the .ini files not being saved with ANSI encoding. Obviously, I had never thought of that ;-)


Also want to mention I have been a pc gamer since 2002. Mainly I play strategy games from HPS\Tiller and the likes of Steel Panthers and Combat Mission.

I have belonged to many Clubs and forums and the response to my question, even when I was appearing as total newbie, really impressed me. It is rare these days for forum members showing such kindness and consideration. I am very impressed with the forum members here ;-)


For future flyers that may be researching the same question, I was using the plane pack for FE1 and running W XP.


Thanks again for your time and trouble!



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..