Jump to content
Sign in to follow this  
"Slick"

Help with YAP vs. Joystick/controller button commands

Recommended Posts

So I finally got around to (6-years later) installing YAP1 into a fresh and patched (Oct08) install of WOV (I also have additional installs of WOV patched and modded that run flawlessly) .

 

My problem is that other than basic flight controls; I cannot get the YAP modded install to recognize assigned button commands from my controllers;   I select a function in the YAP  "customize" menu, assign a controller button to the event/command; once I start a mission and push the assigned buttoned; let's say landing gear raise/lower; the assigned button activates a different function.  

 

I've attempted to import one my "functional" WOV controller config files into the YAP install, though for some reason the YAP install will let me select the config file (ie "Slicks Controller") it does not recognize/assign those buttons to the appropriate functions once the YAP modded install starts.

 

I'm somewhat familiar with extracting and working with .ini files. Is this a .ini fix or?

 

 

Though the ability to play YAP modded WOV won't make or break my day, the topic title is annoying the hell out of me. 

 

Thanks for assistance,

 

Slick

 

Win7

Generic Madcatz Stick.

Saitek ProFlight Throttle Quadrant

CH Pro Pedals

USB 31 Button Interface

etc.. 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Try import (paste)a control.ini set to 'Read Only, all of mine are and I've never had a problem since. Just a thought.

Edited by RAVEN

Share this post


Link to post
Share on other sites

Thanks for the response Raven.

 

I'm looking for the control.ini..  I can't find it in a existing WOV folder  Can you point me to it (Flight, Controls, ?)

 

I realize that it will be within a .cat file

 

Thanks

Edited by "Slick"

Share this post


Link to post
Share on other sites

The file I mean is a copy of your "Slicks Controller".ini set to Read Only. Mine is named Hotas08.ini and until I set it to Read Only the game kept changing it back to Default.ini

Share this post


Link to post
Share on other sites

the issue is a file called

"AircrcraftObject.ini"

 

rename it, and see if the Default.ini (located in the /Controls folder -this is the file that stores your stick/keyboard functions) returns to normal

Share this post


Link to post
Share on other sites

Wrench, you are correct. I just looked at the YAP AircraftObject.ini and the stock 08 patch one. The Yap one is the messing with the joy stick controls. (Actually it's missing control Data entries). Unless I've overlooking something else.

Share this post


Link to post
Share on other sites

renaming the AircraftObject.ini did the the trick.  All controllers are now functioning fine.

 

Thanks for the assist guys!

 

Slick

Share this post


Link to post
Share on other sites

Just a Observation, but the Yap 'FlightEngine.ini is not so good either, at least on my XP machine.

Share this post


Link to post
Share on other sites

I never used either of those from them; just used the stock ones

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..