Jump to content
Sign in to follow this  
Bossco82

Campaign bug since SF2NA

Recommended Posts

Hi,

 

I've come back to SF2 after a couple of years away and I've noticed a little bug using campaigns. The northern sabre campaign is not effected by this bug but all other campaigns are. This is what happens. I'll open a campaign and on the first mission I can open the loadout screen and the map screen just fine. Once I've flown that mission and go onto the next mission if I open either the loadout or map screens the game will crash. The reason for the crash in task manager is the graphicsengineDX10.dll. This is using a fresh install, all titles merged, patched to July 2013 and no mods at all. What I find strange is it happens in every campaign exept northern sabre. The other thing to mention is if I close SF2 then re-open it I can open an existing mission and again use the loadout and map screens again, but on the second mission it will crash again.

 

To check further incase I had a problem with my system I installed all my titles again without SF2NA but at July 2010 patch level. All the campaigns work just fine, no crashes or errors.

 

Has anyone else experienced this issue or is it just me?

 

 

Share this post


Link to post
Share on other sites

Thanks for replying Migbuster,

 

Yeah I have a GTX 970, I did suspect it might be something to do with immature nvidia drivers, I'm also running in g-sync although I doubt that's causing a problem.

 

I'm guessing you don't experience this campaign problem?

 

I'm not really that fussed, its just niggling me and I wanted to know if anyone else is experiencing this in a fully merged install with the July 2013 patch.

Share this post


Link to post
Share on other sites

Works okay for me

 

 

Do you run a single exe file?

 

Make a copy of StrikeFighters2 Europe.exe and rename it. - run it and see if any change.

 

 

If that fails you could try setting ForceDX9=FALSE in the options.ini just to see if it will run at least (should be okay for dx9)

 

 

If it is graphic driver related set up a profile for SF2 in the NVIDIA control Panel maybe set AA / AF manually for example.

Share this post


Link to post
Share on other sites

I had a similar problem with the last patch, game crashed 1 out of 4 times when opening the loadout screen.

Caused bij the graphics dll. Then replaced the dll with one from a earlier patch version.

And no more problems after that.

 

I use a radeon hd 7800

Share this post


Link to post
Share on other sites

Bossco82, you Don't need to go all the way back to a 2010 dll.

Just try the May 2013 patch dll first.

Rename the Original GraphicsEngineDX10.dll (so you always can revert to the original dll)

 

This is my C:\Program Files (x86)\ThirdWire\Strike Fighters\Core folder

 

 

 

Good luck !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..