Jump to content
Sign in to follow this  
harveysimpson

View snapping problem

Recommended Posts

Since the most recent patch, 1.02, I am unable to look to my left, right up down etc.
 
The key bindings are the same.
 
It's seems like the view attempts to change but comes back instantly.
 
Interesting, it works fine using the external view, just not in the virtual cockpit.view.
 
I am using a.thrustmaster Warthog setup but the problem manifests itself with both keys and joystick.
 
I have no track it setup or anything like that. 
 
Like I said , it worked prior to the patch.
 
Please advise if you can.
 
Best,
 
Harvey

Share this post


Link to post
Share on other sites

I changed the repeat rate to 1 and now it works but it flickers madly sometimes.too.
 
It's almost as if something is forcing the view, within the virtual cockpit, to remain centred.
 
The problem manifests itself whether i use keys or joystick.
 
I have read the FAQ and I have no opentrack or similar installed.
 
This is maddening.
 
Please help! 
 
 
 

Share this post


Link to post
Share on other sites

Hi Polovski,

 

When I turn scroll lock on - the view does indeed shift but only like 5 degrees. I want to be able to turn my head 90 degrees either left or right.

 

Should I be using the rotate eyeball command to achieve this?

 

Share this post


Link to post
Share on other sites

Using what number keys?

if you use 4 or 6 on the numpad (with Numlock ON)   AND Scrollock OFF  it will rotate the view constantly in the direction you press.

Pretty much all the way around to the rear.

If you are in GUNSIGHT view (F6 toggle) then all bets are off.

Can you confirm that?

Not sure what rotate eyeball is?

TrackIR is the best way to look around.

Edited by Polovski

Share this post


Link to post
Share on other sites

The numpad keys with numlock on and scroll lock off have no effect whatsoever on my system!

 

Rotate eyeball is the command listed under 'view' commands in the re-map keys / controllers section.

 

(I'm using the brand new WOFF between heaven and hell. )

Share this post


Link to post
Share on other sites

OK I will reply only in here now rather than both in support email and here.. 

Is this a laptop?

Do not use the eyepoint commands as they are normally to physically reposition or move the eyepoint in a semi-permanent mode.  i.e to shift your cockpit eye point position, not used to look around.  Numpad is for that or POV normally.

If numpad does not work, something else must be interfering with the keys or numpad  (other key program or joystick mapping?) or it's possible you have overwritten something in the config. Numpad works normally out of the box, it is a default,  and just normally always works.

BTW if you have head tracking. It will not work of course, it will briefly move, as the head tracking will override!   For that put your tracking clip/hat down or disable the head tracking.

Edited by Polovski

Share this post


Link to post
Share on other sites

No this is a desktop with a Thrustmaster Warthog joystick and Throttle. 

I'm totally stumped. I know my way around a pc and have tried almost everything!

 

 

Thank you for trying to help¬!

 

Share this post


Link to post
Share on other sites

C

17 minutes ago, harveysimpson said:
Using the default setup, with scroll lock off it does nothing.
 
With.num pad on it moves slightly to the right or left respectively. 

Maybe backup your WOFFkeys.xca file, then experiment resetting all to default in WOFF keys program. Check no other odd bindings on your joystick, remove any axis not in use, and toe brakes etc anything not used. 

(.xca is in C:\Users\<YOURNAME>\AppData\Roaming\OBD_Games\OBDWW1 Over Flanders Fields

No headtracking?

Edited by Polovski

Share this post


Link to post
Share on other sites

Ultimately you may need to do a clean uninstall and reinstall to see using WOFFToolbox option.

(backup .xca).

from email;    for me it behaves as you describe when something else is overriding the view (Trackir here).
Maybe your POV hat is sticking the front view on constantly  something like that has to be..

--

Edited by Polovski

Share this post


Link to post
Share on other sites

Seems OK, I thought you meant it showed a POV for every binding rather than every device has a pov listed.

On the left I notice a lot of buttons are "down" what are they doing mostly?  Are any of them "on" pressing etc?

Share this post


Link to post
Share on other sites

I put them all to "up" but still no change.

 

It must be a driver somewhere - Occulus or Vorpx - but I have made sure both of these aren't running even in the background.

 

Many thanks for all of your help and congratulations on such a fantastic game! 

Share this post


Link to post
Share on other sites

Ah yeah must be something in the background, as I say numpad just works no configuring.  Only snaps instantly back after 0.5 of a sec when head tracking is active.  Otherwise pans around nicely with snap (scroll lock ON) or keeps moving (scroll lock OFF) - always been like that 

So either head tracking stuff (I have Oculus no issues but it's not "on"), some other controller somehow forcing it forward (key pressing,  PoV always on and pressing forward that kind of thing).

Maybe try mouselook?

 

Edited by Polovski

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..