Jump to content
  • Announcements

Recommended Posts

Hey, So i've been playing mostly hard mode since i like flat spins and all of those, However when i play on normal mode (Usually because vtol planes work best there) my planes always pitch up when i'm not inputting any control. It doesnt do that on hard mode, so i was wondering if anyone else experiences that, and if so, is there a fix? 

Share this post


Link to post
Share on other sites

Posted (edited)

I fly on Normal most of the time and don't have any issues. Which plane is it? Or is it any plane? The only time it pitches up during landing on Autopilot. Other than that no issues.

Edited by EricJ

Share this post


Link to post
Share on other sites
3 hours ago, EricJ said:

I fly on Normal most of the time and don't have any issues. Which plane is it? Or is it any plane? The only time it pitches up during landing on Autopilot. Other than that no issues.

Every plane I'm using just pitches up slowly, it might be my stick since it is a bit old but I don't see it doing any of this in hard mode or on any other games

Share this post


Link to post
Share on other sites

Yeah my stick was rolling and pitching everywhere so I finally replaced it. Try it on other games. If it does that then it's definitely the stick.

Share this post


Link to post
Share on other sites

also try recalibrating

Share this post


Link to post
Share on other sites

Changed the deadzone in settings, works well now

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..