Jump to content
Sign in to follow this  

Recommended Posts

Does anybody have a fix for the fixed (or should I say absence) guns for the Mirage F-1C200 that I've just uploaded? Here's a sample of the DATA.ini file where all seems to be in the proper order:

 

In the 'Nose' section:

 

[Nose]

ParentComponentName=Fuselage

ModelNodeName=Nose

ShowFromCockpit=FALSE

DamageRating=DESTROYED

MassFraction=0.235

HasAeroCoefficients=FALSE

MaxExtentPosition=-0.45,7.5,0.7

MinExtentPosition= 0.45,1.0,-0.42

CollisionPoint[001]= 0.37,8.00,-0.84

CollisionPoint[002]=-0.37,8.00,-0.84

CollisionPoint[003]=-0.43,8.06,-0.23

CollisionPoint[004]=-0.43,8.06,-0.23

CollisionPoint[005]= 0.00,4.04, 1.09

SystemName[001]=InternalGun1

SystemName[002]=InternalGun2

SystemName[003]=Pilot

SystemName[004]=NoseGear

SystemName[005]=Perche

SystemName[006]=BottomFuselageLight

SystemName[007]=TopFuselageLight

 

And later in the 'Internal Guns' section:

 

[internalGun1]

SystemType=FIXED_GUN

GunTypeName=30MM_DEFA553

GunGroup=1

InputName=FIRE_PRIMARY_GUN

MuzzlePosition=-0.3,1.5,-0.3

LightPosition=-0.3,1.5,-0.592

MaxAmmo=125

EjectShells=TRUE

MinExtentPosition=-0.73,3,71,-0.97

MaxExtentPosition=-0.54,5.61,-0.81

 

[internalGun2]

SystemType=FIXED_GUN

GunTypeName=30MM_DEFA553

GunGroup=1

InputName=FIRE_PRIMARY_GUN

MuzzlePosition=0.3,1.5,-0.3

LightPosition=0.3,1.5,-0.592

MaxAmmo=125

EjectShells=TRUE

MinExtentPosition= 0.73,3,71,-0.97

MaxExtentPosition= 0.54,5.61,-0.81

 

Actually while I'm on the subject, the same seems to be the case with the Tornado GR.1A download. I prefer to consider myself a novice modder but I thought I'd bring this subject to the wider modding community in the hope of somebody having a solution. :help:

Share this post


Link to post
Share on other sites

What is the prob, can`t you fire the guns?!

 

Precisely. That's exactly what I CAN'T do. As you can see from the DATA.ini files above, all the bumps seem to be in the right place. Strange innit?

Share this post


Link to post
Share on other sites

Looking over the various gundata ini's I've discovered:

 

1) Defa 552 30mm is a stock weapon

2) Defa 553 is NOT a stock weapon -- and will therefore need to use one or another of the weapons paks.

 

If NOT using a weapons pak, it's suggested to switch it to the 552 (even if historicall incorrect)

 

Best fix: d/l the weapons pak

 

or add this to the gundata ini, and to the 'adding a gun ini dance'... (don't forget to have the guneditor set for Winge98 compatability)

Gun editor also works in WoI

 

[GunData***]

TypeName=30MM_DEFA553

FullName=30mm DEFA 553 Cannon

Caliber=30.000000

ROF=2000.000000

MuzzleVel=1210.000000

AmmoWt=0.247000

WarheadWt=0.024700

Reliability=95.000000

Accuracy=74.000000

AddLight=TRUE

MaxLightRange=1200.000000

FireColor=0.500000,0.450000,0.320000

GunFireEffect=30mmFireEffect

GunFireSound=Cannon

EffectClassName=30mmEffects

EffectTime=0.100000

TracerTexture=Tracer.tga

TracerSize=0.150000

TracerDistFactor=0.002000

TracerLength=0.015000

MaxVisibleDist=4000.000000

MaxStreakVisibleDist=1000.000000

TimeFuzed=FALSE

 

Wrench

kevin stein

Share this post


Link to post
Share on other sites
Ok lets see

 

1. Do oyu have a weaponspack installed?! If not install pls the latest one avaible here at CA

2. Do have set or changed teh controls for the gun?

 

The latest pack is in place for the last 3 month or so and I've left the gun controls on the keyboard as they were from day one. Will just double check now to see if there's been a newer wep pack released.

Share this post


Link to post
Share on other sites

It`s hard for me to say what`s stock cause I moded my installation so heavy that`s nearly impossible to say what`S stock or not.

 

@Ultramax I``ve got here a F1 EE from the spanish ariforce, I`ve reworked the data.ini cause of strange behaviour to the joystickinput. If you want I can upload it. tomorrow. So you can copy paste some stuff

Share this post


Link to post
Share on other sites
It`s hard for me to say what`s stock cause I moded my installation so heavy that`s nearly impossible to say what`S stock or not.

 

@Ultramax I``ve got here a F1 EE from the spanish ariforce, I`ve reworked the data.ini cause of strange behaviour to the joystickinput. If you want I can upload it. tomorrow. So you can copy paste some stuff

 

Cheers bud. That would be a great help, although I don't use any UBS joysticks or throttles. Like you, I've updated the game very heavily so I know how hard it is to keep track of things. Thanks again for your assistance. :good:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..