Jump to content
  • Announcements

    • Erik

      2019 Drive   05/31/2019

      Can you lend a hand?  GET STARTED TODAY
Sign in to follow this  
quack74

Serial # Decal problem

Recommended Posts

I created a batch of 20 random Pfalz D.III serial number decals to be used on the D.III in game. Each plane in a flight will now have its own number. But my problem is, they show up, but only sometimes. In

one mission I'll have 4 D.III all with different serial numbers. The next mission they wont have any. I also noticed sometimes only 1 D.III will have the number out of a flight of 4.

 

I know the game randomly selects decals with a level 2. But how do I get the decal to appear all the time and not just randomly appear? Below is my decal config. It all seems right to me.

 

Do I need to create more decals so there is more of a selection maybe?

(I put the decals in the games main decal folder. Thats why there is no path in the FileFormat. It works both ways)

 

 

[Decal022]

MeshName=Tail

DecalLevel=2

DecalFacing=LEFT

FilenameFormat=SERIAL

Position=-3.20,0.0200

Scale=0.8

DecalMaxLOD=3

 

[Decal023]

MeshName=Tail

DecalLevel=2

DecalFacing=RIGHT

FilenameFormat=SERIAL

Position=-3.20,0.0200

Scale=0.8

DecalMaxLOD=3

Edited by quack74

Share this post


Link to post
Share on other sites

Below are some pics of my problem. They show Pfalz D.III's of Jasta 30.

 

The first pic is single mission #1. All is good. Have serial #'s and Personal markings. The way it should be.

 

 

The second pic Shows the very next single mission w no serial #'s or personal markings. Why?

 

 

The third pic shows the next single mission w no serial #'s again and only 1 personal marking.And WHY? :wacko:

 

Edited by quack74

Share this post


Link to post
Share on other sites

If I start the game from scratch and select Pfalz D.III in single mission, all the personal markings and serial numbers appear.

 

 

But when mission is complete and I choose to fly a second mission w the D.III or even click refly

this is what I get. No marks at all. Why is the game not generating these decals a second time???????

 

 

But if I close FE and restart, all markings appear again. But only once.

I need to figure this out before I post any of the Pfalz D.III skin I made. So if anyone out there knows something, PLEASE HELP! This is driving me nuts. :crazy: Working on this for hours and hours. :shok:

Edited by quack74

Share this post


Link to post
Share on other sites

I think this is what your trying to do is...

 

If you want a certain a\c to have the number and a corresponding graphic such as a motif.....

you must name the number as normal...and the motifs must follow in order...and be named ..eg..

mot000 mot001 mot003

so a\c number num009 would have the motif called mot009

you just name the decal motif in order as per the numbers

if one a\c in the sqd has no motif...then create a blank tga so it is included in the decal list and is missed out when applying a motif..ie....num001 and mot001 is a\c with number and motif...say a\c 3 and 4 have no motif...they will have a num003 and num..and a blank tga called mot003 and mot004

also check you have decallevel number set correctly for the numbers and motifs

Edited by russouk2004

Share this post


Link to post
Share on other sites

The decal folder that I'm using for the above yellow tail aircraft is in the Pfalz D.III folder. The "D" folder. I just created some new decals and serial numbers. All in the correct format and number sequence. The paths in the decal config file are all correct.

 

[Decal001]

MeshName=Fuselage

DecalLevel=2

DecalFacing=RIGHT

FilenameFormat=PfalzD3/Jasta10/D/Personal

Position=-1.5190,-0.0200

Scale=1.60

DecalMaxLOD=4

Reverse=True

 

[Decal002]

MeshName=Fuselage

DecalLevel=2

DecalFacing=LEFT

FilenameFormat=PfalzD3/Jasta10/D/Personal

Position=-1.5190,-0.0200

Scale=1.60

DecalMaxLOD=4

 

 

[Decal003]

MeshName=Tail

DecalLevel=2

DecalFacing=LEFT

FilenameFormat=PfalzD3/Jasta10/D/SERIAL

Position=-3.20,0.0200

Scale=0.8

DecalMaxLOD=4

 

[Decal004]

MeshName=Tail

DecalLevel=2

DecalFacing=RIGHT

FilenameFormat=PfalzD3/Jasta10/D/SERIAL

Position=-3.20,0.0200

Scale=0.8

DecalMaxLOD=4

 

The only decals I have in the "D" folder are "Personal" and "SERIAL". About 30 each.

ex:

Personal001

Personal002

etc, etc.

SERIAL001

SERIAL002

etc,etc.

 

The system does work. All the Personal decals and SERIAL decals are selected rendomly.

But like the photos show. It only works once. One Single Mission. It wont generate a second time.

Also, what is this in some decal config files:

 

[DefaultAnimationTime]

Animation01=0.5

Animation02=0.5

Animation03=0.5

Share this post


Link to post
Share on other sites

Couple of odd thoughts. Do you have a numbers.lst file in that particular skin? And what's the first number in your serial number sequence? Is it 001, 002, etc. Or did you use 000,001,002, etc?

Share this post


Link to post
Share on other sites
[DefaultAnimationTime]

Animation01=0.5

Animation02=0.5

Animation03=0.5

 

This should not be in decal.ini`s

 

 

It's not. I just saw it in the stock aircraft decal config file. I thought I might need it. No biggie

Share this post


Link to post
Share on other sites
Couple of odd thoughts. Do you have a numbers.lst file in that particular skin? And what's the first number in your serial number sequence? Is it 001, 002, etc. Or did you use 000,001,002, etc?

 

 

I dont have a numbers.lst

 

I've seen it done though. Do I need it? but again why wont the game generate the decals for a second mission. They do work for the first mission.

Something is missing here. :dntknw:

 

My Decal numbers all start at 001.

 

All my other decals show up all the time (stripes and individual markings) on the D.IIIs. Just not my serial #'s or Personal .

The Diamond on the side of my Jasta 30 D.III is a decal. It appears all the time. That decal is in the "D" folder in the Pfalz D.III aircraft folder. Just like my personal and serial. Why would that one appear w out problems?

Share this post


Link to post
Share on other sites

It's a stumper, that's for sure. Forgive me if my questions seems obvious, but when I've had problems, it's usually been something so simple that I can't believe I've overlooked it, when I finally figure it out. I would double check to see if the right decal level is specified for these markings. Is there a number missing from the sequence, perhaps. A person you might want to contact is Wrench. Send him a pm. He's really good with decal stuff. I know he's mentioned a glitch in the sim, where the game says I've hit the last number, and then won't reset, so the decals disappear. You might check with him and see if he thinks that's what it is, although, it doesn't seem like it should crop up after just one mission.

Share this post


Link to post
Share on other sites
It's a stumper, that's for sure. Forgive me if my questions seems obvious, but when I've had problems, it's usually been something so simple that I can't believe I've overlooked it, when I finally figure it out. I would double check to see if the right decal level is specified for these markings. Is there a number missing from the sequence, perhaps. A person you might want to contact is Wrench. Send him a pm. He's really good with decal stuff. I know he's mentioned a glitch in the sim, where the game says I've hit the last number, and then won't reset, so the decals disappear. You might check with him and see if he thinks that's what it is, although, it doesn't seem like it should crop up after just one mission.

 

Sounds good. Thks Heck. I'll give him a shout.

Your right about it probably being something so simple. Makes you say duh. :rolleyes:

Share this post


Link to post
Share on other sites

whats happening "i think"

is you are running out of numbers (have a look at loadout before you fly)

when it randomly selects a individual aircraft number for the flight you(player) are always lowest random iirc

and so the next bunch of random numbers selected for the next mission is your AC number + all number of ac in the your flight + some random amount ...it quickly goes beyond 20 = no decal ... restarting the game resets it...

Its kind of a bug really i guess ...

I don't think it affects the campaign (for a while anyway) as your squady's keep their numbers till they are mia/kia

and if you use a numbers.lst its easy (but boring) to select numbers in the loadout screen for single missions

no solution i know of except to have a bucket load of level 2 decals (what happens in stock, 100+) :blink:

 

the animation stuff should be there, its a newer feature...

Share this post


Link to post
Share on other sites
What is the animation Stuff? What does it do? And what if I created more decals?

 

Not sure about the animation stuff. I think, but I'm not sure, if you create more decals the problem will not appear as often, but it will appear sooner or later, because of what p10ppy pointed out; the number of decals+some random #, etc. I can't be sure of this, but I've often created a few more decals than the game is likely to put in the air, say 24 or more, and it seems to lessen the problem. Also, if you create a decal called say, Serial.tga, ie: one without a number, but the same name, the game will put that decal on all aircraft it can't number, so I've seen the situation where my first few aircraft were sequentially number, and then every aircraft after that had the same decal.

 

The only way to cure this is to make 100 serial numbers and 100 personal markings. Another thing you can do is create 100 decals, for your personal markings say, but purposely create some blank decals in the sequence, like 001 is a sword, 002 Thor's Hammer, 003 is a blank .tga with no image, the same with 004, 005 is my pet cat, etc, until you reach the magic 100 that the game wants. You could do this with serial numbers too, because many aircraft had their serial numbers painted out, or not replaced after a repair...

Share this post


Link to post
Share on other sites

not sure about the animation stuff really either :blush:

I've always assumed it was for the overall timing/speed of a given animationID (e.g Animation01 = animationID=1 in the data.ini)

there is

MaxPowerAnimationTime=0.1

MinPowerAnimationTime=0.2

in the data.ini engine section which does that for the engine animation

but why that stuff is in the decal.ini :dntknw: (and its only a guess...i've never seen anything written about it and i think it appeared with the expansion pack)

 

more decals will mitigate your problem somewhat (i usually do about 40 for generic great war skins, depends on how complicated the decal is)

and of course it looks silly for AC numbers, they never seem to go much over 20....

The default unnumbered decal never used to work as advertised but it could have been fixed in one of the later patchs :dntknw:

there's also the new alias list to play with...http://bbs.thirdwire.com/phpBB/viewtopic.php?f=14&t=5734

and you also can make repeats of your sn.tgas i.e

the set of tga's copied multiple times and each set renamed to the next batch of numbers (eg SN001-SN020.tga copied and renamed SN021-SN040.tga, repeat...)

a bit of a hack but it works... :wink:

Share this post


Link to post
Share on other sites

I think I solved it :yahoo: . I think I just didn't have enough decals. I only had about 30 or so for SERIAL #'s and Personal. I created 99 SERIALs and 80 personals. Now they both appear all the time. I forgot the game also uses the decals for the Stationary D.IIIs. That would eat up the decal inventory as well. I also notice the game cycles through the decal folder I think every three missions. Or maybe it depends on the number of D.III's you use. Anyway it seems to work now. Thanks everybody for your input. :good:

It's nice to know you all want to help :clapping: .

 

You will be able to use the "Personal" decals in the game decal folder or use the ones in the Pfalz aircraft folder ("D"). You would just need to change the wording in the Decal Config File for whatever skin you use. The "D" folder contains some game decals and some I re colored and made. More black. Looks good for the Pfalz I think anyway.

 

I'll explain more in the readme files when I post the new skins.

 

Again thanks everybody. And Heck, It was kind of a "Duh" thing. Just needed more decals :rolleyes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..