Jump to content
Sign in to follow this  
Bigfish2

Latest good Nvidia drivers?

Recommended Posts

Earlier in the month there was a conversation in the Forum about the latest 190.38 Nvidia Forceware drivers, which turned out to be duff. I went back and reinstalled 182.06 which happened to be hanging around as a zip file in my PC. I wondered if any of you PC gurus have a view on whether there's a later set which is stable and works properly with OFF? Or shall I not fix it as it ain't broke? (see, I learned something!)

Share this post


Link to post
Share on other sites

I'm on 182.06 as well...they seem fine!..my advice (for what it's worth) is the same as yours...Don't fix what aint broken

Share this post


Link to post
Share on other sites

One of my mantras as well. That, coupled with the KISS approach to problem solving, has kept me in good stead more often than not.

 

Cheers!

 

Lou

Share this post


Link to post
Share on other sites

Thanks guys, I know it makes sense! Widowmaker, that wasn't a PLASTIC floating tigernut was it?!!

Share this post


Link to post
Share on other sites
Thanks guys, I know it makes sense! Widowmaker, that wasn't a PLASTIC floating tigernut was it?!!

 

It most certainly was!...One of the Enterprise Tackle ones! :yes:

Share this post


Link to post
Share on other sites

Many thanks Cptroyce, despite my promises not to fiddle about, I installed 186.18 and they're just fine, and my impression is that the frame rate has increased. But now I really will leave them alone at least until Nvidia sorts out the 190.38 drivers.

Share this post


Link to post
Share on other sites
Many thanks Cptroyce, despite my promises not to fiddle about, I installed 186.18 and they're just fine, and my impression is that the frame rate has increased. But now I really will leave them alone at least until Nvidia sorts out the 190.38 drivers.

 

Wow.. has it been that long.. I'm using v169.21, guess it's time to update. :blush:

Share this post


Link to post
Share on other sites

I'm shocked and appalled that Rabu one of my OFF heroes should be so seriously out of date - or perhaps just being very careful not to take any chances with dodgy drivers?! Frame rates do now seem to hover around 59 quite a lot of the time (capped at 60) and seldom fall below 35; whether this is due to the driver version, the latest minipatch, or wishful thinking on my part, who knows?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..