Jump to content
Sign in to follow this  
incryptx

Unable to purchase OFF BHaH or RITH from Avangate

Recommended Posts

To the developers or authors of OFF BHaH/RITH

 

For the last month, I have been trying to purchase both of these products.

 

The "Buy Now" button on the website goes to https://secure.avangate.com/order/checkout.php?PRODS=1628794,1628834&QTY=1,1&CURRENCY=USD

 

but then freezes about thirty percent and then nothing. No purchase pages from Avangate.

 

I have contacted support@avangate.com and they claim it works fine.

 

I have tried everything, disabling my firewalls, malware, antivirus, firewall rules, but still nothing. I have tried this from Unix/Linux, both Ubuntu and PCLinux OS and still nothing. Avangate then blamed it on my browser claming Java was not installed, but it is and was. Then they blamed my network and firewall, but it's not. I have tried the "Buy Button" on neighborhood machines, library machines, and government machines, and still no joy.

 

To date, I have tried this "Buy Button" from some 140 machines, using both Firefox and IE, on Unix, Windows 7, Windows Vista, Windows XP and Windows ME, and still the same result.

 

My bank uses Java and Adobe Flash for security login, and I have no problems using my machines to bank, or make purchases on sites like Amazon, Overstock.Co, or any other site. Just Anvangate.

 

The only thing I can think of now is that the Publishers have suspended sales in the U.S., but Avangate claims this is untrue.

 

I have great expertise in the computer industry, having worked for Microsoft actually building and testing both Operating Systems, Browsers, Firewalls, Networking Protocols and Group Policies, yet I am unable to discover why the "Buy Button" does not work.

 

So, I am tired of troubleshooting Anvangate's network and purchase issues. I just want to purchase the game.

 

Would the publishers of this game please contact me at "support at cvscorp dot com" and make some arrangement to sell me the game?

 

If anyone else has experienced this, or has a solution, please post it.

 

Thanks.

Share this post


Link to post
Share on other sites

Welcome,

This is almost a joke. I imagine how frustrating it is.

I suppose you've already tried away from your network?

I'd say, it must be something locally, regionally. It doesn't make sense.

I hope sincerely that the devs/publishers can help you.

Share this post


Link to post
Share on other sites

No joke.

 

Common sense would say this is a local network issue, but, as I stated, I've tried it form neighbors machines, library machines and government machines, and I am unable to get to Avangate's purchase pages for this product. I'm very good at solving local network issues, but this one makes no sense.

 

Since I run a Windows Home Server and have port 443 (https) forwarded, I thought it might be this, but this port forward does not exist on the above mentioned machines.

 

I just want to buy the d$#&* game, not troubleshoot my or Anvangate's networks.

 

As far as my network, it's 100% and I have no other issues, including my own hosted server. Everything else, banking, on-line purchases, stock trading, server and game hosting all works without a glitch.

 

My last resort is attempting to reach the publishers on this forum, to call me and take my payment info manually. I could pay them with pay-pal or credit transaction through pay-pal.

 

You will notice many blurbs on the OFF site to ignore Avangate's download and license emails. Seems the publisher may have no choice but to use them for financial transactions in the U.S.

 

Thanks for your concern.

Share this post


Link to post
Share on other sites

Problem Solved. Learn something new every day.

 

My sincere apologies to Avangate. It was not their fault.

 

As it turns out, the government machines regardless of OS, block port 443 unless it's an official government secure site. The library machines block port 443 to prevent/protect users I.D. and credit card info, so, 135 of these machines will not allow transactions to Avangate, or any service using HTTPS on that port.

 

The five neighborhood machines are our private gaming network and connect to my Windows Home Server and Game Server via P2P, and have port 443 disabled, in favor of port 8080 being used for HTTPS instead. This allows port 443 to be limited for use by the WHS server for SUS updates only.

 

In short, it was a "port 443 blocked/redirected" problem, and only when I checked with the sysadmins of the government and libraries, did they reveal this.

 

Just my bad luck, and although machines used were randomly chosen, Murphy's law prevailed in having port 443 block/redirects on all.

 

Man, what a hard thing to figure out.

 

So, be careful what you do with port 443, as a misconfiguration will prevent you from buying this game.

 

OOPs.

Share this post


Link to post
Share on other sites

Now you just have to read uncleal faq: :grin:

 

Install Order:

 

1. If you have older CFS3 CDs, assume that they are version 3.0. If so, install CFS3, and patch it to 3.1 (obtain patch here: http://www.microsoft.../downloads.aspx). Then run the game briefly.

Note: Many newer CFS3 CDs (e.g., bargain version recently offered by Best Buy) are already 3.1. If you own one of these, you DO NOT have to install CFS3 first, but need to have the CDs

ready when you install BHAH.

2. Install BHaH from DVD. Insert CFS3 CDs when asked (if using CFS3 v3.1). Note: BHaH is only available on DVD, no downloads.

3. Download and install BHaH SuperPatch v1.32, followed by MiniPatch v1.32g (found here: http://www.overfland...wnloadsBH&H.htm)

4. Download and install HiTR (purchase info here: http://www.overfland....com/Addon1.htm) Note: available only by download.

5. Download and install HiTR MiniPatch v1.47 (available here: http://www.overfland...m/Downloads.htm)

 

After you install as per out lined, you should set up as per the FAQ http://www.overfland...on_and_settings

 

And of course the video card http://www.overfland...ds.com/Tips.htm

 

Answers to most Newbie questions are featured in

 

OFF Tips & Cheats STICKY in the Knowledge Base

 

This Simulation has rather steep learning curve

 

If you can't find an answer in one of the many Stickies

 

It's sure as heck going to be in the official FAQ

 

http://www.overfland...lds.com/FAQ.htm

 

Everything is written down Somewhere

 

If you have what you think is a screwy question, ask it

 

The only stupid question, is the one that's never asked

 

 

Just a word to the wise, even with all the bells and whistles. MAX setting on the Terrian Slider is 4, to prevent any possible future problems

 

© uncleal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..