Jump to content
Sign in to follow this  
GregSM

Trouble with dense overcast

Recommended Posts

Hi All,

 

 

I have just got a new notebook which I'm struggling a little to optimize for OFF. Specs are as follows:

 

Clevo/Sager NP8690

Core i7-620M, 2.66-3.33GHz

6GB DDR3, 1333MHz

ATI Radeon HD 5870, 1024MB DDR5

 

Windows 7 Home Premium 64 bit

Catalyst 10.7

 

Generally OFF runs very well, but there's this exception: when the sky is fully overcast, and only when looking upwards such that the sky fills the display (no or little terrain/airframe rendering), framerates drop dramatically, into the high-teens. To no avail, I've tried resolving this via game settings as well as Catalyst Control Centre settings. For instance, the cloud detail slider has little impact. In dense cloud, a setting of one produces nearly the same framerates as a setting of five. Reducing screen resolution produces mildly positive gains, but I'd rather not lower the resolution due to fuzziness when running outside of native resolution.

 

Again, this trouble only occurs during heavy overcast, and only when the overcast sky fills the display.

 

Failing a proper solution, would it be possible to simply remove the dense overcast texture, or to replace it with a lighter version?

 

Any help will be warmly received.

 

 

Cheers,

 

 

Greg

Share this post


Link to post
Share on other sites

Hi!

 

Ok, I'm not any kind of expert, but for one GB of Video RAM, the quality of textures shouldn't be the problem (It should load them all), but since clouds are "transparent" in the edges, the high workload of transparency Anti-Alias may be what slows your frame rate. If you can lower the transparency AA (or general AA) you may get better FPS but the cost is that the edges won't be puffy and will get a kind off "stairs". Again I'm not an expert... but try and see... you have nothing to loose (except 1-2 mins).

 

 

Share this post


Link to post
Share on other sites

Yep I'd say play with AA and Aniso settings, and related settings in your ATI panel. Make note or save current settings of course.

Also noted smoke effects were slow on my ATI 5780 in some games with AA etc on them. Not sure that was drivers or just the way it is currently. Swapped for an NVidia 480, much happier, but not much of a chance of that in a laptop.

Share this post


Link to post
Share on other sites

It isn't aa or aniso. Rather, I suspect it's an ATI driver or hardware thing. But thanks for the suggestions gents. Lowering resolution will need do for now.

 

 

Cheers,

 

 

Greg

Share this post


Link to post
Share on other sites

It isn't aa or aniso. Rather, I suspect it's an ATI driver or hardware thing. But thanks for the suggestions gents. Lowering resolution will need do for now.

 

 

Cheers,

 

 

Greg

BHaH usually runs better at higher resolutions. The type of AA you set in Catalyst Control Center matters a lot when it comes to clouds...Super-sample AA brings my machine to a crawl, but Multi-sample AA works fine.

Share this post


Link to post
Share on other sites

After much – much! - experimentation, I've discovered that this problem is solved completely by disabling “Virtual Cockpit Fog” in overrides. (And I can't notice any graphic degradation.)

 

I hope this is useful to someone.

 

 

Cheers,

 

 

Greg

Share this post


Link to post
Share on other sites

After much – much! - experimentation, I've discovered that this problem is solved completely by disabling “Virtual Cockpit Fog” in overrides. (And I can't notice any graphic degradation.)

Greg,

 

THIS IS EXTREMELY HELPFUL!!! I tried your override and for the first time can fly the quick scenario "Balloon Busting with Camels" with Super-sample AA. Multi-sample or Adaptive Multi-sample AA work fine, but don't get rid of minor jaggies in the landscape when on the runway. IF I use Super-sample AA, the jaggies disappear, but it kills my framerate in heavy clouds.

 

FWIW, here are my settings with an ATI 5770, Catalyst 10.8 in Windows 7 64 bit:

 

Sliders 54455, Resolution 1920X1080, AA Off in CFSConfig, set Overrides as per the FAQ, including Virtual Cockpit Fog

 

Catalyst Control Settings: 2X AA (6 Samples, Wide Tent), AF off, Catalyst AI off, Mipmap Detail Level on Quality, Wait for Vertical Refresh Always On, AA Mode set to Super-sample, OpenGL Triple Buffering On. I also run D3D Overrider in the background to allow VSync with ATI drivers.

 

In furballs (6 planes) over the airfield, FPS ranges from 40-60, heavy clouds averages 35, sometimes dropping to 25. Game looks absolutely fantastic.

 

BIG, BIG IMPROVEMENT with your override. THANKS!!

Share this post


Link to post
Share on other sites

Hi BirdDog,

 

 

I'm glad this has helped you!

 

As for me, I spoke a little too soon – disabling in cockpit fog causes texture corruption at the horizons, such that sections of the horizon appear to be discoloured or washed-out.

 

Do you see this problem too?

 

 

Cheers,

 

 

Greg

Share this post


Link to post
Share on other sites

Hi BirdDog,

 

 

I'm glad this has helped you!

 

As for me, I spoke a little too soon – disabling in cockpit fog causes texture corruption at the horizons, such that sections of the horizon appear to be discoloured or washed-out.

 

Do you see this problem too?

 

 

Cheers,

 

 

Greg

 

I let my enthusiasm get away with me. I'm now seeing the problem you mentioned. Backing off the sliders doesn't help...the only solution I've found to better framerates in heavy clouds is to lower the amount and type of AA. Looks like I'm back to my old settings. Nothing wrong with them...still looks great.

Share this post


Link to post
Share on other sites

I let my enthusiasm get away with me. I'm now seeing the problem you mentioned. Backing off the sliders doesn't help...the only solution I've found to better framerates in heavy clouds is to lower the amount and type of AA. Looks like I'm back to my old settings. Nothing wrong with them...still looks great.

Being an obsessive compulsive kind of guy, I can't resist the temptation to beat a dead horse within an inch of it's life.

 

I decided to do more testing...and it confirms that the level of AA and AF makes a big difference in heavy clouds. I set CFS3config AA to 8X, and tested a number of AA combinations in Catalyst 10.8 using Adaptive Multi-sample AA (I havent found much difference between Multi-sample and Adaptive Multi-sample AA. Super-sample AA is typically used only with dual GPU systems). I aso left Catalyst AI to Standard

 

My test was the Balloon Busting with Camels Quick Scenario, which has very heavy overcast weather over the front lines.

 

AA Level---Samples----AA Level-------AF-----Avg FPS

---8X------------24-----------Edge---------16----------20

---8X------------16--------Wide Tent-----16----------22

---8X------------12-------Narrow Tent---16----------22

---8X-------------8------------Box----------16----------22

 

Not much difference...my 5770 graphics card is maxed out. What about the effect of AF?

 

---8X------------24-----------Edge--------Off----------22

---8X------------12------Narrow Tent----Off---------22

---8X-------------8------------Box----------Off---------29

---2X-------------2------------Box----------Off---------32

 

So I now have a firm grasp of the obvious. Turning AF off and reducing the amount of AA samples definitely helps, without any significant loss in appearance.

Edited by BirdDogICT

Share this post


Link to post
Share on other sites

Yeah thought it might be partly AA/AF, I found my ATI 5870 much slower at higher AA settings than my previous old NVidia (8800GTX), AA set to the lowest type (Box?) and 4x in CFSconfig and 8X in ATI panel was good but anything more and fps dropped a lot.

Share this post


Link to post
Share on other sites

I'm still struggling with this! And it's definitely not a matter of AA or anisotropic filtering.

 

As I've mentioned, reducing resolution eliminates the frame-rate plunge induced by heavy overcast. But, despite high frame-rates, stuttering remains when looking at the clouds.

 

Oddly, this stuttering can in turn be eliminated by turning on “info cycle” (“z” key).

 

I wish there were some other way as all that red text is a distraction.

 

 

Cheers,

 

 

Greg

Share this post


Link to post
Share on other sites

Here's a tip for anyone with an Ati card and this particular trouble: try setting the anti-aliasing mode to “Adaptive Multi-sample”. Normally, this lowers frame-rates somewhat in relation to the standard “Multi-sample” mode, but with my OFF installation it killed most of the stuttering.

 

So evidently this trouble is related to AA after all.

 

 

Cheers,

 

 

Greg

Share this post


Link to post
Share on other sites

Here's a tip for anyone with an Ati card and this particular trouble: try setting the anti-aliasing mode to “Adaptive Multi-sample”. Normally, this lowers frame-rates somewhat in relation to the standard “Multi-sample” mode, but with my OFF installation it killed most of the stuttering.

 

So evidently this trouble is related to AA after all.

 

 

Cheers,

 

 

Greg

That makes sense. Adaptive Multi-sample AA is designed to improve AA of transparent textures, something you would expect in Winder's clouds.

 

Glad you got it sorted.

Share this post


Link to post
Share on other sites

The latest Catalyst drivers, 10.11, solve this old trouble. Now, I maintain frames in the mid-high forties in dense overcast, with little or no stuttering.

 

(The FSX guys are delighted too as this has been a long standing problem for them.)

 

So if you're using older versions still, give these later drivers a trial!

 

 

Cheers,

 

 

Greg

Share this post


Link to post
Share on other sites

The latest Catalyst drivers, 10.11, solve this old trouble. Now, I maintain frames in the mid-high forties in dense overcast, with little or no stuttering.

 

(The FSX guys are delighted too as this has been a long standing problem for them.)

 

So if you're using older versions still, give these later drivers a trial!

 

 

Cheers,

 

 

Greg

Greg,

 

Glad you mentioned this...I noticed the same thing. In fact, I can now use supersample AA (as long as I turn terrain and scenery down a notch or two) and it looks great with FPS 40-60.

 

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..