Jump to content
Sign in to follow this  
themightysrc

A new show stopper - help requested

Recommended Posts

Hi all,

 

Having (apparently) sorted out my sound gremlins, it looks like there's more buggeration afoot.

 

I now have sound, and the briefings come up fine, as does the last minute weather report page, but click OK and up it pops:

 

'Run time error 48: File not found: OFF.dll'.

 

I know that I have copies of this scattered hither and yon across the system, but I suspect that the copy I need is either gash/corrupt or altogether absent.

 

Where should this file live? If I can pop a copy straight in, great, if I have to reinstall, I'll scream.

 

Any mods reading - what's the path for this baby?

 

Cheers,

Si

Share this post


Link to post
Share on other sites

In my install (HitR with latest patch, if that makes any difference) my OFF.dll is in the main game folder ie C:\OBD Software\CFS3 Over Flanders Fields. It's dated 1/10/2009. If it's corrupted, and was updated by one of the patches, I wonder if you may be able to get away with installing the various OFF patches, in sequence.

 

Take it you've already tried the 'reset OFF' option in the Workshop, not sure what that actually does apart from simultaneously retire all pilots but it's got me out of trouble once.

Share this post


Link to post
Share on other sites

Thanks Lima33 - I'll have a think about that. I might just reload HitR and if that helps. And I guess there's always OBD support....

Share this post


Link to post
Share on other sites

Check you don't have something deleting or interfering with OFF.dll. It should reside in your CFSWW1 Over Flanders Fields folder no where else.

 

Otherwise sounds like corrupt install.

 

Check your hard drive for errors, and if all else fails you will need a good clean out and proper reinstall.

Share this post


Link to post
Share on other sites

Thanks Pol - I'll check that out, particularly as I still have an ongoing (but containable) problem with svchost.exe going bananas on a regular basis. Perhaps a full reformat and reinstall will turn out to be the answer.

Share this post


Link to post
Share on other sites

...as I still have an ongoing (but containable) problem with svchost.exe going bananas on a regular basis.

My money would be on stopping "index services". Even when idle, it's continuously searching for files and consuming resources.

 

Sorry I can't help with .dll file.

 

plug_nickel

Share this post


Link to post
Share on other sites

My money would be on stopping "index services". Even when idle, it's continuously searching for files and consuming resources.

 

Sorry I can't help with .dll file.

 

plug_nickel

 

 

Yeah if there's a lot of stuff showing up as running in Task Manager it might be a good idea to apply Black Viper's tweaks to the underlying services. Been using his recommendations myself for ages, just use services.msc like he says;

 

http://www.blackviper.com/

 

...also maybe run msconfig and look at unticking any processes in the 'Startup' tab that you don't need, usually there's one or two.

Share this post


Link to post
Share on other sites

Well. I did it.

 

Full reformat of the hard drive, having pulled off as much data as I could, including HitR and the various patches. Really thought this would be OK. I've loaded CFS3 - it's complaining about the lack of DirectX8 - but that's the least of my problems.

 

I reloaded OFF3 dvd into the drive - and it can't find any files whatsoever on the dvd. None. Empty dvd as far as it's concerned.

 

So farewell not on Major Vic Timm, but also, apparently, OFF at all.

 

At the moment, I'm so pissed off that I really don't know how to react to all of this. I had, until late last week, OFF patched up perfectly and working as well as it ever has. Now I've got absolutely sod all. No OFF at all. Any ideas on miracles?

Share this post


Link to post
Share on other sites

Did you cross check the OFF dvd on another drive on another computer? It doesn't make sense that the OFF dvd isn't being read unless it's been magnetically damaged somehow.

 

plug_nickel

Share this post


Link to post
Share on other sites

Well. I did it.

 

Full reformat of the hard drive, having pulled off as much data as I could, including HitR and the various patches. Really thought this would be OK. I've loaded CFS3 - it's complaining about the lack of DirectX8 - but that's the least of my problems.

 

I reloaded OFF3 dvd into the drive - and it can't find any files whatsoever on the dvd. None. Empty dvd as far as it's concerned.

 

So farewell not on Major Vic Timm, but also, apparently, OFF at all.

 

At the moment, I'm so pissed off that I really don't know how to react to all of this. I had, until late last week, OFF patched up perfectly and working as well as it ever has. Now I've got absolutely sod all. No OFF at all. Any ideas on miracles?

 

I'm assuming that the DVD drive has similar problems with at least some other CDs or DVDs? Does the OFF DVD 'spool up' a bit in the drive and then go quiet (rather than you being able to open if and see it as an empty disc)?

 

If those are the symptoms them your drive may be reverting from DMA mode to PIO mode, happened to me sometimes with XP; easy way to check is to open the IDE ATA/ATAPI controllers entry in Device Manager, find the IDE channel your DVD drive uses, and check its Properties/Adavnced settings tab. There, under 'Current Settings' you should see something like 'Ultra DMA mode 6'. If it says PIO mode then the channel has reverted to a crap setting (technical term, there) and will have trouble reading DVDs and CDs.

 

Happened to me a couple of times; Google DMA reverts to PIO to get a solution, IIRC I used # 6 here, it's not as complex as it looks the first sentences describe what's done the rest is tech-waffle:

 

http://winhlp.com/node/10

 

Worth checking in Device Manager that it's not PIO. If not sure which channel your DVD drive is using, check 'em all.

 

Gawd, don't you just LOVE PC's, IBM and Charlie Chaplin have a lot to answer for.

Share this post


Link to post
Share on other sites

Hi Lima (and everyone else),

 

 

Such is my obsession with this set of ones and zeroes, I couldn't just lt it lie, so I copied the contents off the OFF installation DVD via my missus' PC (bless her) to a USB drive, and now have all these files not only installed on my PC (Yah! Go me!) but also on the hard disk of my PC (hurrah, etc..).

 

What I need now are:

 

1. The order in which I load up the OFF patches (I've got HitR, so all patches for that are needed too), and which ones I'll need, and, more importantly,

2. Having patched (as far as I can tell) CFS3 to 3.1 (which I'll save off), I've still got this bollocks about my hardware not supporting Directx8, when I know for a fact it was working with this hardware less than a week ago, which I'm guessing was DirectX9 or maybe more.

 

Has anyone else had this, and how did you solve this? If any of the OFF mods are reading - please help. I've managed to get OFF back, which is wonderful, but this ridiculous CFS3/Directx8 message (and shutdown) is deeply frustrating. I know that it's not your doing, but this program (CFS3) did work, although when I first installed it, I will admit it was a poxy video card which I subsequently replaved with the best that I could afford with my rubbish rig and restricted monies.

 

In fact, any and all suggestions gratefully received: I just want to get back up there again...

 

Cheers,

SI

Share this post


Link to post
Share on other sites

Try running dxdiag and see what version of DirectX you're on (it's sort-of buried in the long version number on the first page of the dxdiag diagnostic report, IIRC) and whether it reports any probs. Have you tried D/L'ing & (re-?)installing DX9.0c from MS? Or DX10 if your card supports it? I gather there's no prob in installing more than one version of DirectX and anyway the installer checks if you have the files before it installs them.

 

After reformatting I presume you re-installed Windows - XP is it? Did you patch XP right afterwards, to latest version ie Service Pack 3? An update to SP3 I think should get you DX9.0c if you haven't already updated. Sometimes it takes a while for automatic updates to 'catch up'. IIRC Win XP had DX8 when it came out, DX9 arrived soon after. Maybe you have DX8 after your fresh install but need DX9, maybe it's your graphics card that needs DX9 and is objecting to DX8, dunno if backward compatibility is a prob there.

 

Dunno if your unorthodox install could cause any probs. Dunno very much do I? :)

 

Patch order is I think apparent from the OFF website for BH&H and HitR, here, apply patches for the former then those for the latter, that's what I did anyway: http://www.overflandersfields.com/Downloads.htm

 

Good luck!

Share this post


Link to post
Share on other sites

What I need now are:

 

2. Having patched (as far as I can tell) CFS3 to 3.1 (which I'll save off), I've still got this bollocks about my hardware not supporting Directx8, when I know for a fact it was working with this hardware less than a week ago, which I'm guessing was DirectX9 or maybe more.

You need to download and install MS Dx9.0C Redistributable dated June, 2010. It will fix your problem. It'll update Dx8 to 8.1 which is what you need now and also bring your Dx9 up to date as well.

 

If you're running a later card with current drivers, Dx10 is broken, in that, it has corrupted or eliminated many of the links in Dx8/9. MS finally came out with the June,2010 release to take care of that problem.

 

plug_nickel

Edited by almccoyjr

Share this post


Link to post
Share on other sites

Thanks to both 33Lima and plug_nickel.

 

I'm exploring this as I speak - I can confirm that th device drivers for the ATA/ATAPI controllers as just as they should be. The fact I could (and still can) 'see' the CFS3 disks sort of confirms that too.

 

I've already patched XP to SP3 and CFS to 3.1 (I think - I can't confirm because I can't get very far due to this DX8 error message nonsense). Thanks for the tip on the loading order for all the patchs and HitR: let's hope I get that far!

 

I'm loading DX9.0c as we speak, so I'll soon know if I'm back in business. Fingers crossed.

 

On the off chance (Ha! Ha! OFF chance! Hilarious!) that everything springs back into life, does anyone have a copy off their CFS3 vid/etc settings? It would probably save me a lot of vital flying time!

 

Cheers,

Si

Share this post


Link to post
Share on other sites

Right - latest update.

 

Sapphire Radeon 2400 drivers reloaded, along with Directx9.0c - everything is working when I try CFS3 (cue sound of mass cheering). Trackir sort of behaving itself (not in CFS3, but I think I F9'd when I shouldn't have). I'm confident on that. Sound - perfect; Sidewinder 2 doing exactly what it should do.

 

All I'm missing, apparently, is this:

 

C:\documents and settings\me\application data\microsoft\CFSWW1 over Flanders Fields\ConfigOverrides.xml

 

Is there a quick way round this? I've done the CFS3 obligatory chasing Me109s around in a Spitfire IX (actually got one too!), which I'd supposed created this file? Haven't loaded anything else in the way of OFF updates or HitR.

 

Advice?

 

Cheers,

Si

Share this post


Link to post
Share on other sites

Right - latest update.

 

Sapphire Radeon 2400 drivers reloaded, along with Directx9.0c - everything is working when I try CFS3 (cue sound of mass cheering). Trackir sort of behaving itself (not in CFS3, but I think I F9'd when I shouldn't have). I'm confident on that. Sound - perfect; Sidewinder 2 doing exactly what it should do.

 

All I'm missing, apparently, is this:

 

C:\documents and settings\me\application data\microsoft\CFSWW1 over Flanders Fields\ConfigOverrides.xml

 

Is there a quick way round this? I've done the CFS3 obligatory chasing Me109s around in a Spitfire IX (actually got one too!), which I'd supposed created this file? Haven't loaded anything else in the way of OFF updates or HitR.

 

Advice?

 

Cheers,

Si

 

What is it that's telling you you're missing this file - an error message when you trry to do what - run OFF to get into OFF Manager? Run a mission (=get into CFS3) after that?

 

Configoverrides.xml IIRC is the file that holds the settings you make when you run CFS3config - you know, the one with the detail sliders, over-rides, texture limits etc. Which you can either run by clicking on the cfs3config.exe file itself, in the CFS3 (for CFS3) or CFSWW1 OFF (for OFF) root directories; or run from inside OFF's Workshop (for OFF only, naturally), by using the 'set config' button. Not sure why you're missing one, maybe your unusual install procedure?

 

Try running config from OFF Manager, choose your settings as per Olham's guide as usual, set screen res, set sliders, in over-rides turn off dual pass render and do all the usual good stuff. Save settings and hopefully that will create a Configoverrides.xml for you, in the right place.

 

Of if that does not work, find Configoverrides.xml in your equivalent CFS3 App Data folder and copy it across to your OFF App Data folder (path as per your post). I think it should be the same file for CFS3 and OFF and interchangeable, tho it will bring over your CFS3 settings into OFF, so you may have to run config from OFF Manager to change them if you need to.

Edited by 33LIMA

Share this post


Link to post
Share on other sites

PS forgot you asked about settings, I use Olham's here, for CFS3config:

 

http://combatace.com...graphics-setup/

 

...with my own choice of settings for the other OFF Manager settings, eg aircraft skins hi-res (managed this ok even with my budget 9300GS, now have a slightly older but much better 8800GT), object density medium, guns easy/less accurate, fuel/ammo load rather than unique skin to balance out the AI flying at unladen weight etc etc

 

PS should have said in the first post, I believe your CFS3 and OFF installs are entirely independent, doing anything which sets up CFS3, won't help OFF; hence they have separate cfs3config files, and each needs run separately, for the sim whose folder it resides in, CFS3 or OFF, creating separate configoverrides files.

Edited by 33LIMA

Share this post


Link to post
Share on other sites

Also don't forget if this is Vista or Win 7 you need to set CFS3.exe to run in compatibility mode (XP SP3 should do it) See the FAQ on our main website - all this is in there including exactly which patches to install in which order etc (near the top).

Share this post


Link to post
Share on other sites

Thanks Pol - I'm on XP SP3 as it happens, but if I ever get employed again, a new PC with W7 is a priority (after a car, carpet, new sofa, holiday, some windows, etc, etc), however I'll check out the running order for the updates, all of which I have downloaded, thankfully. I'm only just back from a week away after the second family death in two months, so OFF matters haven't loomed large. I'll try to get myself sorted out ASAP.

 

Cheers,

Si

Share this post


Link to post
Share on other sites

Hi Pol,

 

Many things sorted, including OFF, as I took up a new pilot and downed some Huns - hurrah! So, my OFF P3 was fine.

 

And then I added HitR and the associated upgrades.

 

Now, when I try to fly a mission with my (sole) pilot, I get

 

"Populate Airfield Facility: Aircraft Set Up error"

 

and then

 

"Mission file failed to load".

 

What's the issue? How do I get round it? OFF was fine until I chucked in the updates and HitR, now it's gone tits up.

 

Any help appreciated.

 

Cheers,

Si

Share this post


Link to post
Share on other sites

Could be a bad one, normally means you forgot to update BH&H fully to 1.32G, BEFORE installing the HITR addon.

 

This one is in the FAQ under;

9) HAT IN THE RING EXPANSION - KNOWN ISSUES;

 

http://www.overflandersfields.com/FAQ.htm

 

got there hit Ctrl+F in your browser ans search for

Populate Airfield Facility

 

and it should find it

Share this post


Link to post
Share on other sites

Hi Pol,

 

Thanks for the reply. I thought I'd done all the relevant updates, but I might well have missed one of them - there are a few! I'll probably delete OFF and CFS from my rig and start over. Just as a matter of interest once you have OFF P3 on your PC, what updates, and in what order do they go on?

 

Cheers,

Si

Share this post


Link to post
Share on other sites

All in the FAQ... how to install BH&H and HITR and which updates in which order is listed clearly, click the "Installation and Graphics" button in the FAQ brings you to...

 

http://www.overflandersfields.com/FAQ.htm#Installation_and_settings

 

The FAQ is for all this basic stuff, always check through there first.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..