Jump to content
Sign in to follow this  
FLOGGER23

Half Sound in some Guns

Recommended Posts

 

Gents, i`ve been trying to make some fixes in my guns sounds pack, for some reasons some of them sound like muted, like if they have a silencer, like if they sound boom boom boom, all you can hear is tup, tup, tup, if it makes sense, the one i`m workin on is the 57MM and 85MM, which i`m adding for you you check and help me to fix:) any and all help is greatly appreciated, the configuration i have in the Soundlist.ini is:

 

[57MM]

Priority=HIGH

Looped=TRUE

NumBuffers=8

3DSound=TRUE

DopplerEffect=FALSE

MaxDist=1500.000000

MinDist=400.000000

InsideConeAngle=360

OutsideConeAngle=360

ConeOutsideVolume=0

 

[85MM]

Priority=HIGH

Looped=TRUE

NumBuffers=8

3DSound=TRUE

DopplerEffect=FALSE

MaxDist=2000.000000

MinDist=50.000000

InsideConeAngle=360

OutsideConeAngle=360

ConeOutsideVolume=0

 

they are associated to the attached sounds.

 

 

TIA for your help.

 

 

 

Share this post


Link to post
Share on other sites

Simple answer: ROF (Rate Of Fire), and burst length. If the sound file is too long (even echos will effect that), it wont match the burst length, hence, part of the sound will be cut off.

Edited by Fubar512

Share this post


Link to post
Share on other sites

Simple answer: ROF (Rate Of Fire), and burst length. If the sound file is too long (even echos will effect that), it wont match the burst length, hence, part of the sound will be cut off.

 

 

I thought about it, and cut them, i used Nero Wave Editor, i even created another one in a sequence but still no joy here is the other created:

Share this post


Link to post
Share on other sites

Since these guns are single shot simply change Looped=TRUE to Looped=FALSE. Like this every single shot will call its complete sound.

Share this post


Link to post
Share on other sites

Where do i fond the Burst lengh, or how i identify in the data ini?

 

I assume the weapons that are vexing you are the versions mounted on ground objects? Under the gun entry in the object's data.ini there will be (or should be) a line for "burst length", with a variable value.

 

For example:

 

[GunBarrel1]

SystemType=GUN

GunTypeName=40MM_L60

MuzzlePosition=0.18,3.52,2.70

MaxAmmo=240

TracerLoading=1

BurstAmount=4

EjectShells=FALSE

Share this post


Link to post
Share on other sites

Both of your answers fixed my problem, thanks a lot, i will upload a fixed version of my guns thanks to you all!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..