Jump to content
JollyRogerTwo

No flaps sounds in SF1 KAW and Solomon's campaigns

Recommended Posts

WOV does not seem to have this problem.

 

For some reason I hear gear and other sounds but not the flaps sound . I checked to make sure flaps.wav was in the sound folder and that it was called in various aircraft inis. The wav file I had was 8 bit and everything else seemed to be 16 bit recordings so I loaded it into Reaper and rendered it in 16 bit. No joy.

 

I made sure the flaps.wav sound worked by playing it. I guess I could just delete the file and see if the default flaps file would play from the game engine???

 

Anyone seen (but not heard) this before? Have and ideas?

 

Thanks

Share this post


Link to post
Share on other sites

can you post the (Sound) section of the data ini, like below??

 

 

[sound]

EngineSoundName=A1Engine

AfterburnerSoundName=

DamagedEngineSoundName=

FlapsSoundName=Flaps

AirbrakesSoundName=Airbrakes

GearsSoundName=Gear

Share this post


Link to post
Share on other sites

Thanks guys,

 

The flaps.wav file is definitely in the sounds folder of all my installs. Shown below is from the data.ini sound section of the hard wing Sabre. As far as I can tell I hear no flaps sound when taking off or landing in any KAW or Solomon's plane.

 

[sound]

EngineSoundName=SabreEngine

DamagedEngineSound=

FlapsSoundName=Flaps

AirbrakesSoundName=Airbrakes

GearsSound=Gear

 

As I said I checked the flaps.wav and it is now 16 bit. I'm not sure what the sample rate is 44, 16 or 11. Not sure if it makes much difference either.

Share this post


Link to post
Share on other sites

Not sure about the flaps, but the gear annotation will need to read GearSoundName= if you plan on using something other than the gear wav. I've noticed quite a few models, mostly older, that are missing 'Name' at the end of the callouts.

 

Did you happen to save it as stereo when you modified it? If so, change it to mono format.

Edited by swisher

Share this post


Link to post
Share on other sites

Swisher,

 

I'm not trying to replace the default flaps sound at the moment. I just want to get the default to work.

 

Yup mono too.

 

Bit Rate: 176kps

Sample Size: 16 bit

Channels: 1 (mono)

Sample Rate: 11khz

Format: PCM

 

I flew a single mission in KAW using the hard wing Sabre. I set my flaps for takeoff (no sound). When I rotated and raised the gear (nice sound)

Then I raised the flaps.............nothing.

 

Thanks for any suggestions. It's no big deal but it has me baffled and I'm curious to identify what is causing it and figure out what the solution is.

Share this post


Link to post
Share on other sites

I'm stumped. I was wrong about WOV. I have the same problem there too. All my system sound settings are correct. I have changed my in game settings from 16 to 24 bit. It made no difference to the Flaps sound but I think the effects sounds are better. Why just one file? What is different about the Flaps.wav?

Share this post


Link to post
Share on other sites

I tried renaming the Flaps.wav file to see if the game would pick from a list of default sounds buried deep in some .cat file. It didn't work.

 

I found and extracted the Souindlist.ini and here are the pertinent entries:

 

FlightData.Cat

SoundsList.INI

 

 

[Flaps]

Priority=NORMAL

Looped=FALSE

NumBuffers=1

3DSound=TRUE

DopplerEffect=FALSE

MaxDist=100.000000

MinDist=50.000000

InsideConeAngle=360

OutsideConeAngle=360

ConeOutsideVolume=0

 

[Airbrakes]

Priority=NORMAL

Looped=FALSE

NumBuffers=1

3DSound=TRUE

DopplerEffect=FALSE

MaxDist=100.000000

MinDist=50.000000

InsideConeAngle=360

OutsideConeAngle=360

ConeOutsideVolume=0

 

[Gear]

Priority=NORMAL

Looped=FALSE

NumBuffers=1

3DSound=TRUE

DopplerEffect=FALSE

MaxDist=100.000000

MinDist=50.000000

InsideConeAngle=360

OutsideConeAngle=360

ConeOutsideVolume=0

 

I see nothing here that seems wrong. The entries are all the same but for their name including Flaps which is the only one that doesn't work. I'm completely flummoxed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..