Jump to content
Sign in to follow this  
xeroluck

question on installing FE aircraft into FE2

Recommended Posts

I'm working on getting all Armchair Aces Redux aircraft installed.  A few of them have some files that go in the Weapons folder.  My question is what do I do with the WEAPONDATA.DAT and WEAPONDATA.INI files for an aircraft.  I already have those files in my Weapons folder.  The files for specific planes are much smaller (12-15 weapons vs 42 in the current file).  Thanks for any help.

Share this post


Link to post
Share on other sites

How you add weapons is different for FE1 and FE2. My Aviatik-Berg D.I 185hp plane in the Downloads section has instructions for installing a Schwartlose machine gun, for both FE1 and FE2. Other weapons should install the same way.

Share this post


Link to post
Share on other sites

How you add weapons is different for FE1 and FE2. My Aviatik-Berg D.I 185hp plane in the Downloads section has instructions for installing a Schwartlose machine gun, for both FE1 and FE2. Other weapons should install the same way.

 

Hi Stephen! First of all I want to thank you for your great work with the aircraft you creat!  :biggrin:  They are really great to fly!

 

However I have a little problem. I run FE2 on a Windows 7 rig and I have had a Little trouble getting weapon-packs to work for some aircraft I downloaded at A-Team. So I went on a hunt to try to find some useful info on the subject and stumbled on this thread and desided to give it a go with your Aviatik-Berg D.I 185hp.

 

1. I installed the aircraft.

2. I installed the decals.

 

No problems so far!

 

3. Then I put the Schwartzlose-folder in the Weapons-folder I have created under User/Saved Games/ThirdWire/FE2/Objects. 

 

Here's the problem, the machinegun is there on the aircraft but the thing won't fire. Not even a little click when I try to fire it.

 

I have placed the other weapons-folders/-files from the A-Team-aircraft in the same User/Saved Games/ThirdWire/FE2/Objects/Weapons-folder and they don't work, or even show up in the game when I try them on their respective aircraft.

 

Have I put the Weapons-folder in the wrong place or made some other mistake??? :blink:

Edited by Verdun

Share this post


Link to post
Share on other sites

Verdun - I am not that familiar with FE2, I use FE1 - Since the gun shows up in the game, you must have it installed in the right place. My angled gun is really an angled version of the "8MM_Schwarzlose_M07/12" You might need to check that that gun is installed in the gun data as well.

 

Can someone who knows more about FE2 Weapons help us out here?

Share this post


Link to post
Share on other sites

 You might need to check that that gun is installed in the gun data as well.

 

 

Yes, that is right.

 

 In the data file in the newly added "Single Schwarzlose Angled" folder in the Weapons Folder , it has a line ...

 

GunTypeName=8MM_SCHWARZLOSE_M07/12

 

If the Guntype "8MM_SCHWARZLOSE_M07/12" doesn't exist as a folder in your Guns folder, you need to add it - it should be available in original download. If not, you need to create one (using the FE2 Guns Editor), or change the GunTypeName= in the data file above to something else that you have in your Guns Folder.

Share this post


Link to post
Share on other sites

Thanks for your answers guys! But I managed to solve the problem myself actually.

 

I opened the Schwarzlose DATA.INI file just to see what was in it. Then I saw that the line MaxRounds=0 and thought that seemed odd that it was set to 0, so I changed it to a higher number, pressed save and launched the game and voila...the gun fired!

 

When I had done that I thought I would check out the DATA.INI files of the weapons-pack that came with the A-Team Aircrafts I had downloaded. So I opened it and saw that the lines StartYear=, EndYear=, ExportStartYear= and ExportEndYear= were all set to 0, while they had been set to 1912 as start year and 1919 as end year in the Schwarzlose DATA.INI file.

 

Bold as I had become by the success with the Scwarzlose I changed the 0's to 1914 or 1915 for the StartYear= and ExportStartYear= and then for the EndYear= and ExportEndYear= I changed the 0's to 1919. I pressed save, launched the game and it worked.

 

I realize this was pure luck from my side but well it worked! :biggrin: So I'm happy!

 

I don't think I have a Gun-folder. But I did create a Weapons-folder as I described above in my previous post. I have no clue what a FE2 gun editor is either? :dntknw:

Edited by Verdun

Share this post


Link to post
Share on other sites

I'm glad you got it working. I really need to understand the difference between FE1 and FE2 better. In my installs of FE1, all the guns in the Weapons folders have MaxRounds set to zero, but they all fire in the game...

 

But if it works... don't change anything!

Share this post


Link to post
Share on other sites

weapons, guns, pilots and even decals set up EXACTLY the same in FE2 as in SF2.

That is to say, separate, individual folders for each item, within their respective "main category" ( /Objects/Guns/*nameofgun*)

 

There should be more info hiding (literally!!) somewhere in the SF2 knowledge base.

 

but in essence, for a gun, the folder only needs the "main ini", and the data ini, as there Is no physical objects. The bullets are, in truth, just a 'special effects'.

 

weapons, oth, while following the basic format (main ini, data ini), also need the lods residing in the folder.

 

as to editors, the same ones for sF2 work for FE2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..