Jump to content
Sign in to follow this  

wrong canopy animation

Recommended Posts

I encountered an issue I cannot solve no matter what. I tried everything before coming here. The general cockpit animation  is fine (when you look from outside the plane) but that was not my problem. The problem is that , when I'm IN the cockpit I see the animation reversed (cockpit is closed when speed is 0 and then , when aircraft starts, it opens, it closes again when full afterburn, and then it opens in  mid-air and then, no matter what it stays open. Is there anything I could do to keep it shut, with no animation at all, all time ? (I looked into the cockpit LOD, it's a SU-27SKM_cockpit.LOD file, and the animation ID for opening/closing it was 10, the cockpit animation  for the plane LOD was 7, it's a MIG-35).




I tried this first time:

I erased the canopy declaration entirely from Control Surfaces section and I leaved blank the field like this


and I erased the field: "CanopyAnimationID=7"

But , when I'm in the cockpit, it's the same show, it opens , closes and then remains open in mid-air. It drives me crazy.

Second time I tried this:

I copied everything what had in its name the word "canopy" over, from a WOI "native", Mirage IIICJ but no luck, the canopy, in cockpit view, remains open in mid-air.

Any suggestions please ot correction for what I do wrong ? thank you.


These are the lines with word  "canopy" in it I could find in the dataini file:


MaxExtentPosition= 0.249,1.643,0.12
CollisionPoint[001]=-0.000,4.889, 0.503
CollisionPoint[002]=-0.000,4.223, 0.155
CollisionPoint[003]= 0.007,1.509, 0.135
CollisionPoint[004]= 0.165,4.0228, 0.0000
CollisionPoint[005]=-0.165,1.0109, 0.0000





// Crew ---------------------------------------------------------

MinExtentPosition=-0.25, 5.91,-0.20
MaxExtentPosition= 0.25, 6.99, 0.92


// Control Surfaces ---------------------------------------------------------





Share this post

Link to post
Share on other sites


Its probably this:

the entry in your cockpit ini  (the animation link) refers to another animation (slats maybe) which deploy/retract in flight... and thats causing your wild canopy movement.

Change the value to 7 if this is the canopy animation ID of the aircraft model

Further, to prevent the canopy from opening in flight. add following to the [Canopy] section in the data ini:


This sets a limit of 5 m/s (about 10 knots / 18 km/h) and the canopy will close automatically if this speed is exceeded.

You can double the value if you want to taxi faster with the canopy open.

And for info, the  CanopyNodeName=Canopy entry in the [Pilot] section tells the game which part of the aircraft is jettisoned when the crew ejects.

For some aircraft (eg the Mirage F1) the canopy glass node is used there, if ejection (on the real thing) is through the canopy without jettison it first.


  • Thanks 1

Share this post

Link to post
Share on other sites

I'll try the second one, cause I can't change cockpit LOD animation from 10 to 7, it's embeded in...it and I don't know to operate a 3D editor, let alone I don't have one.

Thanks a lot for the info. It's been very helpful. I'll try these settings and I 'll be back with the results.

Edited by UllyB

Share this post

Link to post
Share on other sites

Im talking about the correct ID setting in the cockpit ini


AnimationID=3<<----------------------------------this is the animation number/slot used in the cockpit lod
ItemNumber=3<<----------------------------------this refers to the animation number/slot used in the aircraft lod and must be set to the correct ID used for the canopy animation

You can check the animations from within the lodviewer tool

  • Thanks 1

Share this post

Link to post
Share on other sites

Oh, I see...I missunderstood. My bad. I'll follow your lead and I'll be back with the results. Thank a lot, again!

Share this post

Link to post
Share on other sites

Now I finally understood what was going on. I didn't know that there was an animation link in cockpit.ini!! I was wondering how the hell the canopy was still moving (its animation) even if I deleted all the lines in dataini files concerning it. I learned something new today.

Long story short, after replacing the correct figure in cokpit.ini in [opencanopycontrol] everything works as it should. Thank you once again for your precious help and lesson.

I wish people like you would eneter here more often cause sometimes I really need desperate help for issues I don't know how to approach them because of my lack of knowledge.. The good part is that I am a fast lerner.

Share this post

Link to post
Share on other sites

For me the speed limit always worked !!!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..