Jump to content
Sign in to follow this  

Problems with Logitech Extreme 3d Pro Joystick

Recommended Posts

Hi all

Having issues with getting my Logitech Extreme 3d Pro joystick to work in game. It's recognized and all axis are assigned in the 'Workshop' settings, but when I've tested in game (in quick combat), there is no functionality whatsoever. I've tried clearing everything and rebinding x y & z axis and even cleared all keyboard binds for ailerons, elevator and rudder, but still no response - it as if it isn't even plugged in when I go into a flight. I should add that it works fine in IL2 Great Battles - full functionality and everything works just fine - so I'm guessing it's a problem with WOFF not liking my stick in-game for some reason - maybe a corrupted file in the game install?

Has anyone else experienced a similar problem with their controller (Logitech or others). If anyone can suggest a fix/workaround to get it working, I'd be really grateful. 

Thanks in Advance

Share this post

Link to post
Share on other sites

@OP, something similar occasionally happens to me if moving the WOFFKeys.xca file from computer to computer, so that it is no longer recognized in WoFF. For the Logitech stick, it's important to double-check that its correct identification is always in place in the relevant xca file.

The full path to the file is:

C:\Users\YourName\AppData\Roaming\OBD_Games\OBDWW1 Over Flanders Fields\WOFFKeys.xca

Once you open the WOFFKeys file, drill all the way down until you get almost to the bottom of the document, to the joystick section. Then search for the device type name indicated below and make sure that it is identical (or, if not identical, change to the info. below and then save the file) - the joystick should then be recognized in WoFF (i.e., all inputs will be registered, including programmed keys on the joystick and x/y/z axes).

<Device Type="Logitech Extreme 3D Pro USB">



Share this post

Link to post
Share on other sites

Thanks for your reply:smile:

Anyway, it seems to have fixed itself. After a full restart of my PC, joystick is working fine, with no issues.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..