Jump to content

Recommended Posts

can somebody please say how to fix my problem

i lost all my guns, every mission i start all the aiplanes say that they are out of ammo and i am to

all planes lost ammo. and in the loadout screen i can't edit how much ammo i can have. i can't click on it

 

so please help me

Share this post


Link to post
Share on other sites

make sure in the data.ini the gun stations are correctly worded and that the guns are usable in the years u are flying. Other then that, I dont know, I had a similar problem and had to fix the wording in the data.ini. Hope that helps

Share this post


Link to post
Share on other sites
it started when i checked the gun editor i had no guns edited or something.

 

it STARTED when you checked the gun editor? as in the problem was AFTER you did that?

Share this post


Link to post
Share on other sites

Assuming that you've added 3rd party gun entries:

 

If you have no guns showing in the gundata.ini, then it is hosed. If you do have guns listed in the gundata.ini,ini, but do not have them in-game, delete the gundata.dat (not the gundata.ini) file, open the gundata.ini using the gun editor, save it with the gun editor, and all should be fine.

 

BTW, a thought just occurred to me...you do realize that the gundata.ini and .dat files do not belong in the weapons folder, right?

Share this post


Link to post
Share on other sites
it doesn't work :no2:

 

I'm guessing - reload.

 

A suggestion. I keep a stock version with no, or limited, mods and then have the versions that I use for everything else. That way there is always a backup to the files. So when I do goon something up (if you mod - you will!) you can always step back to the stock version or last version that worked.

Share this post


Link to post
Share on other sites

If you're trying to use the gun editor, MAKE SURE IT'S THE ONE THAT CAME IN THE WEAPONS PAK - it's the latest version, and that it's set to use 'win98 compatibility mode'

 

Also, a little more information is required..is this a 'modern' install, or something ala WW2-ish??? For test purposes, you can always extract the gundata ini & gundata .dat from the objects cat, leaving it in the /objects main folder, and see if your guns return.

 

Normally, it should return to the standard 'using the info from the cat', if you delete or rename the add-on gundata ini and gundata dat files.

 

As for operational years, guns don't have any -- they're available for ALL years and don't have 'nation names', so they're also available for ALL nations (it would be concievalbe then, to have MK-108s mounted on your JASDF Phantom, for example)

 

Whatever happened, it's something you did when you opened up the gun editor, and probably didn't save or it wasn't used correctly.

 

Start over with a fresh one...bet the problem goes away

 

Wrench

kevin stein

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..