Jump to content
Sign in to follow this  
Gepard

HELP! Flickering ground objects

Recommended Posts

While working on an updated version of Vogesen Terrain for First Eagles i found the problem of flickering textures of a flat object.

My intention was to create a garden for a chateau. For the garden i used the same flat object, that i already successfully used in SFP1 and WOE for creating airfields, i only changed the texture of the garden. While i never had problems in SFP1 and WOE i have in FE to face, that the terrain texture is flickering through the object.

Has someone an idea, how to solve this problem?

Share this post


Link to post
Share on other sites

Try increasing "ZBufferOffset" to something like 5 in the terrain's _types.ini. I think that fixed it for me on some flat targets I've had the same problem.

Share this post


Link to post
Share on other sites

Me too. I first noticed it when I was doing the bridges. I thought it was related to the fact that my vid card can't do the new water effects. When I turned water detail down to low it seemed to do away with most of it. I'll try the zbuffer thing...thanks.

Share this post


Link to post
Share on other sites

"Try reducing horizon distance options, thats z-buffer problems we're running into because these open cockpits require very close/small Min Z-buffer clipping distance...

 

TK "

 

What he said over at TWire a while back. If this can be solve without lowering H-distance, great!

Edited by B Bandy RFC

Share this post


Link to post
Share on other sites

Aggie, the ZBuffer thing = 5 worked, but not in the wished way. The flickering is gone, but now i cant see the object texture anymore, its only the terraintile texture visible. I've also tried to set -5, but the flickering is still to see.

 

I will try the idea of Bandy.

Share this post


Link to post
Share on other sites

I solved the problem. I had forgotten to include the line FlatObject=TRUE in the types.ini.

In combination with ZBufferSetting=6 it runs very satisfying.

 

I think the new version of Vogesen terrain could be released next weekend.

Share this post


Link to post
Share on other sites

Gentlemen,

 

I've already posted, that I love this sim......but there's always room for improvements...right?

 

My problem:

Certain ground objects 'flicker' (blink)! A verry good example are those bombed towns along no-mans land. If I get verry close to them they stop 'flickering', but let's say at about 1500ft distance and more it is verry pronounced.

 

I've tried the following stuff...to no avail:

- Increased / decreased view distance (within game ...options)

- Increased / decreased ground details, ground object details, etc. (within game ...options)

- Fiddled around with the flightengine.ini stuff

- By de-creasing the zBuffer (flightengine.ini) ...no more flickering, so I guess it's related to the zbuffer...but then a lot of add-on planes start flickering :blink:

- Also the horizon tiles are anoying :sorry: (tried the suggestions here concerning the 'farsceneclip', etc. ..didn't work)

- I've the NHANCER tool (since I've a NVIDIA7900)...tried a couple of things....no way

- Drivers are up-to-date, DX up-to-date

 

Any...I mean ANY help would be highly appreciated!!!!

 

ONE solution could be (at least for the 'bombed towns') raising the buildings slightly above the ground. So there's on overlapping of the ground and the buildings (since the flicker is caused at exactly the transition point). But WHERE do I configure that???

 

kind regards

gterl

Share this post


Link to post
Share on other sites

I've seen the texture flicker issue mostly on parked aircraft, but also elsewhere. I figured it was my ATI card being flaky all over again, but glad (in an offhand way) that Nvidia cards are also showing this. It means that hopefully it will get solved with another patch. I really enjoyed the high-setting water effects, but now have to turn that off because of terrible flicker.

 

I am now wondering if everyone experiences the "BIG TRIANGLE IN THE SKY" on overcast days??? :wacko: I have not seen it mentioned on the forums, but will post an image when I get home.

 

The FE ExPack seems to have been a major step backwards in many ways graphics related, and I don't understand where/why the changes were made to the "environment" code since otherwise it looks the same as the original game...

 

I've never spent $60 on something that looked so bad, but I must say flies so well :dntknw:

Share this post


Link to post
Share on other sites

Bandy,

 

yes I've seen the 'triangle' too!!!!!!!!!!! :good:

 

My personal solution for that one was modifying the environmentsystem.ini to such a degree that I've now 3d clouds ONLY for overcast and inclement (took me quite a while to figure out what where to do).

It looks terribly nice now, but I guess depending on the machine quite a FPS hit!!

 

bimg0001.jpg

 

rgds

gt

 

 

UUUPS: Forgot to add NO EP here!! Don't see the reason why to be onest ....

Edited by gterl

Share this post


Link to post
Share on other sites
yes I've seen the 'triangle' too!!!!!!!!!!! :good:

 

... I've now 3d clouds ONLY for overcast and inclement (took me quite a while to figure out what where to do).

It looks terribly nice now...

 

Well thank the gods I'm not alone with the triangle, though you say you don't have the ExPack, and I've only seen it since I installed it. :blink:

 

On my original FE (sans ExPack) I also have only 3d clouds by using two very nice 3rd party mods available here, and was REALLY happy with the look. However, they DON'T work in the ExPack at all.

Share this post


Link to post
Share on other sites

Strange.....I would guess that EP wouldn't change the overall behaviour of the game (the DLL's). Personaly I had to replace the 'overcast.bmp' (can't remember the right name) with transparent tga's & mess around with the 3d clouds.

Guess should be feasable also with EP :not_i:

Share this post


Link to post
Share on other sites

Tailspin:

Yup tried that with the terraintypes.ini thingi (just by search/repleace) ....nothing happened. My guess this helps ONLY on pure flat objects (the 'bombed town' models are 3d). Another guess is the overall handling of zBuffer within FE since by changing the zbuffer (as mentioned above) cures the problem on the ground objects ....but opens up another one with the planes ......so at the moment is 'one or the other'

 

gterl

Share this post


Link to post
Share on other sites

Alright chaps,

 

just in case anyone is still following this discussion (looking at the other topics I guess everyone is keen on new add-ons :type: )

 

I've found the solution, at least works here.

 

It looks like FE has a couple of problems with the zBuffer stuff (trees showing up through clouds, horizon-clipping, missing tiles, flickering ground stuff, etc.). The good thing is that is somewhat fixeable.

 

Pls try the following if your ground stuff is flickering:

1. Look within the 'terrain/wwiVerdun' folder for the file WWIVERDUN_TYPES.INI (if you can't find it you may wanna extract it)

2. Change the following stuff (example for the debris, e.g. bombed towns)

 

[TargetType0XX] <----- whatch for continuous numberings

Name=DebrisLarge2

FullName=Debris

ModelName=DebrisLarge2.LOD

TargetType=MISC

ActiveYear=0

TargetValue=0

UseGroundObject=FALSE

DamagePoint=1.0

RepairRate=0.0

StartDetectChance=0

StartIdentifiedChance=0

IncreaseDetectChanceKey=0

MaxVisibleDist=2500.0

ZBufferOffset=24.000000 <-----------------------------------

FlatObject=TRUE <-----------------------------------

DestroyedEffect=StructureCollapse

SecondaryEffect=

SecondaryChance=0

 

[TargetType0XX] <----- whatch for continuous numberings

Name=DebrisSmall1

FullName=Debris

ModelName=DebrisSmall1.LOD

TargetType=MISC

ActiveYear=0

TargetValue=0

UseGroundObject=FALSE

DamagePoint=1.0

RepairRate=0.0

StartDetectChance=0

StartIdentifiedChance=0

IncreaseDetectChanceKey=0

MaxVisibleDist=2500.0

ZBufferOffset=24.000000 <-----------------------------------

FlatObject=TRUE <-----------------------------------

DestroyedEffect=StructureCollapse

SecondaryEffect=

SecondaryChance=0

 

[TargetType0XX] <----- whatch for continuous numberings

Name=DebrisSmall2

FullName=Debris

ModelName=DebrisSmall2.LOD

TargetType=MISC

ActiveYear=0

TargetValue=0

UseGroundObject=FALSE

DamagePoint=1.0

RepairRate=0.0

StartDetectChance=0

StartIdentifiedChance=0

IncreaseDetectChanceKey=0

MaxVisibleDist=2500.0

ZBufferOffset=24.000000 <-----------------------------------

FlatObject=TRUE <-----------------------------------

DestroyedEffect=StructureCollapse

SecondaryEffect=

SecondaryChance=0

 

[TargetType0XX] <----- whatch for continuous numberings

Name=DebrisSmall3

FullName=Debris

ModelName=DebrisSmall3.LOD

TargetType=MISC

ActiveYear=0

TargetValue=0

UseGroundObject=FALSE

DamagePoint=1.0

RepairRate=0.0

StartDetectChance=0

StartIdentifiedChance=0

IncreaseDetectChanceKey=0

MaxVisibleDist=2500.0

ZBufferOffset=24.000000 <-----------------------------------

FlatObject=TRUE <-----------------------------------

DestroyedEffect=StructureCollapse

SecondaryEffect=

SecondaryChance=0

 

 

Conclusion:

The problem lies definitely with the zBuffer 'management'. I've NO idea what the 'ZBufferOffset' stuff does, but increasing that number certainly helps minimizing the flickering. I've still to try out on the rest of the ground objects....altough the 'bombed towns' were the most anoying.

 

hope this helps

kind rgds

gterl

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..