Jump to content
Sign in to follow this  
The_Editor

This is driving me nuts(loadout problem)

Recommended Posts

The bombs will load but the rockets are no show, but are selectable from the loadout screen.

 

I have tried changing the data, but to no avail. I am using the latest weapons pack.

 

Any thoughts on what is wrong.

 

The loadout:

 

[Attack]

Loadout[01].WeaponType=60lb-rocket

Loadout[01].Quantity=1

Loadout[02].WeaponType=60lb-rocket

Loadout[02].Quantity=1

Loadout[03].WeaponType=60lb-rocket

Loadout[03].Quantity=1

Loadout[04].WeaponType=60lb-rocket

Loadout[04].Quantity=1

Loadout[05].WeaponType=60lb-rocket

Loadout[05].Quantity=1

Loadout[06].WeaponType=60lb-rocket

Loadout[06].Quantity=1

Loadout[07].WeaponType=60lb-rocket

Loadout[07].Quantity=1

Loadout[08].WeaponType=60lb-rocket

Loadout[08].Quantity=1

Loadout[09].WeaponType=Mk5_500

Loadout[09].Quantity=1

Loadout[10].WeaponType=Mk5_500

Loadout[10].Quantity=1

 

The Weapons stations:

 

[LeftWingStation1]

SystemType=WEAPON_STATION

StationID=1

StationGroupID=1

StationType=EXTERNAL

AttachmentPosition=-1.25,0.41,-0.56

AttachmentAngles=0.0,0.0,0.0

LoadLimit=90.0

AllowedWeaponClass=RCKT

AttachmentType=UK

ModelNodeName=LRocketPylon

PylonMass=12

 

[LeftWingStation2]

SystemType=WEAPON_STATION

StationID=3

StationGroupID=1

StationType=EXTERNAL

AttachmentPosition=-0.95,0.41,-0.62

AttachmentAngles=0.0,0.0,0.0

LoadLimit=90.0

AllowedWeaponClass=RCKT

AttachmentType=UK

ModelNodeName=

PylonMass=12

 

[LeftWingStation3]

SystemType=WEAPON_STATION

StationID=5

StationGroupID=1

StationType=EXTERNAL

AttachmentPosition=-1.25,0.15,-0.42

AttachmentAngles=0.0,0.0,0.0

LoadLimit=90.0

AllowedWeaponClass=RCKT

AttachmentType=UK

ModelNodeName=

PylonMass=12

 

[LeftWingStation4]

SystemType=WEAPON_STATION

StationID=7

StationGroupID=1

StationType=EXTERNAL

AttachmentPosition=-0.95,0.15,-0.46

AttachmentAngles=0.0,0.0,0.0

LoadLimit=90.0

AllowedWeaponClass=RCKT

AttachmentType=UK

ModelNodeName=

PylonMass=12

 

[RightWingStation1]

SystemType=WEAPON_STATION

StationID=2

StationGroupID=1

StationType=EXTERNAL

AttachmentPosition=1.25,0.41,-0.56

AttachmentAngles=0.0,0.0,0.0

LoadLimit=90.0

AllowedWeaponClass=RCKT

AttachmentType=UK

ModelNodeName=RRocketPylon

PylonMass=12

 

[RightWingStation2]

SystemType=WEAPON_STATION

StationID=4

StationGroupID=1

StationType=EXTERNAL

AttachmentPosition=0.95,0.41,-0.62

AttachmentAngles=0.0,0.0,0.0

LoadLimit=90.0

AllowedWeaponClass=RCKT

AttachmentType=UK

ModelNodeName=

PylonMass=12

 

[RightWingStation3]

SystemType=WEAPON_STATION

StationID=6

StationGroupID=1

StationType=EXTERNAL

AttachmentPosition=1.25,0.15,-0.42

AttachmentAngles=0.0,0.0,0.0

LoadLimit=90.0

AllowedWeaponClass=RCKT

AttachmentType=UK

ModelNodeName=

PylonMass=12

 

[RightWingStation4]

SystemType=WEAPON_STATION

StationID=8

StationGroupID=1

StationType=EXTERNAL

AttachmentPosition=0.95,0.15,-0.46

AttachmentAngles=0.0,0.0,0.0

LoadLimit=90.0

AllowedWeaponClass=RCKT

AttachmentType=UK

ModelNodeName=

PylonMass=12

 

[LeftWingStation5]

SystemType=WEAPON_STATION

StationID=9

StationGroupID=3

StationType=EXTERNAL

AttachmentPosition=-2.9,0.16,-0.23

AttachmentAngles=0.0,0.0,0.0

LoadLimit=650.0

AllowedWeaponClass=BOMB,FT

AttachmentType=UK

ModelNodeName=LBombPylon

PylonMass=30

FuelTankName=Tank450_MD450

 

[RightWingStation5]

SystemType=WEAPON_STATION

StationID=10

StationGroupID=3

StationType=EXTERNAL

AttachmentPosition=2.9,0.16,-0.23

AttachmentAngles=0.0,0.0,0.0

LoadLimit=650.0

AllowedWeaponClass=BOMB,FT

AttachmentType=UK

ModelNodeName=RBombPylon

PylonMass=30

FuelTankName=Tank450_MD450

Share this post


Link to post
Share on other sites

Did you specify the rack type the rockets are going to use, especially for the ones which you do not specify a rack?

 

Example:

 

Loadout[13].WeaponType=AIM-9L

Loadout[13].Quantity=2

Loadout[13].RackType=LAU-105

Edited by kct

Share this post


Link to post
Share on other sites
Have you tried toying around with the load limits? Because 90kg seems a bit small to me.

 

Nah, the 60lb-rocket had only a weight of 63.5 kg. I'm not sure about the availablity, though. Check the EndYear in weapondata...maybe that's the problem. Just a guess.

Share this post


Link to post
Share on other sites

Yeah, I already checked the weight, definitely not the problem.

 

I edited my post though. However, a weapon out of specified years would not show up (example, a weapon produced between 1960 to 1990 would not show up before 1960 and after 1990, the only exception is if the end year is 0, in which the weapon would show up regardless of year, as long as it is after the start year).

 

Check the pylons of the weapons too.

Edited by kct

Share this post


Link to post
Share on other sites

AFAIK the 60lb-rockets don't need a specific rack. Besides, the rack entry is only necessary when you want use a weapon rack that's not part of the aircraft model. Not to mention that weapon racks have their own attachment class (2IR,TER, etc.)

Edited by Gocad

Share this post


Link to post
Share on other sites

1) It'd really help to know what specific aircraft we're working on.....

 

2) Have you looked in the Knowledge Base, my weapons/loadouts/various tweeks forums??? 99.8% of all aircraft have been 'adjusted' for the weapons paks.

 

From looking at you data, I'm gonna guess it for the Ouragan??? I'm also gonna guess this if for WoI??

 

You'll find those in the WoI ONLY Weapons Fixes Forum, with complete instructions and etc and so forths...

 

Wrench

kevin stein

Share this post


Link to post
Share on other sites
Guest pfunkmusik

On the AttachmentType value, try RAF instead of UK and see what happens.

 

pfunk

Share this post


Link to post
Share on other sites

My Venom update????

 

This is from the readme:

 

All loadouts have been adjusted to fit the latest WepPak, and the aircraft now carries RAF (well, UK actually) nation specific bombs/rockets. This fix was posted by me as well at Buny's Weapons Wiki.

 

The loadouts are all fixed --- you don't need to frack with them. I've done all your work for you. :yes:

 

Now, since the 60#s aren't showing, I can guess that you're probably using the TMF pack???

Guess what...they ain't in there.

You'll have to add them.

You'll need the info (data section) from the Bunyap Pak, plus the lod and bmp

 

Might want to let us know, next time, which pack you're using??? Makes it easier to get things sorted.

Remember, too, the TMF pack is VERY much a work in progress, and mostly designed ONLY for their aircraft (and the stock ones). Everything else MUST be added.

Another hint: look at the weapons listings IN the weaponsdata inis. A missing weapon can be easily found by it's absence....

 

Wrench

kevin stein

Share this post


Link to post
Share on other sites

Thanks for the replies.

 

I am using the Bunyap weapons pack with the 60 pound rockets.

 

[WeaponData335]

TypeName=60lb-rocket

FullName=3" RP 60lb HE(SAP)

ModelName=60lb-rocket

Mass=63.500000

Diameter=0.127000

Length=2.280000

AttachmentType=UK,FRANCE

NationName=RAF

StartYear=1943

EndYear=1970

Availability=3

BaseQuantity=24

Exported=TRUE

ExportStartYear=1943

ExportEndYear=1970

ExportAvailability=3

WeaponDataType=1

RailLaunched=FALSE

RocketPod=FALSE

Retarded=FALSE

Streamlined=TRUE

FinStabilized=TRUE

SpinStabilized=FALSE

HasGrowl=FALSE

EffectClassName=MediumRocketEffects

ReleaseDelay=0.000000

WarheadType=0

Explosives=25.000000

FusingDistance=0.000000

ClusterBomblets=0

ClusterDispersion=0.000000

GuidanceType=0

Accuracy=70

MaxTurnRate=0.000000

MaxLaunchG=2.500000

LockonChance=0

LaunchReliability=70

ArmingTime=2.000000

SeekerFOV=25.000000

SeekerGimbleLimit=0.000000

SeekerTrackRate=11.000000

SeekerRange=0.000000

MinLaunchRange=0.000000

MaxLaunchRange=0.000000

Duration=60.000000

CounterCountermeasure=20.000000

NoiseRejection=20.000000

CapabilityFlags=0x00000000

BoosterStart=0.000000

BoosterDuration=1.400000

BoosterAccel=48.980000

BoosterEffectName=RocketFireEffect

BoosterSoundName=Rocket

BoosterNodeName=

BoosterPosition=0.000000,-1.136000,0.000000

SustainerDuration=0.000000

SustainerAccel=0.000000

SustainerEffectName=

SustainerSoundName=

SustainerPosition=0.000000,-1.136000,0.000000

InFlightEffectName=RocketInFlightEffect

InFlightSoundName=

ReleaseAnimationID=-1

EODisplayFlags=0

Edited by The_Editor

Share this post


Link to post
Share on other sites

I think I've found the problem.

 

I just wrote a strike mission for the Venom with one aircraft and the weapons all showed up, so that I think the problem is with the Weapons entry in the WEAPONDATA.INI, probably the 60lb-rocket quantity number.

 

I changed the BaseQuantity to 100, the availability was originally very common, but still the rockets do not show on multi aircraft missions.

Edited by The_Editor

Share this post


Link to post
Share on other sites

They do show up on Seahawk multi aircraft missions, though, but not on Venom or Hunter multi aircraft missions.

 

I don't know if it is something to do with the Weapon Station arangement, which is similar on the Hunter and Venom, but not on the Seahawk.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..