Jump to content
Sign in to follow this  
Olham

Question about SAITEK pedals

Recommended Posts

My Saitek pedals have two axis -

1. the rudder axis

2. the breaks (when i bend the pedals forward).

 

Now, it seems, that in BHaH this second axis makes problems my end.

Could anyone tell, if and how it can be switched "off"?

I'd like to learn to fly with rudder pedals.

Share this post


Link to post
Share on other sites

hi olham,

 

ingame you hit esc to get to the menu. then you hit joystick settings or how it's called. you should be able in a dropdown to choose saitek pedals. the breaks are responsible for a axis (i don't know which one. y maybe). this assignment you can delete and save settings. then the brakes have no effect. you should also choose you joystick and delete the assignment for you twist. otherwise you would be able to move the rudder with the pedal and also with twist rudder and you don't want that.

 

creaghorn

Share this post


Link to post
Share on other sites

I have the Pro-Pedals also and had a problem with the "brakes" causing odd problems. I think one pedal made the plane dive (full down elevator) and the other cause the ailerons to fluctuate back and forth. Anywho, Aussie Pilot came up with a fix in the CFS3.xca file (I think) which is found in the Application Data folder. This was all explained in the old forum, but I think it was lost in the transfer.

 

If he is watching this thread maybe he will post.

 

Beard

Share this post


Link to post
Share on other sites

G'day Olham,

 

It's as Burning beard mentioned mate, When you installed your pedals CFS3 engine see them and automatically configure them for you. But what it has done has also assigned your left toe break as elevator and the right to break as ailerons. Go to outside view of your aircraft on the runway and watch your flight surfaces when you use your toe breaks to confirm.

Now go Doc &setting/your name/application data/CFSWW1 and find the "Mine.xca or what ever one you are using. Open with note pad and down the bottom you'll see the Saitek pedals entry. This is from mine and all you need.

 

<Device Type="Saitek Pro Flight Rudder Pedals">

<GameMode Name="Player">

<Axis ID="Rudder" Action="Set_Yaw" Scale="64" Nullzone="36"/>

</GameMode>

</Device>

 

Delete the other axis commands within this Saitek entry and you should be good to go.

Share this post


Link to post
Share on other sites

Thank you, Aussie Pilot and all - no wonder my flying with pedals was tricky, to say the least.

Should be much more fun in the future.

Share this post


Link to post
Share on other sites

Dont forget to adjust the settings for sensitivity and null zone in the sensitivities tab. It's kind of hard to notice on the controllers screen.

Share this post


Link to post
Share on other sites

This is strange (at least for a computer idiot like me):

 

I searched for Aussie Pilot's .xca file. The only one shown in the search window was

"Flight Simulator.xca", located in CFSWW1 Over Flanders Fields.

Now the strange thing - it wasn't shown anywhere there.

Now I tried to find it with the Editor's "open file" - no way. Invisible?

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..