Jump to content
Sign in to follow this  
Siggi

Hmm...can't install the expansion.

Recommended Posts

My OFF is on my D drive. Clearly the installer is looking on the C drive. I don't see any opportunity to redirect the install. Any way to get around this?

 

If I copy my OFF to the C drive, install the expansion, then copy OFF back to the D drive, will that work or will I trip over some registry issues?

Edited by Siggi

Share this post


Link to post
Share on other sites

Hang on. I've my on D also. I'm still downloading it.

I'll report back soon. Very soon.

 

Hokay. >chewing fingernails< :grin:

Share this post


Link to post
Share on other sites

Did you manually copy your OFF BH&H to that location ?

 

The installer looks for where the original was installed too, that's where it MUST go, it does not install to some other place.

 

No idea on the copying thing, it's not recommended or tested.

 

Sounds like your registry is saying you installed to C:

 

Make sure you are at 1.32G first too.

 

Didn't you have major trouble recently Siggi? What did you do to fix it? Maybe it's screwed from then.

Sounds like you may need to utterly clean out and install fresh.

Share this post


Link to post
Share on other sites

Did you manually copy your OFF BH&H to that location ?

 

The installer looks for where the original was installed too, that's where it MUST go, it does not install to some other place.

 

No idea on the copying thing, it's not recommended or tested.

 

Sounds like your registry is saying you installed to C:

 

No, I didn't manually copy OFF to D, it was properly installed there.

 

I have a cunning plan...I shall put the expansion onto the D drive and try running it from there.

 

Nope, that didn't work (further confirming that Baldric is indeed a cretin).

Edited by Siggi

Share this post


Link to post
Share on other sites

I'm sorry to say this Siggi but all went well.

I've installed from my storage drive F and installed it correctly in D.

My Win7 is in G.

I can do another experiment. I'll switch to my XP whic is on C and try if it installs correctly on D.

It will be just a couple of minutes.

Hang on.

Edited by Von Paulus

Share this post


Link to post
Share on other sites

What the hell then? I was going to conclude this must be a Win7 issue, but you're running Win7 too.

 

The OFF update and hotfix found the install ok. :dntknw:

Share this post


Link to post
Share on other sites

I didn't have any problems on Win7 but Win7 is very fussy about where data goes. Try running the installer using the "run as admin" option Siggi?

Share this post


Link to post
Share on other sites

Yeah Pol, I've had my E drive being lost by Win7 quite regularly, and my pagefile is on E. I think that when the pagefile becomes full Win7 doesn't clear it or something and 'loses' the entire drive. I had to reboot to find it again. I've now set Win7 to automatically handle the pagefile, instead of having a fixed lower and upper value. Not sure why any of that would pork the install of the expansion though, the registry is held in the OS on C drive surely.

Share this post


Link to post
Share on other sites

I didn't have any problems on Win7 but Win7 is very fussy about where data goes. Try running the installer using the "run as admin" option Siggi?

 

Nope, no joy. Last option before doing a total reinstall of the game (and losing my current career, control configuration and ARGH!) is to copy OFF to C etc.

Share this post


Link to post
Share on other sites

My Win7 pagefile is fixed and is on C.

 

Look at the registry:

 

HKEY_CURRENT_USER\Software\VB and VBA Program Settings\OFFManager

 

HKEY_USERS\S-1-5-21-1060284298-1788223648-725345543-1003\Software\VB and VBA Program Settings\OFFManager

 

HKEY_CURRENT_USER\Software\OBD Software\Over Flanders Fields

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\OFF_P3_is1

 

HKEY_USERS\S-1-5-21-1060284298-1788223648-725345543-1003\Software\OBD Software\Over Flanders Fields

 

These seems the place where the registry helds the information where OFF is installed. I took it from XP but tree must be the same as in Win7.

 

By the way all went well also with XP. it installed correctly in D.

Share this post


Link to post
Share on other sites

Bollocks, it doesn't see it on C either. Something is badly porked in my world of OFF. Thanks VP, I'll go have a shufti in the registry, maybe I can manually add any missing entries.

Share this post


Link to post
Share on other sites

In the third line you've provided, OFF is there and shown as being on the D drive. I'm stumped.

 

Did you by any chance rename the default directory?

 

Nope, everything is a default install to D.

 

What should the directory be called, just in case it got changed on my rig somehow?

Edited by Siggi

Share this post


Link to post
Share on other sites

The installer must get the information (I suppose) where OFF is installed from the registry.

If the paths are correct in the registry... that lefts me puzzled.

Try to look in the registry for more entries for offmanager.exe for example.

Share this post


Link to post
Share on other sites

The installer must get the information (I suppose) where OFF is installed from the registry.

If the paths are correct in the registry... that lefts me puzzled.

Try to look in the registry for more entries for offmanager.exe for example.

 

I've done a search in the entire registry for OBD, every entry (and there are quite a few) come up as being in D.

 

I'm going to download the expansion again, maybe it became corrupted.

Edited by Siggi

Share this post


Link to post
Share on other sites

If I were you I would do exactly what you've suggested in your first post.

Copy to C and then copy again to D.

I'd alter then the registry manually to D again.

I've been looking for ascii "OBDSoftware" (which is part of the folder name whre my off is installed) and found nothing important on the files.

So theoretically the only information where OFF is installed is the really the registry.

Share this post


Link to post
Share on other sites

 

I'm going to download the expansion again, maybe it became corrupted.

 

I doubt it. It's zipped. If it was corrupted you couldn't have unzippped it.

Share this post


Link to post
Share on other sites

I already tried copying it to C and running the install again, it made no difference. Just downloaded the expansion again, still no joy.

 

I guess the only thing left to do is uninstall OFF and reinstall it. Strike one against Win7, it's inability to maintain a coherent pagefile has to be what's caused this, the pagefile going down must have corrupted an OFF file or something. Thanks once again MS. :bomb:

Share this post


Link to post
Share on other sites

Well like I've told it before my pagefile is fixed. The initial and the maximum size is 3071 and not 4606 as it is recommended. The system didn't held the 4606 value so I reduce it. It has been working well AFAIK.

My RAM is 4GB.

Share this post


Link to post
Share on other sites

not sure if it finds the directory by a search, or by a registry entry but default directory is

 

obdsoftware\cfsww1 over flanders fields

 

if you happened to modify this when it was installed, and it is a registry item..then you have to navigate to the entry someone else posted..

 

HKEY_CURRENT_USER\Software\OBD Software\Over Flanders Fields , and on the right hand side you will see offpath, and thats where its will be looking for the place to install

 

curious..what is the error message you get?

Edited by sitting_duck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.