Jump to content
Sign in to follow this  
quack74

Lost my animated water effect

Recommended Posts

I dont know when it happened but I just recently realized in FE2, I lost my water effects. I'm using Jan Tumas terrains and I have my water settings to "High" in options menu. How do I get the water effect back? I dont know how I lost it but mybe someone can point me in the right direction to turn it back on.

Share this post


Link to post
Share on other sites

I lost water animation on installing Tuma's terrain as well.

 

If you have FE backed up elsewhere it is easy to find the relevant bits of code to re-install. In fact, I posted on this subject in Jan's terrain release thread (the really long one) when it came out.

 

EDIT from earlier post:

 

This reanimates the water, though I noticed there are some z-buffer water artifacts in Flanders when flying along the coast. It is only a slight PITA, and have not spent time trying to correct it further, yet.

 

...futzed about with old ini's and got the water moving and looking better. Not perfect, but better.

Works good in Vogesen thus far, don't know yet about the others, but should be fine AFAIK.

 

If interested try this in each terrainDATA.INI (includes Stary's tweaks for convenience) apologies for my code comments, I suppose everybody has their own style.

The code line following //Stock is the baseline, which is also commented out // followed by the effective change and whitespace to easily find each of them.

.

.

.

[WaterTextureMaterial]

UseEffectShader=TRUE

EffectShaderName=WaterEffect2.fx

DepthBufferCheck=TRUE

DepthBufferWrite=FALSE

RenderedInOrder=TRUE

AlphaTestEnabled=TRUE

//STOCK

//CullMode=NO_CULL

CullMode=CLOCKWISE

 

LightEnabled=TRUE

SpecularEnabled=TRUE

EmissiveEnabled=FALSE

FogEnabled=TRUE

AmbientColor=1.000000,1.000000,1.000000,1.000000

DiffuseColor=1.000000,1.000000,1.000000,1.000000

SpecularColor=1.000000,1.000000,0.900000,1.000000

SpecularPower=1.000000

//STOCK

//ZBufferOffset=4.000000

ZBufferOffset=6.000000

 

BlendOp=BLEND_SRC_ALPHA

NumTextureStages=2

TextureStage[01].TextureName=

TextureStage[01].MipMap=FALSE

//TRUE

TextureStage[01].FilterEnabled=TRUE

 

//STOCK

//TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE

TextureStage[01].StageColorOp=DIFFUSE

 

TextureStage[01].StageAlphaOp=TEXTURE

 

//STOCK

//TextureStage[02].TextureName=

TextureStage[02].TextureName=ref_color.bmp

 

TextureStage[02].MipMap=FALSE

//TRUE

 

TextureStage[02].FilterEnabled=TRUE

 

//STOCK below --other INI's have no ReflectionMapping

//TextureStage[02].ReflectionMapping=TRUE

 

//STOCK

//TextureStage[02].StageColorOp=TEXTURE_BLEND_TEXTURE_ALPHA

TextureStage[02].StageColorOp=TEXTURE

 

TextureStage[02].StageAlphaOp=DIFFUSE

 

[solidObjectTextureMaterial]

DepthBufferCheck=TRUE

DepthBufferWrite=TRUE

RenderedInOrder=TRUE

AlphaTestEnabled=TRUE

CullMode=NO_CULL

LightEnabled=TRUE

SpecularEnabled=FALSE

EmissiveEnabled=FALSE

FogEnabled=TRUE

AmbientColor=1.000000,1.000000,1.000000,1.000000

DiffuseColor=1.000000,1.000000,1.000000,1.000000

ZBufferOffset=0.000000

 

//STOCK

//BlendOp=BLEND_DST_ALPHA

BlendOp=BLEND_SRC_ALPHA

 

NumTextureStages=1

TextureStage[01].TextureName=

TextureStage[01].MipMap=TRUE

TextureStage[01].FilterEnabled=TRUE

TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE

TextureStage[01].StageAlphaOp=TEXTURE

 

[AlphaObjectTextureMaterial]

DepthBufferCheck=TRUE

DepthBufferWrite=FALSE

RenderedInOrder=false

AlphaTestEnabled=TRUE

CullMode=NO_CULL

LightEnabled=TRUE

SpecularEnabled=FALSE

EmissiveEnabled=FALSE

FogEnabled=TRUE

AmbientColor=1.000000,1.000000,1.000000,1.00000

DiffuseColor=1.000000,1.000000,1.000000,1.00000

ZBufferOffset=2.000000

 

// STOCK

BlendOp=BLEND_SRC_ALPHA

 

NumTextureStages=1

TextureStage[01].TextureName=

TextureStage[01].MipMap=TRUE

//FALSE

TextureStage[01].FilterEnabled=TRUE

TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE

 

//STOCK

//TextureStage[01].StageAlphaOp=TEXTURE

//STARY's Suggestion follows...

TextureStage[01].StageAlphaOp=TEXTURE_BLEND_TEXTURE_ALPHA

 

Fade=NORMAL

StartFadeDistance=50.0

EndFadeDistance=50.0

.

.

.

Edited by Bandy

Share this post


Link to post
Share on other sites

Wow Bandy, thanks for the detailed response. But.... I tried pasting what you have above into my Terrains folders' DATA.ini. But still nothing. I have exactly what you wrote in my DATA.ini files. And I only overwrote those lines. I'm stumped. :dntknw:

Share this post


Link to post
Share on other sites

Doesn't this require a texture in the TextureStage[01].TextureName= and TextureStage[02].TextureName= callouts? I always thought it did, but I'm probably wrong.

Share this post


Link to post
Share on other sites

All I can say is this works in my FEG install. FE2 I think has new FX files, so maybe the code above is referencing FX that do not exist anymore.

 

Sorry, can't add anything more except that it is weird that those textures are not specified. There must be a default.

Edited by Bandy

Share this post


Link to post
Share on other sites

Did anybody ever come across the fix for FE2 by chance? I can live with the dead water if need be, Jan's seasonal terrains are just outstanding, unbelievable how good they are and what it adds to the sim, the water would be cool though if anyone has an answer.

Share this post


Link to post
Share on other sites

I have another problem, only in FE2 using Jan Tuma's terrain. They are a lot of shimmering buildings in the cities. Anybody knows a fix about it? I have no problem in FE1.

Edited by ojcar

Share this post


Link to post
Share on other sites

Like SF2, FE2 uses different effects shaders, with different names

 

try this:

 

[NormalTextureMaterial]

EffectShaderName=terTerrainEffect.fx

DepthBufferCheck=TRUE

DepthBufferWrite=TRUE

RenderedInOrder=FALSE

AlphaTestEnabled=FALSE

CullMode=CLOCKWISE

LightEnabled=TRUE

SpecularEnabled=FALSE

EmissiveEnabled=FALSE

FogEnabled=TRUE

AmbientColor=1.000000,1.000000,1.000000,1.000000

DiffuseColor=1.000000,1.000000,1.000000,1.0000000

ZBufferOffset=0.000000

BlendOp=ONE

NumTextureStages=1

TextureStage[01].TextureName=

TextureStage[01].MipMap=TRUE

TextureStage[01].FilterEnabled=TRUE

TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE

TextureStage[01].StageAlphaOp=NO_OP

 

[WaterTextureMaterial]

EffectShaderName=terWaterEffect.fx

DepthBufferCheck=TRUE

DepthBufferWrite=FALSE

RenderedInOrder=TRUE

AlphaTestEnabled=TRUE

CullMode=NO_CULL

LightEnabled=TRUE

SpecularEnabled=TRUE

EmissiveEnabled=FALSE

FogEnabled=TRUE

AmbientColor=1.000000,1.000000,1.000000,1.000000

DiffuseColor=1.000000,1.000000,1.000000,1.000000

SpecularColor=1.000000,1.000000,0.900000,1.000000

SpecularPower=1.000000lol

ZBufferOffset=4.000000

BlendOp=BLEND_SRC_ALPHA

NumTextureStages=2

TextureStage[01].TextureName=

TextureStage[01].MipMap=TRUE

TextureStage[01].FilterEnabled=TRUE

TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE

TextureStage[01].StageAlphaOp=TEXTURE

TextureStage[02].TextureName=

TextureStage[02].MipMap=TRUE

TextureStage[02].FilterEnabled=TRUE

TextureStage[02].ReflectionMapping=TRUE

TextureStage[02].StageColorOp=TEXTURE_BLEND_TEXTURE_ALPHA

TextureStage[02].StageAlphaOp=DIFFUSE

 

[backgroundMaterial]

EffectShaderName=terFarTerrainEffect.fx

DepthBufferCheck=TRUE

DepthBufferWrite=TRUE

RenderedInOrder=FALSE

AlphaTestEnabled=FALSE

CullMode=CLOCKWISE

LightEnabled=TRUE

SpecularEnabled=FALSE

EmissiveEnabled=FALSE

FogEnabled=TRUE

AmbientColor=1.000000,1.000000,1.000000,1.000000

DiffuseColor=1.000000,1.000000,1.000000,1.0000000

ZBufferOffset=0.000000

BlendOp=ONE

NumTextureStages=1

TextureStage[01].TextureName=

TextureStage[01].MipMap=TRUE

TextureStage[01].FilterEnabled=TRUE

TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE

TextureStage[01].StageAlphaOp=NO_OP

 

[solidObjectTextureMaterial]

EffectShaderName=terSolidObject.fx

DepthBufferCheck=TRUE

DepthBufferWrite=TRUE

RenderedInOrder=TRUE

AlphaTestEnabled=TRUE

CullMode=NO_CULL

LightEnabled=TRUE

SpecularEnabled=FALSE

EmissiveEnabled=FALSE

FogEnabled=TRUE

AmbientColor=1.000000,1.000000,1.000000,1.000000

DiffuseColor=1.000000,1.000000,1.000000,1.000000

ZBufferOffset=1.000000

BlendOp=BLEND_SRC_ALPHA

NumTextureStages=1

TextureStage[01].TextureName=

TextureStage[01].MipMap=TRUE

TextureStage[01].FilterEnabled=TRUE

TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE

TextureStage[01].StageAlphaOp=NO_OP

Fade=NORMAL

StartFadeDistance=50.0

EndFadeDistance=50.0

 

 

[AlphaObjectTextureMaterial]

EffectShaderName=terAlphaObject.fx

DepthBufferCheck=TRUE

DepthBufferWrite=FALSE

RenderedInOrder=false

AlphaTestEnabled=TRUE

CullMode=NO_CULL

LightEnabled=TRUE

SpecularEnabled=FALSE

EmissiveEnabled=FALSE

FogEnabled=TRUE

AmbientColor=1.000000,1.000000,1.000000,1.00000

DiffuseColor=1.000000,1.000000,1.000000,1.00000

ZBufferOffset=2.000000

BlendOp=BLEND_SRC_ALPHA

NumTextureStages=1

TextureStage[01].TextureName=

TextureStage[01].MipMap=FALSE

TextureStage[01].FilterEnabled=TRUE

TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE

TextureStage[01].StageAlphaOp=TEXTURE

Fade=NORMAL

StartFadeDistance=50.0

EndFadeDistance=50.0

 

note the 'ter*nameof*.fx

 

wrench

kevin stein

Share this post


Link to post
Share on other sites

You know, I find this code stuff almost as entertaining as the sim, in an obsessive-compulsive kinda way...Anyway, by way of explanation, here are my settings, I'm using Jan's terrain, Shrike's sky, some effects/smoke, Tailspin's worn airfield, etc., on an XP system with a Nvidea 7600GS, most everything set on "Good" or whatever just below "Unlimited is:

 

[NormalTextureMaterial]

UseEffectShader=TRUE

EffectShaderName=TerrainEffect2.fx

DepthBufferCheck=TRUE

DepthBufferWrite=TRUE

RenderedInOrder=FALSE

AlphaTestEnabled=FALSE

CullMode=CLOCKWISE

LightEnabled=TRUE

SpecularEnabled=FALSE

EmissiveEnabled=FALSE

FogEnabled=TRUE

AmbientColor=1.000000,1.000000,1.000000,1.000000

DiffuseColor=1.000000,1.000000,1.000000,1.0000000

ZBufferOffset=0.000000

BlendOp=ONE

NumTextureStages=1

TextureStage[01].TextureName=

TextureStage[01].MipMap=TRUE

TextureStage[01].FilterEnabled=TRUE

TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE

TextureStage[01].StageAlphaOp=NO_OP

 

[WaterTextureMaterial]

UseEffectShader=TRUE

EffectShaderName=WaterEffect2.fx

DepthBufferCheck=TRUE

DepthBufferWrite=FALSE

RenderedInOrder=TRUE

AlphaTestEnabled=TRUE

CullMode=NO_CULL

LightEnabled=TRUE

SpecularEnabled=TRUE

EmissiveEnabled=FALSE

FogEnabled=TRUE

AmbientColor=1.000000,1.000000,1.000000,1.000000

DiffuseColor=1.000000,1.000000,1.000000,1.000000

SpecularColor=1.000000,1.000000,0.900000,1.000000

SpecularPower=1.000000lol

ZBufferOffset=4.000000

BlendOp=BLEND_SRC_ALPHA

NumTextureStages=2

TextureStage[01].TextureName=

TextureStage[01].MipMap=TRUE

TextureStage[01].FilterEnabled=TRUE

TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE

TextureStage[01].StageAlphaOp=TEXTURE

TextureStage[02].TextureName=

TextureStage[02].MipMap=TRUE

TextureStage[02].FilterEnabled=TRUE

TextureStage[02].ReflectionMapping=TRUE

TextureStage[02].StageColorOp=TEXTURE_BLEND_TEXTURE_ALPHA

TextureStage[02].StageAlphaOp=DIFFUSE

 

[backgroundMaterial]

UseEffectShader=TRUE

EffectShaderName=FarTerrainEffect2.fx

DepthBufferCheck=TRUE

DepthBufferWrite=TRUE

RenderedInOrder=FALSE

AlphaTestEnabled=FALSE

CullMode=CLOCKWISE

LightEnabled=TRUE

SpecularEnabled=FALSE

EmissiveEnabled=FALSE

FogEnabled=TRUE

AmbientColor=1.000000,1.000000,1.000000,1.000000

DiffuseColor=1.000000,1.000000,1.000000,1.0000000

ZBufferOffset=0.000000

BlendOp=ONE

NumTextureStages=1

TextureStage[01].TextureName=

TextureStage[01].MipMap=TRUE

TextureStage[01].FilterEnabled=TRUE

TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE

TextureStage[01].StageAlphaOp=NO_OP

 

[solidObjectTextureMaterial]

DepthBufferCheck=TRUE

DepthBufferWrite=TRUE

RenderedInOrder=TRUE

AlphaTestEnabled=TRUE

CullMode=NO_CULL

LightEnabled=TRUE

SpecularEnabled=FALSE

EmissiveEnabled=FALSE

FogEnabled=TRUE

AmbientColor=1.000000,1.000000,1.000000,1.000000

DiffuseColor=1.000000,1.000000,1.000000,1.000000

ZBufferOffset=0.000000

BlendOp=BLEND_SRC_ALPHA

NumTextureStages=1

TextureStage[01].TextureName=

TextureStage[01].MipMap=TRUE

TextureStage[01].FilterEnabled=TRUE

TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE

TextureStage[01].StageAlphaOp=TEXTURE

 

[AlphaObjectTextureMaterial]

DepthBufferCheck=TRUE

DepthBufferWrite=FALSE

RenderedInOrder=false

AlphaTestEnabled=TRUE

CullMode=NO_CULL

LightEnabled=TRUE

SpecularEnabled=FALSE

EmissiveEnabled=FALSE

FogEnabled=TRUE

AmbientColor=1.000000,1.000000,1.000000,1.00000

DiffuseColor=1.000000,1.000000,1.000000,1.00000

ZBufferOffset=2.000000

BlendOp=BLEND_SRC_ALPHA

NumTextureStages=1

TextureStage[01].TextureName=

TextureStage[01].MipMap=TRUE

TextureStage[01].FilterEnabled=TRUE

TextureStage[01].StageColorOp=TEXTURE_MODULATE_DIFFUSE

TextureStage[01].StageAlphaOp=TEXTURE

Fade=NORMAL

StartFadeDistance=50.0

EndFadeDistance=50.0

 

OK, the above gives me good terrain, dead water, and an occasional flashy building. Although interestingly I don't get any flashy buildings in the Vosegen terrain, I also have no "[backgroundMaterial]" entry in Vosegen or in Edwards Flanders terrain, I'm not sure what that means if anything...Anyway, good terrain, dead water, occasional flashy building. Now if I do a line for line swap with Wrench's .ini I get good terrain, a different dead water, and shimmering trees...Now my .ini's do not include the "ter" prefix, but the terrain, the trees and whatnot, seem to render really nicely. Maybe the new ini's didn;t work because instead of simply cutting and pasting Wrench's ini's in place of my own I did a line for line swap checking along the way and left my entry for example, "EffectShaderName=TerrainEffect2.fx," only adding the "ter-" prefix in the beginning. I thought the "2" designated something of importance, I wasn't sure, I left it...

 

What does it all mean? Beats me. I'm not certain what importance that "ter" prefix plays in the big scheme of things as the terrain for the most part looks good without it...In summary, swapping the old for the new gives me flashy trees and a different kind of dead water, I feel like the answer is real close here, maybe more obsessing is in order, and it really is kind of fun in a weird way...

Share this post


Link to post
Share on other sites

dx10 shaders, maybe??? :dntknw:

 

pull the data ini from any of the stock terrains and compare. What is looks like, is the 2-type fx callouts may be custom-made. They may not work in FE2, without rebulding to take advantage of the new new shaders (even in XP. iirc, it's a game engine ™ thing)

 

btw, the section I posted is from the Flanders terrain, after my conversion to FE2.

 

This tutorial might be of some help:

 

http://combatace.com/topic/54856-converting-sfwo-terrains-to-sf2-usage/

Share this post


Link to post
Share on other sites

Good info...The more I monkey with this the more I learn, albiet in fits and starts, but it really is fun tweaking with it when things fall into place. There is a logic to it that is gratifying somehow...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..