Jump to content

Recommended Posts

Does anyone have an idea how to add shadows to third-party weapons?

I added this entry in .ini file

 

[shadow]

CastShadow=TRUE

ShadowCastDist=10000

MaxVisibleDistance=100

 

but it does not work

Share this post


Link to post
Share on other sites

I have set at unlimited but didn't show. Im using MGunny weapons pack, only stock weapon has shadows.

Share this post


Link to post
Share on other sites

a lot them in gunny's pak are missing a few lines (either that, or me running the SF2WepEd changed something)

 

Make sure the weapo's lods are called out in the main ini, and add the shadow lines

 

This is from the JM-117/GSC-1 I jsut released with the Misti F1

 

[WeaponData]

ObjectFullName=JM-117 w/EO Kit

ObjectDataFile=JM117-GCS1_data.INI

 

[LOD001]

Filename=BOLT117.LOD

Distance=100

 

[LOD002]

Filename=BOLT117-001.LOD

Distance=250

 

[LOD003]

Filename=BOLT117-002.lod

Distance=500

 

[shadow]

CastShadow=TRUE

ShadowCastDist=1200

MaxVisibleDistance=400

 

works as advertised!

 

wrench

kevin stein

Share this post


Link to post
Share on other sites

Umm yes I edited ini and add entries for properly lods and shadow, but still they are not show, hmm maybe in 3dsmax must be something set??

Share this post


Link to post
Share on other sites

beside having the shadow section in the weapons ini file, there are several names which must be identical :

 

folder name of the weapon = ini name of the weapon = name of the main LOD = TypeName and ModelName in data ini of weapon

 

many add-on weapons have not the correct matching name for the LOD - that prevents the shadow from showing up,

despite having the shadow section in the ini

Share this post


Link to post
Share on other sites

beside having the shadow section in the weapons ini file, there are several names which must be identical :

 

folder name of the weapon = ini name of the weapon = name of the main LOD = TypeName and ModelName in data ini of weapon

 

many add-on weapons have not the correct matching name for the LOD - that prevents the shadow from showing up,

despite having the shadow section in the ini

 

How does this work for asymmetric fuel tanks? I get the shadow for the left tank (Tank170_RF-104.LOD) but no shadow for the right tank (Tank170_RF-104R.LOD).

 

At the moment I have this setup.

 

[WeaponData]
ObjectFullName=170-gal Drop Tank
ObjectDataFile=Tank170_RF-104_data.INI

[LOD001]
Filename=Tank170_RF-104.LOD
Distance=3000

[shadow]
CastShadow=TRUE
ShadowCastDist=1000
MaxVisibleDistance=500

 

[WeaponData001]
TypeName=Tank170_RF-104
FullName=170-gal Drop Tank
ModelName=Tank170_RF-104
Mass=605.559998
Diameter=0.475000
Length=5.572000
SubsonicDragCoeff=0.200000
SupersonicDragCoeff=0.770000
AttachmentType=
SpecificStationCode=
NationName=
StartYear=0
EndYear=0
Availability=0
BaseQuantity=0
Exported=FALSE
ExportStartYear=0
ExportEndYear=0
ExportAvailability=0
WeaponDataType=5
MaxFuelAmount=501.230011
Asymmetrical=TRUE
RightModelName=Tank170_RF-104R

post-2896-023758900 1280881130.jpg

Share this post


Link to post
Share on other sites

Nevermind, got it to work. All that was needed was a Tank170_RF-104R.ini.

 

[WeaponData]
ObjectFullName=170-gal Drop Tank
ObjectDataFile=Tank170_RF-104_data.INI

[LOD001]
Filename=Tank170_RF-104R.LOD
Distance=3000

[shadow]
CastShadow=TRUE
ShadowCastDist=1000
MaxVisibleDistance=500

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..