Jump to content
Sign in to follow this  

Problems Loading Mods in Fe2 Win7 64

Recommended Posts

After fussing, fumbling and grumbling for several days now, I remain deep into the swamp with FE2 on my new Win 7 64 system.

Everything runs fine, including FE2 (60 fps and great quality images), but I cannot get any mods beyond Main and Single Mission screens to load.


Yes, I have looked at and tried to faithfully follow the excellent advice from migbuster in http://forum.combata...e-by-migbuster/ I have loaded mods into the SavedGames directory, and created the appropriate folders where the named folders did not previously exist. The game is loaded into Program Files (x86) but I also tried loading into Program Files with the same results. I reviewed the file names for variation s in upper lower case. These are the same files copied from my XP Pro SP3 install that ran FE2 and load AOK.


This problem exists with the Strutters I helped create and with other add on mods such as the Staaken (previously a WIP flyable) and the Gotha (previously a modded flyable) as well as other mods including the new Tuma Terran.


I tried modding with and without my beloved Jones Soft Mod Enabler. No diff in results with or without. I can see the mods in the file structure, but the game does not appear to compile them. They simply fail to appear.


Ironically my old FE2 XP Pro install is/was AOK.


I have not yet tried running the game in XP emulation mode. That seems a waste with a game that was written for W7.


I'd really like to hear from anyone who has W7 64 and successfully loaded new AC and mods, especially using the Jones Soft Mod Enabler. I must be missing something, perhaps some gray matter between my headphones.


2.80 gigahertz Intel Core i7 930

Windows 7 Home Premium (x64) (build 7600)

8 Gig RAM, ATI Radeon HD 5700

post-6006-033441100 1282313613.jpg

Share this post

Link to post
Share on other sites

Sinbad I have Win7 64bit and everything works fine.


I think your problem is you created a folder called MODS and put things in there. In your /SavedGames/ThirdWire/FE2/ folder structure you should have a folders for each object or mod you want to install. Not just one folder.


/SavedGames/ThirdWire/FE2/ Objects/ (Aircraft-GroundObjects-Decals-Guns-Weapons)

/SavedGames/ThirdWire/FE2/ Effects/

""""""""""""""""""""""""""""""" ''/ Terrains/

""""""""""""""""""""""""""""""" / Sounds/

"""""""""""""""""""""""""""""""" / Flight/


etc, etc. Of course when you unpack all the security files this is where you put all the unpacked files.

You will need to create most of these new folders like the Sounds folder and the Effects folder. Also the Decals folder inside the FE2/ Objects/ Decals/ has to be made.


I hope you understand what I wrote here. I'm on the fly right now. I have to get back to work. But I think this might be your problem. We'll talk later.

Share this post

Link to post
Share on other sites

Hi Quack 74-


Thanks for the prompt reply.


l I'm glad to hear that it is possible to mod FE2 in W7 64.


The files are only in MODS as a storage point.


When the Jones Soft Generic Mod Enabler runs, it loads copies of each file (or file folder) directly into the target folders, retaining the originals in MODS.


Unless I overlooked something in configuring the file structure or files, everything should be going into the structure as outlined.


But obviously something is not correct. If I had it right these posts would not be here.


I look forward to hearing more about how you do what you do to make it all work.


I thought you were using the JSGME as well. If so please advise how you have that configured.




Share this post

Link to post
Share on other sites

Yep I have FE2 on Win 7 64, intel i7, Ati 5700


The Mods work as in SF2 on here - so its strange that somethings are not appearing. Did you move the mods manually in? -


1. Cut the folder called MOD out and stick it on your desktop - there is a good chance that could be causing problems - can the JSME be set to save the mods elsewhere?


2. Check they are not in subfolders - like this




that wont work


3. What patch are you running?


4. Here is what I would try in case the options.ini file has been porked - cut the whole FirstEagles 2 folder


C:\Users\Ralph\Saved Games\ThirdWire\FirstEagles2


and paste it onto your desktop. So you are left with no \Saved Games\ThirdWire\FirstEagles2 folder.


Run the game - it will create a new FirstEagles2 folder - exit the game and move back 1 mod (ie the terrains)only from the FirstEagles folder you saved on the desktop - then test it .



5. Why do you need the JSME - what does it do exactly?

Share this post

Link to post
Share on other sites

Hi Migbuster!


Thanks for looking in.


Now I have two confirmations of AOK FE2 mods in W7 64 and good evidence that something is especially amusing here.


I tried -

both manual and JSME installs;

with the MOD folder in place and manually without the MOD folder;

both FE2 clean and FE2 with the July patch;

scrubbing the FE2 install with Revo Uninstaller and reinstalling;

both install auto to Program Files (x86) and forced install to Program Files;

loading the AC files that run AOK on my XP Pro FE2 install and even downloading the files I previously uploaded from the CA site.


I was able to manually install the Tuma Terrains after deleting the full FE2 saved games folder, but no joy with the AC.


There are/were no double filing Aircraft\SE5A\SE5A type errors but that was a good idea.


I'm a bit surprised you don't know JSGME. It is a set of scripted copy and delete routines that take a file or file set and pastes it into another targeted file set while preserving a copy of the original. Then it can remove same, restoring the original. It is a great aid for modding and testing, and saves a lot of time, especially with complex installs of terrains, multiple skins etc. It is more fully described here: http://www.users.on.net/~jscones/software/products-jsgme.html


I have used the most recent version (2.6.0 August 2010) during the current fun, but so far exclude JSME as a cause of the mystery because I cannot get the AC/skin mods to work even if I load them manually, even on an install that has not yet included the JSME.


Having said that, I think I'll try an earlier version of the JSME and also try manually installing some third party skins for the stock AC.


I have seen other posts at the TW forum describing similar problems but not in enough detail to sort this out. Knowing that you and Quack74 can work mods with similar systems makes it clear that there is an answer, hidden somehow, that I have not found. Not yet - - -


Meanwhile, this is the most intractable problem I've been stuck with for some time.




Update- I have been able to do a manual skin install - Wow - just like learning to walk again!


I now suspect the latest version of the JSME. I'll try an earlier version tomorrow. Right now I want to see how much Scotch is in the bottle.


Stay tuned.



Edited by sinbad

Share this post

Link to post
Share on other sites

I just noticed that all the file folders in Saved Games are set for READ ONLY.

I have repeatedly tried to change the setting but there appears to be an override somewhere.

There must be a way to change that



After further testing it seems the READ ONLY setting is not the problem.\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\


Edited by sinbad

Share this post

Link to post
Share on other sites

Thanks for the info on the mod program - might give it a look - am trying to write something for myself at the mo.


I havnt installed the July 2010 patch yet - still on June 2010 - although suspect thats not the issue


See PM regarding the RO Directories.

Share this post

Link to post
Share on other sites

Could this maybe helpfull?

Found this at subsim:


If you intend installing over any previous version of JSGME, you MUST disable all enabled mods first. Not doing so will corrupt JSGME and hence your game. Once you've disabled all mods, you can install the new version over the top of the old version and resume using as normal.


If you like to read in his threat:



Best regards :salute:


PS: Using his last version on many games including FEG on Win7 without any problems

Share this post

Link to post
Share on other sites

Problem solved, with many thanks, by Migbuster.


When the files were copied across to the new machine, for some reason the Texture set.ini files were stripped from the skin files. It seems not all backup/synchronize software believes that ini files should be copied.


It is especially hard to see what is not there.


When I was troubleshooting I looked everywhere but inside the skin folders, where the testureset.ini files reside.


Thanks A6Intruder and all of you who were willing to spend time to help cure this headache.


BTW- the models and skins look terrific in FE2 DX11.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..