Jump to content
Sign in to follow this  
33LIMA

No sound in game - possible solution

Recommended Posts

I've seen a few posts re sound probs but none like this so I'll post in case it helps someone else do a needless re-install. Like I just did.

 

I was fiddling with the keyboard as an OFF mission loaded and about the time the 3d world appeared I evidently hit my keyboard's 'mute' button. Many 'boards seem to have these 'helpful' extra buttons along the top. In this case it was anything but helpful.

 

I got no sound in 3d of course, having inadvertently muted all the sound, just as it was loading. I eventually realised what had happened, seeing the red ring and bar over the status bar's speaker icon, on my next visit to my desktop. Opened the sound settings and un-muted the sound slider.

 

Now I got interface sound but no game sound.

 

Tried everything I could think of, including toggling on and off the offending keyboard mute button. Sound was ok in other games and everything else checked out, so I figured the button must have done something to OFF. Checked CFS3config and sound was not disabled. Checked in-game sound was not disabled, via the drop-down cFS3 menu. Checked uisel.xml in my user appdata folder and bingo, SoundOn was set to 'n'. Changed it to 'y' and all was well - for about one mission. Then back to interface sound only. The uisel.xml setting was probably something I'd done during troubleshooting, not the original problem. Don't know why it worked once and not again.

 

Finally gave up and assumed some other OFF/CFS3 setting was corrupted. But using the Workshop reset options did not help.

 

So I uninstalled, deleted ALL folders and re-installed, the whole shooting gallery.

 

Still the same problem. :blink:

 

After a while I had a hunch. Fiddling with the sound settings that pop up when i clicked the usual little system speaker icon in the status bar at bottom of my desktop, I'd noticed there was one sound slider for each application running. They were not muted. I couldn't see one for OFF, but...what would I see when I launched it? Might the OFF sound setting be muted, but invisibly, until I launched it? And so it proved to be.

 

I launched OFF, and checked the slider which appeared for it - not muted. But that was just for the interface, not the 3d world. So I started a mission and hit the keyboards 'Windows' key so I could see the sound settings as they looked when the sim was running in 3d. Sure enough, an extra slider ('CFS3', IIRC) had now appeared for it and sure enough it was muted. So I unchecked 'mute' and my sound was back to normal.

 

A most tiresome lesson, but one I won't forget - beware of hitting the keyboard's mute button! Worth checking before re-installing, if your in-game sounds suddenly stop.

Edited by 33LIMA

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..