Jump to content
Sign in to follow this  
Jack Morris

Fixing an Invisible Airfield in Modded Maps

Recommended Posts

Hi All,

 

Someone told me how to solve this problem before, but I forgot how I did it.

 

I am running SFP1 on Windows 7 due to the fact that there is more mods, and performance is still perfect,so that is not an issue.

 

However when I install a modded map (Korea, Euro WWII) and fly, everything is perfect, except the airfields. There are objects the ground layer (Taxiways, Runways) is not there, and you can see the default scenery tiles instead.

 

From what I remember I need to add, or remove some text from a config file.

 

Help would be appreciated,

 

Regards,

 

Jack

Share this post


Link to post
Share on other sites

1) wrong terrain cat reference pointer

2) missing airfield from the terrain cat referenced

3) missing airfield data ini from terrain cat referenced

Share this post


Link to post
Share on other sites

1) wrong terrain cat reference pointer

2) missing airfield from the terrain cat referenced

3) missing airfield data ini from terrain cat referenced

 

Ok thanks, I'm kind of a newbie at this on SFP1, so how do I check up on these things. By the way, I am trying to fix the problem on Euro WW2 map.

Share this post


Link to post
Share on other sites

Under ground level, I believe.

 

Now it depends on the terrain. In my Deutschland terrain, for instance the tiles which are used as basich for airfields are called Feldflugplatz (in other terrains it are different tiles).

If you open the deutschland_data.ini you find following lines:

 

[Texture036]

Filename=Feldflugplatz.BMP

HasWater=0

HeightMap=Feldflugplatz_hm.BMP

HeightMapScale=0.000000

Color=0.295611,0.372053,0.179665

SolidObjectTexture=terobject_buildings1.BMP

AlphaObjectTexture=terobject_trees1.TGA

 

Important is the line HeightMapScale=0.00000

if there is a value bigger than 0.0 then reduce it to 0.0

Share this post


Link to post
Share on other sites

Now it depends on the terrain. In my Deutschland terrain, for instance the tiles which are used as basich for airfields are called Feldflugplatz (in other terrains it are different tiles).

If you open the deutschland_data.ini you find following lines:

 

[Texture036]

Filename=Feldflugplatz.BMP

HasWater=0

HeightMap=Feldflugplatz_hm.BMP

HeightMapScale=0.000000

Color=0.295611,0.372053,0.179665

SolidObjectTexture=terobject_buildings1.BMP

AlphaObjectTexture=terobject_trees1.TGA

 

Important is the line HeightMapScale=0.00000

if there is a value bigger than 0.0 then reduce it to 0.0

 

I have attached the "EuroWW2_Data.ini" I cannot see an airfield tile, would you mind taking a look?

 

 

EuroWW2_data.txt

Share this post


Link to post
Share on other sites

you won't find airfields in the data.ini; that only has the 'terrain' info (what tiles, height field information, etc)

 

you'll be looking in the _targets.ini.

 

If you're using my slightly upgraded verision

 

http://combatace.com/files/file/6930-ww2-europe-by-fng2k-edward/

 

even with the 'euro_ww2_****airfield.ini, it should still work. mine always did, pointing to desert or germany cats

 

be advised, that that terrain (to not to put too fine a point on it), has serious issues

Edited by Wrench

Share this post


Link to post
Share on other sites

you won't find airfields in the data.ini; that only has the 'terrain' info (what tiles, height field information, etc)

 

you'll be looking in the _targets.ini.

 

If you're using my slightly upgraded verision

 

http://combatace.com...y-fng2k-edward/

 

even with the 'euro_ww2_****airfield.ini, it should still work. mine always did, pointing to desert or germany cats

 

be advised, that that terrain (to not to put too fine a point on it), has serious issues

 

That's the one that I have, after clicking the link on how to make an install on that page, could the fact that I have WoV and not WoE be the problem?

Share this post


Link to post
Share on other sites

Jack, in the file you posted all heightmapscales are set to 50. Give it a try to reduce all heightmapscale values to 0 and then test it again. Perhaps it will work.

 

 

Do you see the airfield from high altitutes? Or are the airfields always invisible. If you see the airfields from the high and they disappear if you come close or low, then the heightmapscale setting is the reason for the problem. If you never see airfields you must set a correct link to the .cat file.

Share this post


Link to post
Share on other sites

Jack, in the file you posted all heightmapscales are set to 50. Give it a try to reduce all heightmapscale values to 0 and then test it again. Perhaps it will work.

 

 

Do you see the airfield from high altitutes? Or are the airfields always invisible. If you see the airfields from the high and they disappear if you come close or low, then the heightmapscale setting is the reason for the problem. If you never see airfields you must set a correct link to the .cat file.

 

Nope. Not working still. I think I am going to have to call it a day. Thanks for all your help guys! I will try again in a few months when I get my new Alpine Computer.

 

See you then,

 

Jack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..