Jump to content
Sign in to follow this  

SF2 not working

Recommended Posts

All of a sudden whenever I start any SF2 tiltle I get the message: SF2* has stoppped working. Tried to reinstall the whole thing two times, all merged, latest patch, no mods, still the same error. SF2 worked fine up until now. Haven't installed anything new on my pc or updated anything since then.This is the error log:


Problem signature:
  Problem Event Name:    APPCRASH
  Application Name:    StrikeFighters2.exe
  Application Version:
  Application Timestamp:    4f5951fe
  Fault Module Name:    KERNELBASE.dll
  Fault Module Version:    6.1.7601.18229
  Fault Module Timestamp:    51fb1116
  Exception Code:    0eedfade
  Exception Offset:    0000c41f
  OS Version:    6.1.7601.
  Locale ID:    1050
  Additional Information 1:    0a9e
  Additional Information 2:    0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:    0a9e
  Additional Information 4:    0a9e372d3b4ad19135b953a78882e789

I'm using Win7 and NVidia graphic card.

Any ideas are welcome.

Share this post

Link to post
Share on other sites

maybe try this:


1. rename mod folder (es StrikeFighters2.bak)

2. the program will generate a new vanilla StrikeFighters2 folder

3. if it works now copy from that new folder its options.ini and copy it in StrikeFighters2.bak overwriting the previous one

4. delete StrikeFighters2 folder and rename StrikeFighters2.bak to StrikeFighters2

5. run the game again


I don't know if this could work with your issue ... but it saved my mod install several times .....


I hope it could be useful.



Share this post

Link to post
Share on other sites

Thanks for the suggestion, but it's not workin...


To be clear, I have a problem running SF2 and it's titles without mods. Fresh new install of SF2* is not working, it informs the  error each time i start it...

Share this post

Link to post
Share on other sites

Did you do a clean UNINSTALL? (including deleting folders and registry entries?)


I'm not sure if you are comfortable working with REGEDIT......


Any luck on the TW forums?


I have not had this problem but I did run into a day where all my SF2 exes would CTD. I don't do reinstalls per se. I back up my SF2 EXE folder to a zip file and just restore that. That got me running again.


Are you sure you didn't have an anti-virus, spyware, etc. update sneak in somewhere? Just askin'..........

Share this post

Link to post
Share on other sites

I've never tampered with REGEDIT. I've reinstalled SF2 many times before without deleting registry entries and it always worked fine. I've checked antivirus and similar stuff, and don't see any problem...   :(

Share this post

Link to post
Share on other sites

Can you get to the main menu screen?


What version are you trying to install?


you are running it from the exe not from an old shortcut?


If any mod folder has been created delete that


Does it run as admin? (right click - properties - compatibility).


Try stopping some programs via task manger to see if any other program is stopping it.

Edited by MigBuster

Share this post

Link to post
Share on other sites

Oh man. It works when run as admin!  I didn''t even try it 'cause I thought it was something not so trivial and stupid. I do not believe it. I'm really starting to hate PCs, the amount of time  and effort one has to put in for something just to work is tremendous. I am the only user of my PC, why ask admin? could as well be run as George!MiniGun.gif.pagespeed.ce.Uw3L7cW4wh.gif  bought a new rig few weeks ago and couldn't get my Windows 7 to update, had to spend 3 days of googling error and trying online remedies until I finally got it to update. I envy the ones who own Machintosh...



Thanks Migbuster and everybody!

Edited by hrc

Share this post

Link to post
Share on other sites

Microsucks loans you your computer, didn't you know that? :biggrin:   There's admin, and then there's Admin (Winblows 7,8,8.1,9,9.725a).  You're just not old enough to run a computer by yourself, according to Microsoft.  Glad you got it sorted out, hrc. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..