Jump to content

Recommended Posts


Take a look at the controls configuration. You may have to set it again. Also make sure you connect your joystick to your pc BEFORE starting SF2

Share this post


Link to post
Share on other sites

To add to the above most games don't recognize the stick if you plug it in after starting the game.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..