Jump to content
Sign in to follow this  
WallysWorld

Adding the Campaign Customizer DLC to July 2012 SF2?

Recommended Posts

Hello,

I have my SF2 install set to the July 2012 patch and wouldn't mind buying the Campaign Customizer DLC. But I am worried that installing the customizer DLC may update SF2 to the latest patch. I read about extracting the files from other DLC's using WinRAR and just copying the .DLC file to SF2's DLC folder which seems to work according to posters. Can the same be done with the Campaign Customizer DLC?

Thanks.

Edited by WallysWorld

Share this post


Link to post
Share on other sites

It is possible to set up DLC to earlier versions, IF otherwise there is no compatibility issue besides version numbering...

I did set up DLC 28 and 29 (AI planes)  under July2012. I think the same can be done with DLC011 as well. If I remember you only need the DLC file (Which is a CAT, you can look into it). You don't need to extract it, anyway you can't extract LODs, and the customiser is a fake LOD (not to be stolen). So ust copy this file into the DLC inside your GAME (NOT ADDON) folder and start the game. You can also add the line into Options.ini  DLCdata011=TRUE..  But I think the game will do it automatically if you run it with the DLC file in the correct place.

Look, this is my main game Version.ini

Quote

[Version]
BuildDate=Jul 2012
StrikeFighters2=TRUE
StrikeFighters2 Vietnam=TRUE
StrikeFighters2 Europe=TRUE
StrikeFighters2 Israel=TRUE
StrikeFighters2 Exp1=TRUE
StrikeFighters2 Exp2=TRUE
StrikeFighters2 NorthAtlantic=TRUE
StrikeFighters2 Exp3=FALSE

[OnlineNews]
LastUpdateVersion=Jul 2013
LastDLCCount=29

[DLC]
DLCData003=TRUE
DLCData028=TRUE
DLCData011=TRUE
DLCData029=TRUE

 

Share this post


Link to post
Share on other sites

Thanks for the post, Snailman. Unfortunately it seems that placing the DLC file from the customizer into the DLC folder and also the campagincustomscreen.dll into the Menu folder produces an error in SF2 when I try to customize a campaign.

Trying to install the customizer the normal way says that my SF2 is at the wrong version and to update it to July 2013.

Share this post


Link to post
Share on other sites

I've emailed TW support asking if they have the July 2012 setup file available, but I'm not hopeful they will reply. I think I might have just wasted $7 as I don't want to go to the July 2013 patch from what I've read on this forum.

Share this post


Link to post
Share on other sites

that's horseshit

90+% of us are on that last patch level. all mods made in the last 3+ years are for that patch level. 

what does that tell you?

 

 

Share this post


Link to post
Share on other sites

I'm just saying what other people have posted about the patch levels and which to stay about. Something about the AI not using external ECM pods and flares with the latest patch? I happened to come across some threads as I was installing SF2.

I would be happy if I could patch it to the 2013 patch and not wonder about what these threads said as I humbly defer to those with way more SF2 experience than me.

https://combatace.com/forums/topic/91071-which-patch-is-best/

 

 

Edited by WallysWorld

Share this post


Link to post
Share on other sites
13 hours ago, WallysWorld said:

I finally patched my SF2 to the 2013 patch and successfully installed the campaign customizer which is great.

Sorry, I certainly didn't mean to cause a stir here with my posts.

 

Unfortunately, the choice of patch level involves various compromises. You gain some things and lose others. Don't worry about causing stirs. The people here are plain and direct speakers, but in my experience it's not their intention to silence anyone.

  • Like 1

Share this post


Link to post
Share on other sites

I have never encountered any addon that did not work on July 2012...  and all DLCs are also working. Sure it need a little work, but can be done. The addons I am doing have been done under 2012  and noone has complained that they aren't working. So I guess it is not a serious concern.

As for external CM launchers, I also think they are not working in July2013, but I will test it for you just to be sure. In case they aren't working, it's just more work for us, modders.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..