Jump to content
Sign in to follow this  
Dimus

Flickering?

Recommended Posts

Hello guys,

 

I must admit that I was away from OFF for several reasons but I came back to it after the release of HitR which I promptly got after its release. I don't know if it was the case before HitR but I get a lot of flickering on the terrain, especially trees. My sliders are 5 5 4 4 5 5 and I run on a Q6600 2.4 with a GeForce 9600GT512. My frame rates are in the 30s with AA at 8xQ and AS at 16x set through Nhancer for CFS3.exe. My only overrides that are checked are Dual pass render and Terrain Detail Texture.

 

Some how it also seems that the AA is not applied well. Any thoughts, suggestions?

Edited by Dimus

Share this post


Link to post
Share on other sites

Thanks Unc!

 

My issue is not performance as the game is smooth and 30FPS with no stutters is good enought for me (I have put a limit of 30 FPS to avoid stutters and it works). I just don't get the quality and clarity of picture I would expect with these high settings (which I had unchanged since the first version of P3.

 

I'll experiment with nvidia control panel based on the FAQ. Thanks for that! See ya!

Share this post


Link to post
Share on other sites

I managed to resolve it by applying my trusted FSX Nhancer settings in both global and profile. It is all clear now.

 

For anyone interested the settings were based on Nick Needham's guide for FSX tuning found here:

 

http://www.simforums.com/forums/forum_posts.asp?TID=29041

 

The FAQ also helped a lot to set my CF3 config overrides etc. Thanks Unc!

Share this post


Link to post
Share on other sites

I too have found that running terrain over 3 causes flickering as you describe, all my other settings are on 5. I had not heard of nhancer before and will check it out as although terrain over 3 causes flickering it does not cause drop in fps.

Share this post


Link to post
Share on other sites

... OFF utilizes a single core, as CFS3 is old technology. A quad is not needed. ...

 

While the first point is certainly true, having extra cores DOES help if one uses a processor affinity tool (many free or demos available).

I have a quad and put all OS processes on the second core (cpu 3 and 4), run TIR4 and joystick on cpu 2, and sim on cpu 1 with high priority.

Nice boost in performance.

Share this post


Link to post
Share on other sites

I continue to have stuttering issues. After locking framerate to "32" I have seen some success. I am going to do some more testing tonight.

 

I have not thought about using affinity tools... and I think this is built into Vista and you don't need a 3rd party tool. I will try this tonight and see if this boosts my performance.

 

As for nHancer. Anyone else suggest using this tool (http://www.nhancer.com/)? Seems like the standard new nVidia drivers gives you all the flexibility you need, but maybe there are settings with this tool that would help.

Share this post


Link to post
Share on other sites
I have not thought about using affinity tools... and I think this is built into Vista and you don't need a 3rd party tool. I will try this tonight and see if this boosts my performance. ...

 

While you can set processor affinity in any version of Windows, you have to reset it every time on reboot. Also 3rd party utilities allow you to set process priority, and other optimizations such as "game mode" that tweak things that are a bit over my head. A very good one to try is Process Lasso HERE, which offers a demo that remains working and only adds a nag screen at start up when the demo period expires. I bough it subsequently for $8, and is well worth it.

Share this post


Link to post
Share on other sites

After some research, I found some people cautioning affinity in Vista. Or more precisely, don't mess with affinity and windows processes, but you can set affinity for other programs. Since OFF only runs on one processor, Vista doesn't give the option of selecting affinity.

 

So, I decided to leave it along and just monitor each CPU core performance. After defragging, messing with a few graphic settings, I think I have it running smoothly now. The 4 CPU cores don't ever seem to reach capacity (Vista seems to manage it well) and no more stuttering. I also have graphics on very high settings.... so things look good. I think limiting the framerate was the most important fix.

 

I do occasionally see tearing on the edges and some other graphic anomalies, so I will continue to tweak and test (I still need to try Nhancer)... but so far things are looking much better. I had a lot of fun flying last night. :)

Edited by tofu

Share this post


Link to post
Share on other sites

... I do occasionally see tearing on the edges and some other graphic anomalies, ...

 

Sounds like you need to enable v-sync if not already. Glad to hear things are better.

Share this post


Link to post
Share on other sites
Guest British_eh

Hi there:

 

I talked to POL about my loss of 20 FPS with the new HITR. Among other things he mentioned turning down in Workshop the Ground Object Density. I turned it down to low, and gained about 15 FPS, and it looks fine. I also put the slider from 5 3 4 5 5 to 5 3 3 3 5, and it is much better now.

 

Cheers,

 

British_eh

Share this post


Link to post
Share on other sites

Hi there:

 

I talked to POL about my loss of 20 FPS with the new HITR. Among other things he mentioned turning down in Workshop the Ground Object Density. I turned it down to low, and gained about 15 FPS, and it looks fine. I also put the slider from 5 3 4 5 5 to 5 3 3 3 5, and it is much better now.

 

Cheers,

 

British_eh

 

... And disable shadows.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.