Jump to content

Recommended Posts

Hi all,I seem to have developed a porblem with my control mapping.I am running SF2 combined with SF2E,SF2I and SF2V all patched to latest level.My joystick is a thrustmaster T.Flight Stick X and I am runnig on Windows XP.When I save a custom control set up it doesn't seem to change the joystick mapping even though the changes are visible as saved in the control folder.This has only recently started to happen any ideas anyone ?

Share this post


Link to post
Share on other sites

I had some similar issues on the last round of patches. try renaming your controls folder to "Xcontrols" or whatever works for you, and then restart the game and let it generate a whole new controls folder then go in and re-map to your liking.....on my set-up I have 2 different controls files one is the default and one is re-named and completely remapped to suit my homebuilt sim pit ....thing. Anyways when I did the april update the default control ini just refused to let me remap anything until I did what I explained earlier......thankfully my other custom ini wasnt bothered with the update, it's alot of work to remap EVERYTHING

Hope that works for you.

Share this post


Link to post
Share on other sites

I had some similar issues on the last round of patches. try renaming your controls folder to "Xcontrols" or whatever works for you, and then restart the game and let it generate a whole new controls folder then go in and re-map to your liking.....on my set-up I have 2 different controls files one is the default and one is re-named and completely remapped to suit my homebuilt sim pit ....thing. Anyways when I did the april update the default control ini just refused to let me remap anything until I did what I explained earlier......thankfully my other custom ini wasnt bothered with the update, it's alot of work to remap EVERYTHING

Hope that works for you.

 

nice set up ! I tried this but it failed to resolve the problem.The "new" control menu showed everything unmapped and would not recognise the control stick ...

Share this post


Link to post
Share on other sites

Are you running software for the stick or just running through windows?

Does windows recognize the stick in control panel?

Dx9 up to date?

I think if you are running dx9 you need to force the game to use dx9??? I think this is done in the options.ini? Maybe when you patch up, the file gets reverted back to stock.........just a thought, I am running dx10

Share this post


Link to post
Share on other sites

Are you running software for the stick or just running through windows?

Does windows recognize the stick in control panel?

Dx9 up to date?

I think if you are running dx9 you need to force the game to use dx9??? I think this is done in the options.ini? Maybe when you patch up, the file gets reverted back to stock.........just a thought, I am running dx10

 

stick is running through windows and no problems in control panel.DX9 is up to date as far as I am aware.I tried with FORCE DX set to true and it made no difference.Problem seems to be with thrust vector control.whatever i map thrust vector key as it changes weapon release to same key ????

Share this post


Link to post
Share on other sites

i think you had to install the Hotfix for the Control Mapping prior to the April Patch.

 

I did , anyone else got any ideas/solutions ??

Share this post


Link to post
Share on other sites

I did , anyone else got any ideas/solutions ??

 

hi there, i think i have resolved the issue, at least on my system (win7, t flight stick):

 

1) merged install (sf2, sf2v, sf2e, sf2i, exp1, exp2, sf2na), to get full march 2012 (no further patches) version;

2) key and joysick mapping at will (rename and backup your layout, just in case);

3) install mod (i tried with nf4, but it could work even with );

4) since the game at this point won't start (due to nf4 requiring latest patches, black screen on mission start), apply the full set (mar12hotfix, apr12, may12, jun12, jul12) of updates.

 

your key+stick mapping will be seen as the default one, but you won't be able to modify it due to updates deficiency (aug12 patch anyone?), so perform carefully step n°2.

 

since the last post is from june, i don't know if you ever solved the issue, if not, try this solution and good luck!

 

Will

Share this post


Link to post
Share on other sites

by chance, do any of you folks have the AircraftObject.ini residing someplace in you mods folders? If so, Try renaming it and see if the remapping holds.

Share this post


Link to post
Share on other sites

by chance, do any of you folks have the AircraftObject.ini residing someplace in you mods folders? If so, Try renaming it and see if the remapping holds.

 

i don't. you think this could be the problem?

anyway, i resolved reinstalling everything in that order, could be painful if you have an heavily modded game, but...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..