Jump to content
Sign in to follow this  
Dels

Squadron name not displaying on loadout screen

Recommended Posts

I'm a bit stumped. I am trying to get some additional squadron names to display on the loadout screen for the F-2A.

 

I have added a few extra squadrons to the Squadronlist.ini (the default already includes 8 Squadron JASDF).

 

Anyway, the TextureSet.ini files are correct and I have made sure that there's a fake DecalLevel=1 entry in the Decals.ini but the squadron names still won't show. Not even the default 8 Squadron will show.

 

I was wondering is there a requirement to activate a nation or something like that?

 

Dels

Edited by Dels

Share this post


Link to post
Share on other sites

you need:

a mention in the squadronlist.ini

a mention in the texture set and a decal level 1 mention in the decal ini

AND a level 1 decal for it to find in a decal folder.

 

this threw me off trying to get the Danes to show up for a bit as i worked on my uber squadronlist ini. btw have you tried the list in the realism mod thread? (yea shameless plug) did up some Hikotais in there as well as many other folks. working up the Dhimari AF right now and tryin to figure out who else to add....

 

anyhow hope this helps

Share this post


Link to post
Share on other sites

Thanks for the reply, but what exactly do you mean by this:

 

AND a level 1 decal for it to find in a decal folder.

 

Do you mean that one of the decals in the decal folder has to be called out by a level 1 entry in the Decals.ini?

 

Dels

Share this post


Link to post
Share on other sites

something like my 'fake sqtail' decal

 

try this one...unzip, drop in the root of the /Decals folder, and rewrite the path something like below:

 

[Decal010]

MeshName=RightOUterWing

DecalLevel=1

DecalFacing=bottom

FilenameFormat=Decals/SqTail

Position=-4.60,0.1278

Scale=0.00000001

DecalMaxLOD=1

 

what's cool, is you don't even need the correct mesh name!! (or you can attach it to any mesh that dosen' t thave anything on it, rudder, elevator, aileron, etc)

Share this post


Link to post
Share on other sites

for say,ESK 727, to appear in the loadout screen, i had to make a decal for 727. we'll say for sake of arguement its #609 in the squadonlist, and are adding a badge. you therefore need badge609.tga then all will show in the dropdown.

if you make all your marking on the skin itself, you can just list in the texturelist, but it will only show that squadron and greyed out at that.

Share this post


Link to post
Share on other sites

not necessarily! this one "fakes out the engine. as long as there's an entry in the squadronlist.in, this works. The game enigne seems to want to "look" for a 'SqTail.tga"

Share this post


Link to post
Share on other sites

shoot, brother, I"ve been using that fake SqTail for nearly a year!! (I was probably hiding in Korea!!!)

Share this post


Link to post
Share on other sites

Thanks for the suggestions guys, but it still doesn't seem to be working.

 

For every other aircraft I have done this to, all I had to do was:

 

1. Make a new entry in the SQUADRONLIST.ini

2. Make sure that the TextureSet.ini had the correct squadron name, and

3. Add this to the Decals.ini (replacing the XXX with the correct number):

 

[DecalXXX]

MeshName=flap_inner_left

DecalLevel=1

DecalFacing=TOP

FilenameFormat=

Position=0.0,0.0

Rotation=0.0

Scale=0.0

DecalMaxLOD=3

 

That is all. All those aircraft are working, it's just this one that's not.

 

What I have noticed is that all the main nations seem to work but new ones don't. I tried this with the JAS39/Sweden and had the same result: "None" in dark grey on the loadout screen.

 

I was just wondering if the nation had to be activated or something like that. For example, if you bought the DLC JASDF F-4s this would work and mine's not working because I haven't got that DLC.

 

Dels

Share this post


Link to post
Share on other sites

interesting thoughts bout the activation, again using Denmark and the F-104G, the stock skins are none in dk gray but the third party skin with a deal is fully up. will give your method a try later today on the stock skins to see how it works, given i would like to get them displayed in game for the lesser used NATO folks (Denmark, Norway)

Share this post


Link to post
Share on other sites

I don't have the DLC, but i do have all the squadrons from them (plus everything else included in the squadronlist that daddyairplanes mentioned), and they're showing up correctly on all my JASDF jets, even including custom decal sets for your old F-2. Texture set for that one looks like this in my case:

 

[TextureSet]

Name=8SQ

Nation=JAPAN

Squadron=8JASDF

Specular=0.300000

Glossiness=0.750000

Reflection=0.000000

DecalNumberRandomize=TRUE

 

It could be something really simple but easy to overlook, like the nation name or squadron name not matching up exactly to the entries in the nations.ini or squadronlist.ini. (Remember that the stock files use "JAPAN" as the nation name and not, say, "JASDF" for example.) Little things like that cause problems for me all the time.

Share this post


Link to post
Share on other sites

I don't have the DLC, but i do have all the squadrons from them (plus everything else included in the squadronlist that daddyairplanes mentioned), and they're showing up correctly on all my JASDF jets, even including custom decal sets for your old F-2. Texture set for that one looks like this in my case:

 

[TextureSet]

Name=8SQ

Nation=JAPAN

Squadron=8JASDF

Specular=0.300000

Glossiness=0.750000

Reflection=0.000000

DecalNumberRandomize=TRUE

 

It could be something really simple but easy to overlook, like the nation name or squadron name not matching up exactly to the entries in the nations.ini or squadronlist.ini. (Remember that the stock files use "JAPAN" as the nation name and not, say, "JASDF" for example.) Little things like that cause problems for me all the time.

 

Yes, that's what I thought at first. But I have spent the last 2 days checking and re-checking that.

The fact that you're not having any troubles leads me to beilieve that I must have missed something, but I'll keep looking.

 

Dels

Share this post


Link to post
Share on other sites

Ok. I have narrowed it down to the Squadronlist.ini.

 

I have been experimenting:

 

By changing the TextureSet.ini file's nation and squadron to USAF and 4TFS it shows up correctly on the loadout screen. (So it's not the TextureSet.ini or Decals.ini etc.)

So then I changed the squadron back to 3JASDF (nation still USAF and changed the Squadronlist.ini accordingly) and now it displays "None", with the dropdown box still available but the new squadron's name isn't there.

So then I changed the squadron to 3SQ with the nation as JAPAN (with appropriate changes also in the Squadronlist.ini) and we're back to a greyed out "None".

 

This is seriously doing my head in.

Share this post


Link to post
Share on other sites

interesting point, anyone notice that even in the stock list, Japan is all caps?

Dels, give this a try

 

 

 

its the one that works for WBS, hopefully it works for you.

Share this post


Link to post
Share on other sites

Thank you to everyone for your help but I AM SUCH AN IDIOT! :fool:

 

I was making all my changes to the Squadronlist.ini in the Flight folder and I didn't transfer it to the PilotData folder. :doh:

 

It's all working fine now.

 

In summary, to add a new squadron and have it selectable in the loadout screen:

 

1. Add the squadron to the Squadronlist.ini and copy this file to your PilotData folder.

2. Add the Squadron="Name" (where "Name" is the name from the Squadronlist.ini) to the applicable TextureSet.ini.

2. Add the entry below to the applicable Decals.ini:

 

[DecalXXX]

MeshName=flap_inner_left

DecalLevel=1

DecalFacing=TOP

FilenameFormat=

Position=0.0,0.0

Rotation=0.0

Scale=0.0

DecalMaxLOD=3

 

That is all.

 

Dels

Share this post


Link to post
Share on other sites

on a serious note tho Dels, finally tried it out on the stock RDAFSilver skin. imported folder and decal ini with entry just as you posted above. works like a charm, tho the <none> displays first due to no squadron being assigned in the textureset. will be using it to make squadrons available for the Realism mod if you have no probs. workload will be mine but the credit for the idea is all yours!

Share this post


Link to post
Share on other sites

Happy to help. I'm sure someone else came up with it initially, but I'll take the credit!

 

Dels

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..