Jump to content
Sign in to follow this  
stingray77

Does DLC require the latest game-version?

Recommended Posts

Hi - now that the TW store is online again, I am about to download TW's F-4N-DLC. But I am having second thoughts: I have SF2V and NA both on July 2012 and (seeing the trouble the latter updates brought) am more than happy with that. Will downloading and installing a DLC require the latest game-version - or (even worse) update the games "itself"?

Share this post


Link to post
Share on other sites

The DLC will update your sims to the latest patch level, which I have been perfectly happy with.  Be aware that your mods will be affected just like running a patch, so you will need to re-name your Mod Folder to zMods to prevent those files being altered.  Do a search for the method for installing the DLC without having it update your current patch level.  It is easily done, just I have not tried it myself.  In a recent thread it was covered at length.

Share this post


Link to post
Share on other sites

I seem to remember a thread about using  a second install to accomplish this . One game  at the current patch level and one at say July 2012, using the current patch level to install the DLC... and then porting it over to the July 2012 patch level game.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..