Jump to content

Recommended Posts

Folks, what makes my WWII plane climbs vertically like a rocket after leaving the runway? Is it an DATA.INI mess or what? Is there a fix? Cheers!

Share this post


Link to post
Share on other sites

There is a "game issue" regarding the take off behavior. I've concluded there is an invisible vertical waypoint that the AI aircraft target after take off. This causes the steep low speed AI climb outs you see after take off. Also,  there are things going on with the aircraft weight when under AI / autopilot control. If IIRC, the weight of the external loadout is ignored.

Having said that, there could be an FM issue as well. What airplane are you having issues with?

Share this post


Link to post
Share on other sites

sometimes I have opposite they barely lift off before runway ends lol....probably an ini issue. more often than not tho they lift off ok...unless base under attack

Edited by russouk2004

Share this post


Link to post
Share on other sites

Check the entry MaxPitchForAltitude= in the  [AIData]  section of the aircraft's Data.INI.

The stock figure from AircraftAIData.INI is (from memory) 15, which is  too high for WW2 aircraft. Try reducing it to 10 -12 for a WW2 fighter, and 8-10 for a WW2 bomber, and see if that fixes  the problem.

Share this post


Link to post
Share on other sites

Thanks guys! The plane is the YAP's Ki-43-III. I'll try the ini edit trick. Post results later.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..