Jump to content
Sign in to follow this  
Panama Red

Jan Tuma Flashing Buildings ?

Recommended Posts

I have been using Jan Tuma's fantastic Terrain mod ever since he released it for my FE1 game and I have had zero problems with it all this time (ATI 4890 vid card).

 

I recently got a Win7 64 bit PC and bought the FE2 game to play on it. When I installed Jan Tuma's Terrain mod, I instanly noticed that all his building that have courtyards in them "flash" where the courtyard is suppose to be.

 

It does not happen on my XP SP3 FE1 Jan Tuma terrain.

 

It does not happen on my Win 7 64 bit FE1 Jan Tuma terrain.

 

It does not happen on my XP SP3 FE2 Jan Tuma terrain.

 

It does happen on my Win7 64 bit FE2 Jan Tuma terrain.

 

Can anybody help me on how to stop the "flashing" in my Win7 64 bit FE2 game since it does not happen on any other combination ???

Share this post


Link to post
Share on other sites

Latest DX10 and vid card drivers? Its apparent his terrain is fine. So its seems to me a system problem.

Share this post


Link to post
Share on other sites

Dave72:

The really strainge part is that it happens on both my desktop Win7 64 bit ATI 4890's 10.6 drivers and on my laptop Win7 64 bit ATI 5870's 9.12 drivers.

 

Is there anyway to force the FE2 game to use the DX 9c drivers in the Win7 64 bit OS ???

Share this post


Link to post
Share on other sites

Get the same thing on My Win 7 64 FE2 install - needs some experimenting with the data.ini I would think.

 

I also remember the very same thing was happening when Green Hell was released with those type of buildings and Stary posted a tod fix (I think)

 

Im on an ATi card actually

 

 

for DX9 - Look in options.ini

 

 

[GraphicsOptions]

DisplayDeviceID=0

DisplayWidth=1280

DisplayHeight=1024

DisplayDepth=32

AspectRatio=1.250000

AntiAliasing=4

UseAdvancedShaders=1 <-----------may have to set this to 0

ForceDX9=FALSE <---------- change

ForceVSyncOff=FALSE

LensFlare=0

DetailLevel=4

ObjectDetail=2

ObjectTexture=3

CockpitTexture=3

CockpitMirrors=1

CockpitReflection=1

EffectsDetail=3

TerrainDetail=2

TerrainTexture=2

HorizonDistance=2

GroundObjectDensity=2

WaterDetail=2

CloudsDetail=2

Shadow=1

Share this post


Link to post
Share on other sites

There is an "Options".ini here:

 

C:/ Users/ name/ Saved Games/ ThirdWire/ FirstEagles2/ Options.ini

 

Open the Options.ini and change the line below

 

[GraphicsOptions]

DisplayDeviceID=0

DisplayWidth=1280

DisplayHeight=1024

DisplayDepth=32

AspectRatio=1.250000

AntiAliasing=0 <<-----------------I changed mine to 0

UseAdvancedShaders=0

ForceDX9=TRUE <<-------------- Change to True

ForceVSyncOff=FALSE

LensFlare=0

DetailLevel=4

ObjectDetail=2

ObjectTexture=3

CockpitTexture=0

CockpitMirrors=1

CockpitReflection=1

EffectsDetail=1

TerrainDetail=2

TerrainTexture=3

HorizonDistance=3

GroundObjectDensity=2

WaterDetail=2

CloudsDetail=2

Shadow=2

 

The Sim's default is DX10

 

 

Share this post


Link to post
Share on other sites

Migbuster:

You are correct. The original Green Hell 2 did have flashing buildings until a fix was posted. The interesting part is it must be a DX problem because the Win7 FE1 does not flash because it still uses the DX9c versus the DX10.

 

Now if I can just figure how to force the FE2 to use the DX9c in the Win7 OS until some one posts a fix for the DX10 problem.

Share this post


Link to post
Share on other sites

The options.ini they have posted is the way to go. It might cure the problem however you wont have any of the cool shaders. Its not so much a problem with the sim as opposed the way the vid card handle the shaders. I am using his terrain on a Win7 64 bit and a Nvidia 285 card with DX10 and I am not getting the flashing buildings. ATI cards have always been troublesome for the series.

 

 

Share this post


Link to post
Share on other sites

I recently got a Win7 64 bit PC and bought the FE2 game to play on it. When I installed Jan Tuma's Terrain mod, I instanly noticed that all his building that have courtyards in them "flash" where the courtyard is suppose to be.

 

 

 

 

 

Try out this:

 

http://combatace.com/files/file/10563-alternatice-solid-objects-setting-for-fe-tiles-by-jan-tuma/ (Use files: BLEND_SRC_ALPHA).

 

Unfortunately I shan't FE2 , so that it can't try out, nor optimise for FE2.

 

 

 

Jan :blink:

 

 

 

 

Share this post


Link to post
Share on other sites

Those data_inis do seem to sort out the flashing courtyards - thanks for that Jan :good:

 

 

If you use the Panama you will need to change the shader names for FE2

 

EffectShaderName=terTerrainEffect.fx

 

etc

Share this post


Link to post
Share on other sites

Jan Tuma:

Thank you, thank you, thank you. Switching out the original "BLEND_DST_ALPHA" for the alternate "BLEND_SRC_ALPHA" works perfectly. Now I will be able to enjoy your fantastic terrain with my FE2 game too.

 

 

 

 

Migbuster"

With Jan Tuma's alternate "BLEND_SRC_ALPHA" working in my FE2 game, I am not exactly sure what you are trying to tell me when you said that I need to change some other items, please explain.

 

Panama Red

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..