Jump to content
  • Announcements

    • Erik

      2019 Drive   05/31/2019

      Can you lend a hand?  GET STARTED TODAY
Sign in to follow this  
draken

Helios and why don't they fly correctly in the game engine

Recommended Posts

I have download quite a few helicopters for WOE WOV SF but they all come with gremlins. If i don't set the game mode to easy they do not fly straight nor hover. but they do some of craziest aerial ballet this side of a flying circus. So gentleman i ask you all is there a remedy to my current but most obvious problem? I thank you :salute:

Share this post


Link to post
Share on other sites

The issue is that it wasn't designed for helicopters so what you see is what you get, and that's the best they could have done given the limits that are hardcoded.

Share this post


Link to post
Share on other sites

Most choppers will fly on Normal or Easy FM, but not Hard FM due to the hardcoding by TK. After all, this basicly a Jet Sim even though the communuity has added choppers and prop planes.

Share this post


Link to post
Share on other sites

Well, try Marcfighters MI-8 with the hard data.ini :grin:

 

 

Hmmmmmm Marcfighters you say and a MI-8 even, well I'll give it shot.............. :good:

Share this post


Link to post
Share on other sites

Helios and why don't they fly correctly in the game engine.....?

 

Perhaps it's because you're not from Heliopolis?

Share this post


Link to post
Share on other sites
Guest HoneyFox

Mainly because of sharp change of plane's AOA and Sideslip Angle when the helo is hovering.

 

There are only Data Tables for AOA, but no one for Sideslip Angle, which will result to strange performance when the helicopter is hovering.

 

(In debug mode you can easily see that the Sideslip turns sharply from -180 to 180 or so when the helo's speed is near zero.)

 

 

Share this post


Link to post
Share on other sites

I had this kind of issue too, someone gave me the trick, and it fixed 95% of the weird movments of my helicopters.

 

1- Open your (helicopter)_DATA.INI

 

2- scroll down to this line:

[AircraftData]

...

>>EmptyInertia=8238.342,4678.712,12917.054

...

 

3- add a "0" before each decimal. For example:

EmptyInertia=82380.342,46780.712,129170.054

 

4- then save, and fly.

 

I don't know if it will help but for me it did :grin:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..