Jump to content
Sign in to follow this  
winson

AH-64 Apache model, work in SF1?

Recommended Posts


yes,there's been severla posts of that very subject ... I'd try a search "Apache helicopter in SF1" (with the quotes)

Share this post


Link to post
Share on other sites

I just tried it in SF1, it is works. All the .ini files need to re-save in ANSI format with notepad in order for it to work in SF1. SF2 use UNICODE format.

Everything work normally somehow except the background image for Hanger and Loading screen did not show up.

Share this post


Link to post
Share on other sites

I'm missing something I can't seem to make this work in sfp-1,, alittle help please.

Share this post


Link to post
Share on other sites

Yubba,

 

Make sure to convert the UNICODE files to ASCI.

Open the files AH-64A.ini and AH-64A_DATA.ini and "save as" ASCI

Edited by krfrge

Share this post


Link to post
Share on other sites

thank you for your timely response, is that opening the files with note pad and saving the setting I think I did that I'll double check,, and again thank you.

Share this post


Link to post
Share on other sites

Yubba,

 

Your hanger and loading files are TGAs and need to be converted to BMP for SF1 to be able to read them

Share this post


Link to post
Share on other sites

Yubba,

 

Your hanger and loading files are TGAs and need to be converted to BMP for SF1 to be able to read them

thanks I spent more time than I care to admit to on that and the cobra g and I'm still no farther now than I was yesterday,, I figured out the weapons editor ,, a word of warning the weapon editors here,, set off my malware and I had to dump them used up my daily allotment,,got an editor off site made a weapons file and still nothing..

Edited by yubba

Share this post


Link to post
Share on other sites

Yubba,

 

Your hanger and loading files are TGAs and need to be converted to BMP for SF1 to be able to read them

How too,, I got xp open properties on files no way to change format or it is beyond me,,I got tga files in the cobra g and it works except for weapons big time loss of time

Edited by yubba

Share this post


Link to post
Share on other sites

The .tga's need to be changed with a program like PhotoShop or any photo editing program that surports .tga. and .bmp's. Export as a .bmp. The main .ini for the AC needs to be edited from .tga's to .bmp's also.

WeaponsData.ini and the .dat file need to be in the weapons (if you don't have one, make one and it goes in the Objects folder) folder along with the .lod's for the weapons. Basically everything for the weapons to show has to match, year, Hardpoint specs. NationName. Also the format of each weapon folder has to be converted to SF1. I haven't looked at the download, but weapons for SF2 won't work in SF1with just a copy/ past into the weapons folder. If you haven't done it, download a SF 1 weapons pack and look at the .ini's in a folder, in some weapons packs the .lod's and .ini's are not in folders, there just clumped together in one folder, but look at a .ini.

Share this post


Link to post
Share on other sites

Thanks guys, for the help,, sorry that I'm all over the place in this thread,,I'm a moderate modder myself having worked on Janes ww2,,cfs2, il-2,,and the silent hunter series,,I had been flying IL-2 ,, and then I got that need for speed and I wasn't about to download C.U.P after getting hsfx to my likeing thought it be easier to blow the dust off sfp-1,, wov until I saw the heicopters,, my main gripe is the helicopters in the sfp-1 download section like the cobra g with it's weapons pack,,should have been good to go,, now that I got pointed in the right direction maybe i'll get the cobra armed,, again thanks for the help.. 

Edited by yubba

Share this post


Link to post
Share on other sites

question are the cobras in sfp-2 download ready to fly with no fuss in sfp-2 ????

Share this post


Link to post
Share on other sites

well, that experiment didn't work,, thought I could cross some data files,, ok next question is.. why don't the helicopters in sfp-1 downloads work properly,, I haven't downloaded a helicopter from here that had the weapons showed up, except for the mi-35 and with that chopper the main rotor won't turn,,the tow loach won't show up,, the huey's blowup on the runway,,and the only chopper that did fly right and had weapons was mi-8 and I got that off site,, alittle qaulity control goes a long way,,sorry,,had to vent alot work and reading trying to get a bird up..makes me cranky

Share this post


Link to post
Share on other sites

Are you sure you are not mixing SF2 download with SF1 game ? For sure Cobra/Loach/Lahatut is exported to game in two diferent  versions for SF2 and SF1. I used different exporter plugin, so SF2 mod will not show up in SF1.

SF1 cobra - I  think got different data.ini file than SF2. Few changes but still changes. But don't remember right now what exactly.

 

As for the rotors on other aircrafts.

look for line in _data.ini :

 

PropDiameter= [value] and change to lower number like 2, 3 or similiar.

 

And what is your game patch level ?

 

 

 

, alittle qaulity control goes a long way,,sorry,,had to vent alot work and reading trying to get a bird up..makes me cranky

Had to put some work for those helos to work also.  Sorry that you are disappointed.

But for me it looks like some instal  issue / ini conflict than corupted files.

Share this post


Link to post
Share on other sites

Sorry for the rant,, the answer is no. I have downloaded from the sfp-1 download only,, your cobra g and it's weapon pack got the weapons editor made that file and pasted it every where that I could think of where it might work and na da,,, plus the other chopper I spoke of earlier,,, if I wasn't such a rotor head I'd be happy with vast array of planes how I  do love that F-15E strike eagle man I need cigarette. wov, vietnam 84, patched 2008,, cobra g not seeing the weapons at all the soviet stuff weapons will load except machine guns,,, the Mi-35 the main rotor will not turn but all weapons will function

Edited by yubba

Share this post


Link to post
Share on other sites

Ok.. got Mi-35 main rotor to work,,, copied a few things from Mi-24 into the Data config,,, rotor radius who would of guessed it was at 17. something zeroed it out.. see I'm not that much of a noob here after all,, I had lost interest in sfp-1 when I got involved with IL-2 and was hanging around mission4today,

Share this post


Link to post
Share on other sites

a parade for me you shouldn't have,, I'd settle with a clear path on getting that cobra q tow job to work in sfp-1 that looks like alotta fun,,,the Mi-35 flies nicely though it needs alittle tweaking in the cockpit,,maybe swap it out with a harrier pit.

Share this post


Link to post
Share on other sites

well I got it to show  up in game,, but I'm on the run way with no pit,, or aircraft,,no sound or controls ,, but have hud,

Edited by yubba

Share this post


Link to post
Share on other sites

you know, all these difficulties would vanish if you'd evolve to SF2. Just saying

Share this post


Link to post
Share on other sites

It took me forever to evolve a thumb,,, and that means I would have to buy it ,, and I'm not sure my machine can run it..,, it does look nice,, heck I'd be happy just getting the weapons on the cobras .. 

Share this post


Link to post
Share on other sites

well I got a pit sitting on run way no sound no aircraft that's progress from last post.

Share this post


Link to post
Share on other sites

well at last more progress,,,there wasn't much mention of replaceing DDS files I guess that's why there is DDS version file folder tucked away in the ah-64a folder,,, well guys do not overwrite DDS files delete them and replace them with ones in the DDS version file but overwrite the config file,,, now I got functional chopper but it's white.

Share this post


Link to post
Share on other sites

plus the throttle control is tied into the collective control aka {thrust vector} so it flies like crap,,, the Mi-35 flies much better with seperate controls,, compare the Data files of the two,,, down at the engines data region of that file..tried to fix it no joy

Edited by yubba

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..