Jump to content
Sign in to follow this  
Dillon

How do you get Effects to work with 3rd party add-on aircraft in SF2: NA?

Recommended Posts

Can't seem to figure this out.  First off I'm using SF2: North Atlantic.   I created a MOD secondary setup from the original install.  I now have the Top Gun music working in the menus and the 3rd party Mirage Factory F-14's (with effects working).


 


Everything after this has been a disaster.  I first tried to get the A-6 3rd party aircraft package to work with no joy.  Reading the instructions it's asking for an A-6 LOD files that does not exist (from what I can find) in SF2: North Atlantic.  I gave up because without what it's asking for it won't work.


 


 


Next I installed successfully the great F/A-18E/F packages in SF2: NA but the effects don't work in the sim.  This should not be rocket science just move the effects files into the effects folder like I did the F-14 effect files.  The effects refuse to work in the sim for the F/A-18E/F.  I'm at a lose as to what's wrong here.


 


Last but not least I would love to get the 'Carrier Illumination' effects to work so I can see the carrier runway better at night when coming in for a landing.  These effects won't work either.  


 


 


What am I doing wrong here.  Thanks in advance for any help as this is very frustrating.  It seems some instructions were written for another version of SF2 versus the newer SF2: NA. help.gif.pagespeed.ce.mZGjc8Y3Cw.gif 


Share this post


Link to post
Share on other sites

What folder are you placing the effects in?  It should be under C:\Users\YourName\Saved Games\Thirdwire\SF2version\Effects

Edited by Fubar512

Share this post


Link to post
Share on other sites

What folder are you placing the effects in?  It should be under C:\Users\YourName\Saved Games\Thirdwire\SF2version\Effects

 

 

That's the folder I'm putting the effects in.  When I go into the sim it doesn't work.  For example 'EricJ's F/A-18E/F's work in the sim but the effects included with his package don't work.  I placed them in the folder you referenced.  Is there something different going on with the North Atlantic version?

Share this post


Link to post
Share on other sites

No, unless the effects that you're trying to use are not SF2 compliant.  But that doesn't explain the carrier illumination effects not working, because they were specifically written for SF2's DX10 shaders.

 

And BTW, all flavors of SF2 behave the same way, in as far as effects and models are concerned.  The only difference is patch level, and if you've installed SF2NA over earlier versions of SF2, you're patched up to at least that level.

 

You're obviously missing a step somewhere.

Share this post


Link to post
Share on other sites

You're obviously missing a step somewhere.

 

 

I've been moding sims for years by way of Flight Simulator so I know it's not rocket science.  Most SF2 add-ons have no instructions and/or assumes you know where things need to go.  Either that or they reference folders (not folder paths) assuming one has been around the SF2 environment since it's inception.  There are two key locations I found with my install and that's under x86 Program Files and under the User directory.  If (in the case of the Carrior Illumination MOD and F/A-18) the download has an effects folder within it you would the assume it goes in the \effects folder.  This was the case with the third party F-14 that worked on my end.  I can't imagine what would be different with the Carrior lights and F/A-18.  Again the F/A-18 actually works with no afterburner or mist over the body of the aircraft effect.  Carrior Illumination is just MIA.  :blackeye:

Edited by Dillon

Share this post


Link to post
Share on other sites

Well, I believe that you've just provided an answer.  You've probably double nested the files. 

 

For example, from the carrier illumination mod readme:

 

To install: Simply drag the contents of the zip file, which are the two folders, "effects and groundobject", into the mod (saved games) folder of the desired title. For example, using SF2NA, the default path would be "YOUR NAME/Saved Games/Thirdwire/StrikeFighters2 NorthAtlantic

 

That simply means exactly what is written, that you should drag the contents of the archive into the main directory.  That prevents nesting , that is, creating unwanted subfolders.  In your effects folder, there should be nothing other than files. There should be no subfolders.

 

As to your A-6 issue, the LOD files  are locked away inside the Objectdata002.cat file, which is locked to discourage piracy. However, the path statement for them is already in place in the A-6x.ini file. 

 

I suggest that you take some time and peruse the knowledge base.  It's a great way to spend an evening, and should greatly help you understand how this series works. 

 

 

Share this post


Link to post
Share on other sites

Well, I believe that you've just provided an answer.  You've probably double nested the files. 

 

For example, from the carrier illumination mod readme:

 

To install: Simply drag the contents of the zip file, which are the two folders, "effects and groundobject", into the mod (saved games) folder of the desired title. For example, using SF2NA, the default path would be "YOUR NAME/Saved Games/Thirdwire/StrikeFighters2 NorthAtlantic

 

That simply means exactly what is written, that you should drag the contents of the archive into the main directory.  That prevents nesting , that is, creating unwanted subfolders.  In your effects folder, there should be nothing other than files. There should be no subfolders. 

 

 

I already have an 'effects' folder under the root of my 'YOUR NAME/Saved Games/Thirdwire/StrikeFighters2 NorthAtlantic - MOD'  folder.   So in essence all the effects files go in the same 'Effects' folder which is what I did, there weren't any sub-folders.  I'm not understanding how anything different could be possible.

Edited by Dillon

Share this post


Link to post
Share on other sites

how about posting a screenshot of the SF2NA mods folder???

 

this, below, shows the innards of my /Effects folder

 

(edit: posted wrong picture before)

Edited by Wrench

Share this post


Link to post
Share on other sites

how about posting a screenshot of the SF2NA mods folder???

 

this, below, shows the innards of my /Effects folder

 

 

When I get home I'll send a screenshot.  Thanks for the help...  

Share this post


Link to post
Share on other sites

OK, the folder structure is wrong.  Everything should be in the Strikefighters2 NorthAtlantic folder.  That is what everyone refers to as the "mod" folder. Move all the folders that are currently in your "Strikefighters2 NorthAtlantic-mod" folder,  up one level, into the Strikefighters2 NorthAtlantic folder, and all should be fine.

Edited by Fubar512

Share this post


Link to post
Share on other sites

OK, the folder structure is wrong.  Everything should be in the Strikefighters2 NorthAtlantic folder.  That is what everyone refers to as the "mod" folder. Move all the folders that are currently in your "Strikefighters2 NorthAtlantic-mod" folder,  up one level, into the Strikefighters2 NorthAtlantic folder, and all should be fine.

 

 

I'm really confused :blackeye: :

 

 

When trying to get the Top Gun music to play in the sim I had to do what's outlined in the YouTube video.

Share this post


Link to post
Share on other sites

I'm really confused :blackeye: :

 

 

That's really only applicable if you're creating a separate install, for say, the Korean Air War Mod (etc.). It is not something that you need to do in your case.

Read this: http://combatace.com/topic/62302-what-is-the-mod-folder/

Edited by Fubar512

Share this post


Link to post
Share on other sites

your folder structure on left should look like the one on right


options.ini in main mod folder ,bottom of ini...should also point to so...or whatever path you have

[Mods]
ModsEnabled=TRUE
Directory=C:\Users\your name here\Saved Games\ThirdWire\StrikeFighters2 NorthAtlantic
Editors=StrikeFighters2

[screenShots]
Directory=C:\Users\your name here\Saved Games\ThirdWire\StrikeFighters2 NorthAtlantic
Format=JPG

post-1981-0-55385400-1415924578_thumb.jpg

Share this post


Link to post
Share on other sites

Taking everything out of the MOD's install did nothing but break my menu music and brought back the default music.  I put everything back and tried the 'options.ini' MOD you mentions. That did nothing as well. Loading up the F/A-18F add-on aircraft showed that the effects (afterburners, mist over fuselage) were still not present.  The deck lights did not show up.  :blackeye:

Share this post


Link to post
Share on other sites

Post a screen capture of your present folder structure.

 

 

I put it back to what I posted above (the screenshot above).

Share this post


Link to post
Share on other sites

you have either wrong path in your options.ini...

or folders wrong order...heres mine...My mod folder on 2nd HDD  but same applies...if you have it as mine,apart from the different path... theres no reason it wont work

 

[Mods]
ModsEnabled=TRUE
Directory=D:\Games\Strikefighters2\Great Britain
Editors=StrikeFighters2

[screenShots]
Directory=D:\Games\Strikefighters2\Great Britain\ScreenShots
Format=JPG

post-1981-0-20291100-1415932468_thumb.jpg

Share this post


Link to post
Share on other sites

Based on yours here's mine:

 

 
[Mods]
ModsEnabled=TRUE
Directory=C:\Users\Leo\Saved Games\ThirdWire\StrikeFighters2 NorthAtlantic - Mod
Editors=StrikeFighters2
 
[screenShots]
Directory=C:\Users\Leo\Saved Games\ThirdWire\StrikeFighters2 NorthAtlantic - Mod\ScreenShots
Format=JPG

Share this post


Link to post
Share on other sites

Dillon,

 

You're spinning your wheels and confusing yourself.  The last two statements in the options.ini should read like so:

 

[Mods]
ModsEnabled=TRUE
Directory=C:\Users\Leo\Saved Games\ThirdWire\StrikeFighters2 NorthAtlantic
Editors=StrikeFighters2

 

[screenShots]
Directory=C:\Users\Leo\Saved Games\ThirdWire\StrikeFighters2 NorthAtlantic\ScreenShots
Format=JPG

 

After you edit the two statements to match the above, move all the files and folders you've created into the main StrikeFighters2 NorthAtlantic folder and delete the "StrikeFighters2 NorthAtlantic - Mod" folder. 

Share this post


Link to post
Share on other sites

Dillon,

 

You're spinning your wheels and confusing yourself.  The last two statements in the options.ini should read like so:

 

[Mods]

ModsEnabled=TRUE

Directory=C:\Users\Leo\Saved Games\ThirdWire\StrikeFighters2 NorthAtlantic

Editors=StrikeFighters2

 

[screenShots]

Directory=C:\Users\Leo\Saved Games\ThirdWire\StrikeFighters2 NorthAtlantic\ScreenShots

Format=JPG

 

After you edit the two statements to match the above, move all the files and folders you've created into the main StrikeFighters2 NorthAtlantic folder and delete the "StrikeFighters2 NorthAtlantic - Mod" folder. 

 

 

I told you a few posts above that I did exactly what your stating here and it didn't work that's why I put everything back.  That's why I edited this file to reflect where everything is at.  The only thing that happened with moving the files back to the original folder was my menu must went back to default.

Share this post


Link to post
Share on other sites

Dillon,

 

You're spinning your wheels and confusing yourself.  The last two statements in the options.ini should read like so:

 

 

I just wanted to say I appreciate all your help so I hope I didn't come across the wrong way in my last post.  It's just very frustrating to see the add-on F-14 work without issue and the other MOD's not function properly.

Share this post


Link to post
Share on other sites

I told you a few posts above that I did exactly what your stating here and it didn't work that's why I put everything back.  That's why I edited this file to reflect where everything is at.  The only thing that happened with moving the files back to the original folder was my menu must went back to default.

 

I typed this up last night while watching the news and got frustrated on two fronts.  To explain this in a more reasonable manner here goes.

 

Correction:

 

A few posts above I did exactly what you suggested.  I moved all files back to the default folder and found the only thing that changed was my menu music went back to the default setting (thanks to a Mod here I have Top Gun's music playing in the background in the menu area).  Seeing none of the effects worked with your suggested change I opted to put things back the way I had them as the 'mod' install seems to be good for something.  I changed the 'options.ini' entry to reflect where everything is located on my end meaning paths point to the 'mod' install.  If you have anymore suggestions let me know but understand your suggestion above didn't resolve the issue.  It seems to be a no brainer that putting effects in the effects folder is basically all that needs to be done no matter what path your using (default or mod location).  That being said what else could be at play here?  Why is editing of '.ini' files needed on individual cases and if it is needed why don't add-on makers put this information in their install instructions? 

Edited by Dillon

Share this post


Link to post
Share on other sites

your best bet is to ...move the stuff to a new folder...delete all the folders apart from the Thirdwire folder in your users\saved games folder...recreate the folders by running the exe again and move each folder into correct place and try again ?

Share this post


Link to post
Share on other sites

your best bet is to ...move the stuff to a new folder...delete all the folders apart from the Thirdwire folder in your users\saved games folder...recreate the folders by running the exe again and move each folder into correct place and try again ?

 

 

I uninstalled and reinstalled the whole game and the same issue is present.  I'd love to do a join me session to show you this.  

 

Is it possible to use add-on aircraft in campaigns?  When I go into campaign mode I don't see the extra aircraft I've added.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..