Jump to content

Recommended Posts

I can't get the damn fade distance mod to work. I re read and re read the fading mod thread until my head started to hurt. I just don't get it. the damn cities still pop up too close and I used Hecks settings in that thread.

 

Think its time to retire SF2. Its becoming too taxing and WIN10 ruined the smooth graphics I enjoyed before I upgraded to WIN10 on top the WIN8.1 I had.

 

Anyway if you guys have tips to get the cities to pop up in distance I'll appreciate it.

 

Falcon

Share this post


Link to post
Share on other sites

Falcon you did set the ObjectsFade=FALSE in options.ini? They have to be set to false for the extra fading shaders actually do their work

Share this post


Link to post
Share on other sites

FalconC45, would you please attach your FLIGHTENGINE.INI and ENVIRONMENTSYSTEM.INI files for us to look at? Also are you using any terrain mods and if so which ones?

 

Edit:What Stary said also.

Edited by KJakker

Share this post


Link to post
Share on other sites

Falcon you are not alone...Ive been modding this game since 2004 and i cant get it to work either. Really hoping you get it sorted out.

Share this post


Link to post
Share on other sites

Wait a sec, the thread said NOTHING about environment.ini tweaking. I tweaked the flightengine.ini AND the two .fx files mentioned in the thread.Falcon

 

Falcon you did set the ObjectsFade=FALSE in options.ini? They have to be set to false for the extra fading shaders actually do their work

 

 

Stary yes I did.

Share this post


Link to post
Share on other sites

I ask about the ENVIRONMENTSYSTEM.INI in case there was something in it that could be interfering. Make sure that the SkyDistance= in the environmentsystem.ini is greater than the FarClipDistance= in the flightengine.ini.

 

Just to check, did you put the .fx files into every single one of your terrain folders?

 

Next what are the settings you are using in your flightengine.ini? The ones below are what I am presently using. 

 

[backgroundSceneClip]
/FarClipDistance=240000.0
FarClipDistance=160000.0
NearClipDistance=3000.0
 
[ForegroundSceneClip]
FarClipDistance=14000.0
NearClipDistance=0.45
 
[insideSceneClip]
FarClipDistance=250.0
NearClipDistance=0.01
 
[LowDetailOption]
//HorizonDistance=30000.0
/HorizonDistance=90000.0
HorizonDistance=60000.0
/DetailMeshSize=6
DetailMeshSize=9
DetailLevel=0
WaterEffect=0
NoiseTexture=0
MaxTextureRes=128
 
[MedDetailOption]
/HorizonDistance=42000.0
//HorizonDistance=126000.0
HorizonDistance=84000.0
/DetailMeshSize=6
DetailMeshSize=9
DetailLevel=1
WaterEffect=1
NoiseTexture=0
MaxTextureRes=256
 
[HighDetailOption]
/HorizonDistance=50000.0
//HorizonDistance=150000.0
HorizonDistance=100000.0
/DetailMeshSize=9
DetailMeshSize=14
DetailLevel=2
WaterEffect=2
NoiseTexture=1
MaxTextureRes=512
 
[unlimitedDetailOption]
/HorizonDistance=62000.0
//HorizonDistance=186000.0
HorizonDistance=124000.0
DetailMeshSize=18
DetailLevel=2
WaterEffect=2
NoiseTexture=1
MaxTextureRes=-1

Share this post


Link to post
Share on other sites

 

 

I ask about the ENVIRONMENTSYSTEM.INI in case there was something in it that could be interfering. Make sure that the SkyDistance= in the environmentsystem.ini is greater than the FarClipDistance= in the flightengine.ini.

 

Just to check, did you put the .fx files into every single one of your terrain folders?

 

Next what are the settings you are using in your flightengine.ini? The ones below are what I am presently using. 

 

[backgroundSceneClip]

/FarClipDistance=240000.0

FarClipDistance=160000.0

NearClipDistance=3000.0

 

[ForegroundSceneClip]

FarClipDistance=14000.0

NearClipDistance=0.45

 

[insideSceneClip]

FarClipDistance=250.0

NearClipDistance=0.01

 

[LowDetailOption]

//HorizonDistance=30000.0

/HorizonDistance=90000.0

HorizonDistance=60000.0

/DetailMeshSize=6

DetailMeshSize=9

DetailLevel=0

WaterEffect=0

NoiseTexture=0

MaxTextureRes=128

 

[MedDetailOption]

/HorizonDistance=42000.0

//HorizonDistance=126000.0

HorizonDistance=84000.0

/DetailMeshSize=6

DetailMeshSize=9

DetailLevel=1

WaterEffect=1

NoiseTexture=0

MaxTextureRes=256

 

[HighDetailOption]

/HorizonDistance=50000.0

//HorizonDistance=150000.0

HorizonDistance=100000.0

/DetailMeshSize=9

DetailMeshSize=14

DetailLevel=2

WaterEffect=2

NoiseTexture=1

MaxTextureRes=512

 

[unlimitedDetailOption]

/HorizonDistance=62000.0

//HorizonDistance=186000.0

HorizonDistance=124000.0

DetailMeshSize=18

DetailLevel=2

WaterEffect=2

NoiseTexture=1

MaxTextureRes=-1

Yeah I put the .fx files in every terrain folder. I'll put the ini's in this thread tomorrow. I'm just drained mentally tonight.

 

Falcon

Share this post


Link to post
Share on other sites

Also for one in a million chnace put the shaders also into root terrains folder.

 

Another question Falcon, is the modded folder in the (mostly usual) username/saved games/ or on other drive?

Share this post


Link to post
Share on other sites

Okay, I just tried this out. Below are two pairs of screenshots taken in the same single mission in SF2 comparing my Windows 7 desktop and a Windows 10 laptop both with Mue's distance fix in place. Detail setting in game us Unlimited.
 

EnvironmentSystem.ini Sky setting used.

 

[sky]

SkyDistance=250000
////SkyDistance=180000
///SkyDistance=95000
//140000
//70000 default
SkyHeightPosition=-500
//0 default
SkyPanelCount=9
//9
SkyPanelHeight=35000
//25000.0 works juuust fine
//50000.0
//15000.0 default
HorizonVertexHeight=0.025
//0.025 default
SkyMaterial=SkyMaterial
HorizonCloud=HorizonCloud

HorizonCloudTexture=HorizonCloud%d%d.tga

 

 

FlightEngine.ini Scene Clip and Detail Option settings used.

 

[backgroundSceneClip]
FarClipDistance=240000.0
NearClipDistance=3000.0

[ForegroundSceneClip]
FarClipDistance=14000.0
NearClipDistance=0.45

[insideSceneClip]
FarClipDistance=250.0
NearClipDistance=0.01

[LowDetailOption]
HorizonDistance=90000.0
DetailMeshSize=9
DetailLevel=0
WaterEffect=0
NoiseTexture=0
MaxTextureRes=128

[MedDetailOption]
HorizonDistance=126000.0
DetailMeshSize=9
DetailLevel=1
WaterEffect=1
NoiseTexture=0
MaxTextureRes=256

[HighDetailOption]
HorizonDistance=150000.0
DetailMeshSize=14
DetailLevel=2
WaterEffect=2
NoiseTexture=1
MaxTextureRes=512

[unlimitedDetailOption]
HorizonDistance=186000.0
DetailMeshSize=18
DetailLevel=2
WaterEffect=2
NoiseTexture=1
MaxTextureRes=-1

 

 

Windows 7 Desktop
post-56847-0-07663000-1467224883_thumb.jpg
 
Windows 10 Laptop
post-56847-0-12288200-1467224899_thumb.jpg
 
Windows 7 Desktop
post-56847-0-57807200-1467224892_thumb.jpg
 
Windows 10 Laptop
post-56847-0-25547700-1467224908_thumb.jpg

Share this post


Link to post
Share on other sites

@FalconC45: Could you please post your options.ini, flightengine.ini and the fx files.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..