Jump to content
GKABS

Game does not support more than one texture per model

Recommended Posts

Please, can someone confirm to me that the game does not support more than one texture per model?  From what I read that's what I came out with and that's what I was doing all along, so my question is does anyone know of a software that will take the textures and combined them as one texture for more than one model.

 

Share this post


Link to post
Share on other sites

I absolutely do not confirm that. Even stock SF2 objects use more textures for each 3d model.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Menrva said:

I absolutely do not confirm that. Even stock SF2 objects use more textures for each 3d model.

Sorry for not making my self clear, what I meant is if I apply 2 texture for the same model which is consists of two models but I want to attach them as one. instead of parents and children.  in the game, they will show as a green color when I attache them.

For example, this model consists of 3 separated models as I have a texture for each one I was thinking of using the multi / sub-Object for the material, but I never got it to work. that is why I was asking for a software to combine all the texture is one

Annotation 2019-10-15 194025.png

Annotation 2019-10-15 193913.png

Annotation 2019-10-15 193940.png

Edited by GKABS

Share this post


Link to post
Share on other sites
21 minutes ago, swambast said:

No - the game engine does NOT support Multi-Sub object texturing.

Thank you:good:

Share this post


Link to post
Share on other sites

one time I had one mesh using 2 textures...what I did was select the polys of mesh used 2nd texture on them and didnt deselect polys...and exported the model did have the polys area still using the 2nd texture...not sure if it still works with the latest exporter tho

  • Like 1

Share this post


Link to post
Share on other sites
28 minutes ago, russouk2004 said:

one time I had one mesh using 2 textures...what I did was select the polys of mesh used 2nd texture on them and didnt deselect polys...and exported the model did have the polys area still using the 2nd texture...not sure if it still works with the latest exporter tho

Thank russouk, I will try that :good:

Share this post


Link to post
Share on other sites

I tried it russouk, but no luck. :stars: that is okay I will just try to find a texture atlas to compile all the texture as one and work my way from there.

 

Share this post


Link to post
Share on other sites

I just found what I was looking for and I thought of sharing it with you all.:drinks:

 

Share this post


Link to post
Share on other sites

This is a test result of 3 parts model now one model and one texture. (UVW is not the best but this is a test lol)

 

Annotation 2019-10-16 190403.png

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, russouk2004 said:

odd shapes are a pain when making textures eh lol

Yes your are correct, it's a Pain in the ...  :stars:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use, Privacy Policy, and We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue..